aboutsummaryrefslogtreecommitdiff
path: root/java/sablevm/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-04-04 12:59:53 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-04-04 12:59:53 +0000
commit389cde614a5674be42922eca4d800f63da3173c3 (patch)
treedb2caedafd0950f4590dbff65111591019785516 /java/sablevm/Makefile
parent5fa5b0a327bbdea900d0d540c4211ad2bdf556db (diff)
downloadports-389cde614a5674be42922eca4d800f63da3173c3.tar.gz
ports-389cde614a5674be42922eca4d800f63da3173c3.zip
- Adapt for new libffi, and various fixes
PR: ports/122399 Submitted by: Bjoern Koenig <bkoenig@alpha-tierchen.de> (maintainer)
Notes
Notes: svn path=/head/; revision=210497
Diffstat (limited to 'java/sablevm/Makefile')
-rw-r--r--java/sablevm/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/java/sablevm/Makefile b/java/sablevm/Makefile
index 603230613baf..ceae27ca526e 100644
--- a/java/sablevm/Makefile
+++ b/java/sablevm/Makefile
@@ -7,8 +7,8 @@
PORTNAME= sablevm
PORTVERSION= 1.13
-PORTREVISION= 1
-CATEGORIES= java
+PORTREVISION= 2
+CATEGORIES= java devel
MASTER_SITES= SF
MAINTAINER= bkoenig@alpha-tierchen.de
@@ -20,9 +20,13 @@ LIB_DEPENDS= popt:${PORTSDIR}/devel/popt \
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libltdl
USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_ICONV= yes
USE_LDCONFIG= yes
-CONFIGURE_ENV= CFLAGS="-I${PREFIX}/include -L${PREFIX}/lib -I${LOCALBASE}/include -L${LOCALBASE}/lib"
+USE_GNOME= pkgconfig
+PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include `${PKG_CONFIG} libffi --cflags`" LDFLAGS="-L${LOCALBASE}/lib"
OPTIONS= SVMCP "Install SableVM classpath" ON \
MAN "Build and install man pages" ON
@@ -32,12 +36,11 @@ CONFLICTS= classpath-*
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_SVMCP)
-RUN_DEPENDS+= ${LOCALBASE}/share/sablevm-classpath/java/lang/Object.class:${PORTSDIR}/java/sablevm-classpath
+RUN_DEPENDS+= ${LOCALBASE}/lib/sablevm-classpath/libjavalang.so:${PORTSDIR}/java/sablevm-classpath
.endif
.if !defined(WITHOUT_MAN)
MAN1= java-sablevm.1 sablevm.1
-.else
.endif
post-extract: