aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2008-08-19 23:18:36 +0000
committerGreg Lewis <glewis@FreeBSD.org>2008-08-19 23:18:36 +0000
commit582d67b410e45602807f37bf0e20fd522b31b033 (patch)
tree61e46fcd3c070a286dd191a662c84e41a49478bd /java
parentd9aa6f5324e7b3537527baa181f944e80044b30c (diff)
downloadports-582d67b410e45602807f37bf0e20fd522b31b033.tar.gz
ports-582d67b410e45602807f37bf0e20fd522b31b033.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/diablo-jdk15/Makefile12
-rw-r--r--java/diablo-jre15/Makefile15
2 files changed, 18 insertions, 9 deletions
diff --git a/java/diablo-jdk15/Makefile b/java/diablo-jdk15/Makefile
index e415bad0b71a..ad7000be2431 100644
--- a/java/diablo-jdk15/Makefile
+++ b/java/diablo-jdk15/Makefile
@@ -79,12 +79,11 @@ PLIST_SUB+= CLIENTVM="@comment "
.endif
.if (!exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) || (!defined(WITHOUT_TZUPDATE) && !exists(${DISTDIR}/${TZUPDATEFILE}))) && !defined(PACKAGE_BUILDING) && defined(JDK_OSREL)
-ECHO_MSG=/usr/bin/printf
-IGNORE= :\n\
+DISTFILE_INSTRUCTIONS=\n\
Because of licensing restrictions, you must fetch the distribution\n\
manually.\n\n
.if (!exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}))
-IGNORE += Please access\n\
+DISTFILE_INSTRUCTIONS += Please access\n\
\n\
${DOWNLOAD_URL}\n\
\n\
@@ -93,13 +92,18 @@ with a web browser and \"Accept\" the End User License Agreement for\n\
${DISTNAME}${EXTRACT_SUFX} in ${DISTDIR}.\n\n
.endif
.if !defined(WITHOUT_TZUPDATE) && !exists(${DISTDIR}/${TZUPDATEFILE})
-IGNORE += Please open http://java.sun.com/javase/downloads/index.jsp\n\
+DISTFILE_INSTRUCTIONS += Please open http://java.sun.com/javase/downloads/index.jsp\n\
in a web browser and follow the \"Download\" link for\n\
\"JDK US DST Timezone Update Tool - ${TZUPDATE_VERSION}\" to obtain the\n\
time zone update file, ${TZUPDATEFILE}.\n\n
.endif
.endif
+pre-fetch:
+.if defined(DISTFILE_INSTRUCTIONS)
+ @printf "${DISTFILE_INSTRUCTIONS}"
+ @exit 1
+.endif
.if !defined(WITHOUT_TZUPDATE)
post-extract:
diff --git a/java/diablo-jre15/Makefile b/java/diablo-jre15/Makefile
index 51ac3bb9a6ab..a5136bfb82bc 100644
--- a/java/diablo-jre15/Makefile
+++ b/java/diablo-jre15/Makefile
@@ -79,12 +79,11 @@ PLIST_SUB+= CLIENTVM="@comment "
.endif
.if (!exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) || (defined(WITH_TZUPDATE) && !exists(${DISTDIR}/${TZUPDATEFILE}))) && !defined(PACKAGE_BUILDING) && defined(JRE_OSREL)
-ECHO_MSG=/usr/bin/printf
-IGNORE= :\n\
+DISTFILE_INSTRUCTIONS=\n\
Because of licensing restrictions, you must fetch the distribution\n\
-manually.\n
+manually.\n\n
.if (!exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}))
-IGNORE += Please access\n\
+DISTFILE_INSTRUCTIONS += Please access\n\
\n\
${DOWNLOAD_URL}\n\
\n\
@@ -93,13 +92,19 @@ with a web browser and \"Accept\" the End User License Agreement for\n\
${DISTNAME}${EXTRACT_SUFX} in ${DISTDIR}.\n\n
.endif
.if defined(WITH_TZUPDATE) && !exists(${DISTDIR}/${TZUPDATEFILE})
-IGNORE += Please open http://java.sun.com/javase/downloads/index.jsp\n\
+DISTFILE_INSTRUCTIONS += Please open http://java.sun.com/javase/downloads/index.jsp\n\
in a web browser and follow the \"Download\" link for\n\
\"JDK US DST Timezone Update Tool - ${TZUPDATE_VERSION}\" to obtain the\n\
time zone update file, ${TZUPDATEFILE}.\n\n
.endif
.endif
+pre-fetch:
+.if defined(DISTFILE_INSTRUCTIONS)
+ @printf "${DISTFILE_INSTRUCTIONS}"
+ @exit 1
+.endif
+
.if defined(WITH_TZUPDATE)
post-extract:
@${UNZIP_CMD} -qo ${DISTDIR}/${TZUPDATEFILE} -d ${WRKDIR}