aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2010-06-10 06:20:29 +0000
committerGreg Lewis <glewis@FreeBSD.org>2010-06-10 06:20:29 +0000
commit58ac91985ef2e25c6f659c6addbc2086a135e8a6 (patch)
tree59aa7d30862b97b488f5badc1669f8fa4ab16a55 /java
parent85daf4662a6245a880c1062460d1f0f1be8add53 (diff)
downloadports-58ac91985ef2e25c6f659c6addbc2086a135e8a6.tar.gz
ports-58ac91985ef2e25c6f659c6addbc2086a135e8a6.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-devel/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/java/eclipse-devel/Makefile b/java/eclipse-devel/Makefile
index 71d63c5e5ef5..9686618db21d 100644
--- a/java/eclipse-devel/Makefile
+++ b/java/eclipse-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= eclipse-devel
PORTVERSION= 3.5.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= java devel
MASTER_SITES= http://download.eclipse.org/technology/linuxtools/eclipse-build/:1 \
http://download.eclipse.org/tools/orbit/downloads/drops/R20090825191606/bundles/:2 \
@@ -208,8 +208,16 @@ do-install:
${BUILD_WRKSRC}/eclipse.tmp
.endif
@${INSTALL_SCRIPT} ${WRKSRC}/eclipse.tmp ${PREFIX}/bin/${PORTNAME}
- @cd ${BUILD_WRKSRC}/bundles && \
- ${COPYTREE_SHARE} . ${PORTDESTDIR}/plugins/
+ @for f in `ls ${BUILD_WRKSRC}/bundles/*.jar`; do \
+ BASE=`basename $$f`; \
+ FILES=`find ${PORTDESTDIR}/plugins/ -name "$$BASE"`; \
+ if [ ! -z "$$FILES" ]; then \
+ for s in $$FILES; do \
+ ${RM} "$$s"; \
+ ${INSTALL_DATA} "$$f" "$$s"; \
+ done; \
+ fi; \
+ done
@${PREFIX}/bin/${PORTNAME} -initialize -consolelog
-@update-desktop-database
@(cd ${PREFIX}; ${FIND} -s lib/${PORTNAME} -not -type d) >> ${TMPPLIST}