aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2006-02-12 00:28:23 +0000
committerGreg Lewis <glewis@FreeBSD.org>2006-02-12 00:28:23 +0000
commit5954b07aaae8015f2574e8e5919aa57163e356cc (patch)
tree53d0a36773baa3308e2a12d32315442886690a41 /java
parent4120e2717e941a0721fa2dc388f8c271aa8d1e6a (diff)
. Link with the system libz instead of building the our own internal
copy. This should have the following effects: . Fix problems experienced by programmes that dynamically create their own copy of the JVM and are linked against the system's zlib (e.g., eclipse). . Reduce the potential for zlib based security problems affecting the JDK. This is similar to the patch in the PR, but was actually backported from the patches for the jdk15 port, so its a touch different. PR: 92459
Notes
Notes: svn path=/head/; revision=155803
Diffstat (limited to 'java')
-rw-r--r--java/jdk14/Makefile2
-rw-r--r--java/jdk14/files/patch-j2se::zip::FILES_c.gmk18
-rw-r--r--java/jdk14/files/patch-j2se::zip::Makefile31
3 files changed, 50 insertions, 1 deletions
diff --git a/java/jdk14/Makefile b/java/jdk14/Makefile
index 1203fc6bde45..14ba2e837e49 100644
--- a/java/jdk14/Makefile
+++ b/java/jdk14/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jdk
PORTVERSION= ${JDK_VERSION}p${JDK_PATCHSET_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= java devel
MASTER_SITES= # http://www.sun.com/software/java2/download.html
# http://www.eyesbeyond.com/freebsddom/java/jdk14.html
diff --git a/java/jdk14/files/patch-j2se::zip::FILES_c.gmk b/java/jdk14/files/patch-j2se::zip::FILES_c.gmk
new file mode 100644
index 000000000000..dfe676c5b80a
--- /dev/null
+++ b/java/jdk14/files/patch-j2se::zip::FILES_c.gmk
@@ -0,0 +1,18 @@
+--- ../../j2se/make/java/zip/FILES_c.gmk.orig Wed Sep 10 19:43:01 2003
++++ ../../j2se/make/java/zip/FILES_c.gmk Sat Feb 11 00:55:54 2006
+@@ -8,15 +8,4 @@
+ $(CTARGDIR)Inflater.c \
+ $(CTARGDIR)ZipFile.c \
+ $(CTARGDIR)ZipEntry.c \
+- $(CTARGDIR)zadler32.c \
+- $(CTARGDIR)zcrc32.c \
+- $(CTARGDIR)deflate.c \
+- $(CTARGDIR)trees.c \
+- $(CTARGDIR)zutil.c \
+- $(CTARGDIR)inflate.c \
+- $(CTARGDIR)infblock.c \
+- $(CTARGDIR)inftrees.c \
+- $(CTARGDIR)infcodes.c \
+- $(CTARGDIR)infutil.c \
+- $(CTARGDIR)inffast.c \
+ $(CTARGDIR)zip_util.c
diff --git a/java/jdk14/files/patch-j2se::zip::Makefile b/java/jdk14/files/patch-j2se::zip::Makefile
new file mode 100644
index 000000000000..ed15182c29cc
--- /dev/null
+++ b/java/jdk14/files/patch-j2se::zip::Makefile
@@ -0,0 +1,31 @@
+--- ../../j2se/make/java/zip/Makefile.orig Wed Sep 10 19:43:01 2003
++++ ../../j2se/make/java/zip/Makefile Sat Feb 11 00:55:54 2006
+@@ -12,8 +12,6 @@
+ PRODUCT = sun
+ include $(BUILDDIR)/common/Defs.gmk
+
+-ZLIB_VERSION = 1.1.3
+-
+ #
+ # Files to compile.
+ #
+@@ -58,13 +56,6 @@
+ CPPFLAGS += -UDEBUG
+ endif
+
+-CPPFLAGS += -I$(SHARE_SRC)/native/java/util/zip/zlib-$(ZLIB_VERSION)
+-
+-#
+-# Add to ambient vpath so we pick up the library files
+-#
+-vpath %.c $(SHARE_SRC)/native/$(PKGDIR)/zlib-$(ZLIB_VERSION)
+-
+ #
+ # Has been converted to the JNI: generate JNI-style header files
+ #
+@@ -73,4 +64,4 @@
+ #
+ # Link to JVM library for JVM_Zip* functions
+ #
+-OTHER_LDLIBS = $(JVMLIB)
++OTHER_LDLIBS = -lz