aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2019-04-22 20:52:52 +0000
committerGreg Lewis <glewis@FreeBSD.org>2019-04-22 20:52:52 +0000
commit6b01de01db1f96c9c48db06731145d828133ed5a (patch)
treeb0072951c17620a526c47b36f31291022cddf699 /java
parent71ee4102f4e6ef3c45c8ab778406e7b2c8c8b82a (diff)
downloadports-6b01de01db1f96c9c48db06731145d828133ed5a.tar.gz
ports-6b01de01db1f96c9c48db06731145d828133ed5a.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/openjdk8/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/java/openjdk8/Makefile b/java/openjdk8/Makefile
index 61d67918f9f5..4c7553428f2d 100644
--- a/java/openjdk8/Makefile
+++ b/java/openjdk8/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= zip:archivers/zip \
autoconf>0:devel/autoconf \
${LOCALBASE}/include/cups/cups.h:print/cups \
bash:shells/bash
-LIB_DEPENDS= libfreetype.so:print/freetype2 \
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
libinotify.so:devel/libinotify
RUN_DEPENDS= javavm:java/javavmwrapper \
dejavu>0:x11-fonts/dejavu
@@ -105,8 +106,7 @@ X11_CONFIGURE_OFF= --disable-headful
X11_CONFIGURE_ON= --with-giflib=system \
--x-includes=${LOCALBASE}/include \
--x-libraries=${LOCALBASE}/lib
-X11_LIB_DEPENDS= libgif.so:graphics/giflib \
- libfontconfig.so:x11-fonts/fontconfig
+X11_LIB_DEPENDS= libgif.so:graphics/giflib
X11_MAKE_ENV_OFF= BUILD_HEADLESS_ONLY=1 \
MAKEFLAGS=X_CFLAGS="-I${LOCALBASE}/include"
X11_MAKE_ENV_ON= MAKEFLAGS=""