aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2022-04-10 21:02:29 +0000
committerGreg Lewis <glewis@FreeBSD.org>2022-04-10 21:03:15 +0000
commit7bcde8fa251a0d295de4ff9e2d9705f5ef1f77a1 (patch)
tree3ed1f113614477d0548695a774429bc5c2eb6ad1 /java
parent8ba1801ad5d241c8071d87da33d80bdb1be86255 (diff)
downloadports-7bcde8fa251a0d295de4ff9e2d9705f5ef1f77a1.tar.gz
ports-7bcde8fa251a0d295de4ff9e2d9705f5ef1f77a1.zip
Diffstat (limited to 'java')
-rw-r--r--java/openjdk18/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/java/openjdk18/Makefile b/java/openjdk18/Makefile
index aa71d4e7d2a1..c077b1255c69 100644
--- a/java/openjdk18/Makefile
+++ b/java/openjdk18/Makefile
@@ -149,7 +149,12 @@ CONFIGURE_ARGS+= --with-extra-ldflags="-Wl,-rpath=${LOCALBASE}/lib/gcc${GCC_DEFA
.else
MAKE_ENV+= USE_CLANG=true
.if ${COMPILER_VERSION} >= 130
-CONFIGURE_ARGS+= --with-extra-cflags="-Wno-unused-but-set-parameter"
+EXTRA_CFLAGS+= -Wno-unused-but-set-parameter
+.if ${COMPILER_VERSION} >= 140
+EXTRA_CFLAGS+= -Wno-bitwise-instead-of-logical
+.endif
+CONFIGURE_ARGS+= --with-extra-cflags="${EXTRA_CFLAGS}"
+CONFIGURE_ARGS+= --with-extra-cxxflags="${EXTRA_CFLAGS}"
.endif
.endif