aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2025-03-01 16:17:21 +0000
committerRene Ladan <rene@FreeBSD.org>2025-03-01 16:17:21 +0000
commit9fbdee6ef447f33c708c2209c33cb6a4263c128a (patch)
tree61a7ea2f93cc9e099f9073dd8b32b41b5d250f0a /java
parenta9361305b3ddc8a23af79414322a230c67fa0826 (diff)
Diffstat (limited to 'java')
-rw-r--r--java/Makefile1
-rw-r--r--java/cos/Makefile36
-rw-r--r--java/cos/distinfo2
-rw-r--r--java/cos/pkg-descr10
-rw-r--r--java/cos/pkg-plist76
5 files changed, 0 insertions, 125 deletions
diff --git a/java/Makefile b/java/Makefile
index 57a6f9c2c60a..4e18508dec62 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -20,7 +20,6 @@
SUBDIR += bootstrap-openjdk17
SUBDIR += bootstrap-openjdk8
SUBDIR += bouncycastle
- SUBDIR += cos
SUBDIR += dbvis
SUBDIR += eclipse
SUBDIR += eclipse-EPIC
diff --git a/java/cos/Makefile b/java/cos/Makefile
deleted file mode 100644
index a007ea1e7a7c..000000000000
--- a/java/cos/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-PORTNAME= cos
-PORTVERSION= 2002.11.05
-PORTREVISION= 3
-PORTEPOCH= 1
-CATEGORIES= java devel
-MASTER_SITES= http://www.servlets.com/cos/ \
- http://www.oreilly.com.tw/bookcode/
-DISTNAME= ${PORTNAME}-05Nov2002
-
-MAINTAINER= java@FreeBSD.org
-COMMENT= The O'Reilly package of utility classes for servlet developers
-WWW= http://www.servlets.com/cos/index.html
-
-# Converted from RESTRICTED
-LICENSE= cos
-LICENSE_NAME= cos
-LICENSE_TEXT= Special conditions apply for commercial use, see licence
-LICENSE_PERMS= auto-accept
-
-DEPRECATED= Upstream seems gone since 2024-08-22
-EXPIRATION_DATE= 2025-02-28
-BROKEN= unfetchable, upstream seems gone
-
-NO_WRKSUBDIR= yes
-USES= java zip
-
-NO_BUILD= yes
-DATAFILES= readme.txt license.txt doc
-DATADIR= ${JAVASHAREDIR}/${PORTNAME}
-
-do-install:
- @${INSTALL_DATA} ${WRKSRC}/lib/cos.jar ${STAGEDIR}${JAVAJARDIR}
- @cd ${WRKSRC} && ${COPYTREE_SHARE} "${DATAFILES}" ${STAGEDIR}${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/upload.war ${STAGEDIR}${DATADIR}/doc
-
-.include <bsd.port.mk>
diff --git a/java/cos/distinfo b/java/cos/distinfo
deleted file mode 100644
index 67c94014385f..000000000000
--- a/java/cos/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (cos-05Nov2002.zip) = 96f9959e8252eddacce24b592a9c4c1dbf0082749115d7e75619504f70df1d90
-SIZE (cos-05Nov2002.zip) = 372387
diff --git a/java/cos/pkg-descr b/java/cos/pkg-descr
deleted file mode 100644
index 853fb9c5516e..000000000000
--- a/java/cos/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-The com.oreilly.servlet package contains a set of useful utility classes
-for servlet developers. Included are classes to help servlets parse
-parameters, handle multipart requests (file uploads), generate multipart
-responses (server push), negotiate locales for internationalization,
-return files, manage socket connections, and act as RMI servers, among
-other things. There's even a class to help applets communicate with
-servlets. The package was developed by Jason Hunter for his book "Java
-Servlet Programming" published by O'Reilly. See:
-
-For more details.
diff --git a/java/cos/pkg-plist b/java/cos/pkg-plist
deleted file mode 100644
index 67b023b06d36..000000000000
--- a/java/cos/pkg-plist
+++ /dev/null
@@ -1,76 +0,0 @@
-%%JAVAJARDIR%%/cos.jar
-%%DATADIR%%/readme.txt
-%%DATADIR%%/license.txt
-%%DATADIR%%/doc/com/oreilly/servlet/package-tree.html
-%%DATADIR%%/doc/com/oreilly/servlet/package-summary.html
-%%DATADIR%%/doc/com/oreilly/servlet/package-frame.html
-%%DATADIR%%/doc/com/oreilly/servlet/multipart/package-tree.html
-%%DATADIR%%/doc/com/oreilly/servlet/multipart/package-summary.html
-%%DATADIR%%/doc/com/oreilly/servlet/multipart/package-frame.html
-%%DATADIR%%/doc/com/oreilly/servlet/multipart/PartInputStream.html
-%%DATADIR%%/doc/com/oreilly/servlet/multipart/Part.html
-%%DATADIR%%/doc/com/oreilly/servlet/multipart/ParamPart.html
-%%DATADIR%%/doc/com/oreilly/servlet/multipart/MultipartParser.html
-%%DATADIR%%/doc/com/oreilly/servlet/multipart/MacBinaryDecoderOutputStream.html
-%%DATADIR%%/doc/com/oreilly/servlet/multipart/LimitedServletInputStream.html
-%%DATADIR%%/doc/com/oreilly/servlet/multipart/FileRenamePolicy.html
-%%DATADIR%%/doc/com/oreilly/servlet/multipart/FilePart.html
-%%DATADIR%%/doc/com/oreilly/servlet/multipart/DefaultFileRenamePolicy.html
-%%DATADIR%%/doc/com/oreilly/servlet/multipart/BufferedServletInputStream.html
-%%DATADIR%%/doc/com/oreilly/servlet/VersionDetector.html
-%%DATADIR%%/doc/com/oreilly/servlet/ServletUtils.html
-%%DATADIR%%/doc/com/oreilly/servlet/RemoteHttpServlet.html
-%%DATADIR%%/doc/com/oreilly/servlet/RemoteDaemonHttpServlet.html
-%%DATADIR%%/doc/com/oreilly/servlet/ParameterParser.html
-%%DATADIR%%/doc/com/oreilly/servlet/ParameterNotFoundException.html
-%%DATADIR%%/doc/com/oreilly/servlet/MultipartWrapper.html
-%%DATADIR%%/doc/com/oreilly/servlet/MultipartResponse.html
-%%DATADIR%%/doc/com/oreilly/servlet/MultipartRequest.html
-%%DATADIR%%/doc/com/oreilly/servlet/MultipartFilter.html
-%%DATADIR%%/doc/com/oreilly/servlet/MailMessage.html
-%%DATADIR%%/doc/com/oreilly/servlet/LocaleToCharsetMap.html
-%%DATADIR%%/doc/com/oreilly/servlet/LocaleNegotiator.html
-%%DATADIR%%/doc/com/oreilly/servlet/HttpsMessage.html
-%%DATADIR%%/doc/com/oreilly/servlet/HttpMessage.html
-%%DATADIR%%/doc/com/oreilly/servlet/DaemonHttpServlet.html
-%%DATADIR%%/doc/com/oreilly/servlet/CookieParser.html
-%%DATADIR%%/doc/com/oreilly/servlet/CookieNotFoundException.html
-%%DATADIR%%/doc/com/oreilly/servlet/CacheHttpServlet.html
-%%DATADIR%%/doc/com/oreilly/servlet/Base64Encoder.html
-%%DATADIR%%/doc/com/oreilly/servlet/Base64Decoder.html
-%%DATADIR%%/doc/images/blue-ball-small.gif
-%%DATADIR%%/doc/images/blue-ball.gif
-%%DATADIR%%/doc/images/class-index.gif
-%%DATADIR%%/doc/images/constructor-index.gif
-%%DATADIR%%/doc/images/constructors.gif
-%%DATADIR%%/doc/images/cyan-ball-small.gif
-%%DATADIR%%/doc/images/cyan-ball.gif
-%%DATADIR%%/doc/images/error-index.gif
-%%DATADIR%%/doc/images/exception-index.gif
-%%DATADIR%%/doc/images/green-ball-small.gif
-%%DATADIR%%/doc/images/green-ball.gif
-%%DATADIR%%/doc/images/interface-index.gif
-%%DATADIR%%/doc/images/magenta-ball-small.gif
-%%DATADIR%%/doc/images/magenta-ball.gif
-%%DATADIR%%/doc/images/method-index.gif
-%%DATADIR%%/doc/images/methods.gif
-%%DATADIR%%/doc/images/package-index.gif
-%%DATADIR%%/doc/images/red-ball-small.gif
-%%DATADIR%%/doc/images/red-ball.gif
-%%DATADIR%%/doc/images/variable-index.gif
-%%DATADIR%%/doc/images/variables.gif
-%%DATADIR%%/doc/images/yellow-ball-small.gif
-%%DATADIR%%/doc/images/yellow-ball.gif
-%%DATADIR%%/doc/package-list
-%%DATADIR%%/doc/packages.html
-%%DATADIR%%/doc/stylesheet.css
-%%DATADIR%%/doc/help-doc.html
-%%DATADIR%%/doc/index-all.html
-%%DATADIR%%/doc/index.html
-%%DATADIR%%/doc/overview-frame.html
-%%DATADIR%%/doc/overview-summary.html
-%%DATADIR%%/doc/overview-tree.html
-%%DATADIR%%/doc/serialized-form.html
-%%DATADIR%%/doc/allclasses-frame.html
-%%DATADIR%%/doc/deprecated-list.html
-%%DATADIR%%/doc/upload.war