aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2022-06-19 04:53:05 +0000
committerGreg Lewis <glewis@FreeBSD.org>2022-06-19 04:55:54 +0000
commitaa1ca89826b5669e623d868e447830aad01e6f1a (patch)
treea6e574e68f524a7faeabec550fae3f78ae00fd7e /java
parent8e82ed9d130f86805caff49d1b0f83b6757b7067 (diff)
downloadports-aa1ca89826b5669e623d868e447830aad01e6f1a.tar.gz
ports-aa1ca89826b5669e623d868e447830aad01e6f1a.zip
java/openjdk8: Attempt to fix newer aarch64
Revert to forcing Clang 12 if Clang 13 or newer is detected. This may fix problems with the built JDK on aarch64. PR: 264065
Diffstat (limited to 'java')
-rw-r--r--java/openjdk8/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/java/openjdk8/Makefile b/java/openjdk8/Makefile
index 9addd3e34e55..28e45e5412f7 100644
--- a/java/openjdk8/Makefile
+++ b/java/openjdk8/Makefile
@@ -204,7 +204,12 @@ LIB_DEPENDS+= libffi.so:devel/libffi
MAKE_ENV+= COMPILER_WARNINGS_FATAL=false USE_CLANG=true
CONFIGURE_ENV+= LIBCXX="-lc++"
.if ${COMPILER_VERSION} >= 130
-CONFIGURE_ARGS+= --with-extra-cflags="-Wno-unused-but-set-parameter"
+# PR258954: OpenJDK <= 13 crash due to undefined behavior with clang >= 13
+# See also https://bugs.openjdk.java.net/browse/JDK-8229258
+LLVM_VER= 12
+BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
+CC= ${LOCALBASE}/bin/clang${LLVM_VER}
+CXX= ${LOCALBASE}/bin/clang++${LLVM_VER}
.endif
.endif