aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGeorge V. Neville-Neil <gnn@FreeBSD.org>2013-08-17 17:37:03 +0000
committerGeorge V. Neville-Neil <gnn@FreeBSD.org>2013-08-17 17:37:03 +0000
commite19c8e662058685eb69a636b46c538f051fa0204 (patch)
tree2477e42341321e880269c94d3a8f7379730642cf /java
parentfc05dacb4597b6822dd6a443903f52cf11c8cbac (diff)
downloadports-e19c8e662058685eb69a636b46c538f051fa0204.tar.gz
ports-e19c8e662058685eb69a636b46c538f051fa0204.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-devel/Makefile7
-rw-r--r--java/eclipse-devel/files/BindingModel.java.patch14
2 files changed, 20 insertions, 1 deletions
diff --git a/java/eclipse-devel/Makefile b/java/eclipse-devel/Makefile
index f26091f1ddeb..3e72f9b716d7 100644
--- a/java/eclipse-devel/Makefile
+++ b/java/eclipse-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= eclipse-devel
PORTVERSION= 4.2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= java devel
MASTER_SITES= http://download.eclipse.org/technology/linuxtools/eclipse-build/4.2.x/:1 \
http://download.eclipse.org/tools/orbit/downloads/drops/R20120119162704/repository/plugins/:2 \
@@ -273,6 +273,11 @@ post-patch:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${ANT} ${MAKE_ARGS} applyTestPatches)
.endif
+pre-build:
+ @${CP} ${BUILD_WRKSRC}/build/eclipse-4.2.0-I20120608-1400-src/plugins/org.eclipse.ui.workbench/Eclipse\ UI/org/eclipse/ui/internal/keys/model/BindingModel.java ${PATCHDIR}
+ @${PATCH} -d ${PATCHDIR} -E -p0 -i ${PATCHDIR}/BindingModel.java.patch
+ @${CP} ${PATCHDIR}/BindingModel.java ${BUILD_WRKSRC}/build/eclipse-4.2.0-I20120608-1400-src/plugins/org.eclipse.ui.workbench/Eclipse\ UI/org/eclipse/ui/internal/keys/model/BindingModel.java
+
do-install:
@${RM} -rf ${PORTDESTDIR}
@${MKDIR} ${PORTDESTDIR}
diff --git a/java/eclipse-devel/files/BindingModel.java.patch b/java/eclipse-devel/files/BindingModel.java.patch
new file mode 100644
index 000000000000..534f7060a753
--- /dev/null
+++ b/java/eclipse-devel/files/BindingModel.java.patch
@@ -0,0 +1,14 @@
+--- BindingModel.java 2013-08-13 13:47:55.000000000 -0400
++++ BindingModel.java 2013-08-13 13:48:48.000000000 -0400
+@@ -237,7 +237,10 @@
+ if (obj instanceof Binding) {
+ Binding b = (Binding) obj;
+ if (!activeManagerBindings.contains(b)) {
+- be.fill(b.getParameterizedCommand());
++ ParameterizedCommand cmd = b.getParameterizedCommand();
++ if (cmd != null) {
++ commandToElement.remove(cmd);
++ }
+ bindingToElement.remove(b);
+ i.remove();
+ controller.firePropertyChange(this, PROP_BINDING_REMOVE,