aboutsummaryrefslogtreecommitdiff
path: root/korean/imhangul-gtk3
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2016-09-15 18:12:44 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2016-09-15 18:12:44 +0000
commitc2f2e891a9838ec1929dd1499738b9e92c8ec9d3 (patch)
tree781bec1d7a68a46750a7370c04a91f8820a905fb /korean/imhangul-gtk3
parent52c5d9c7fad3fdc302b7b686da5f76a19c87d5c3 (diff)
downloadports-c2f2e891a9838ec1929dd1499738b9e92c8ec9d3.tar.gz
ports-c2f2e891a9838ec1929dd1499738b9e92c8ec9d3.zip
Notes
Diffstat (limited to 'korean/imhangul-gtk3')
-rw-r--r--korean/imhangul-gtk3/Makefile39
-rw-r--r--korean/imhangul-gtk3/distinfo3
-rw-r--r--korean/imhangul-gtk3/files/patch-Makefile.am10
-rw-r--r--korean/imhangul-gtk3/pkg-descr7
-rw-r--r--korean/imhangul-gtk3/pkg-plist4
5 files changed, 63 insertions, 0 deletions
diff --git a/korean/imhangul-gtk3/Makefile b/korean/imhangul-gtk3/Makefile
new file mode 100644
index 000000000000..dac05bb9a40b
--- /dev/null
+++ b/korean/imhangul-gtk3/Makefile
@@ -0,0 +1,39 @@
+# Created by: Junho CHOI <junho.choi@gmail.com>
+# $FreeBSD$
+
+PORTNAME= imhangul
+PORTVERSION= 3.1.1
+CATEGORIES= korean
+PKGNAMESUFFIX= -gtk3
+
+MAINTAINER= jkim@FreeBSD.org
+COMMENT= Hangul input module for GTK+ 3.0
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libhangul.so:korean/libhangul
+
+CONFLICTS_INSTALL= ko-imhangul-3.*
+
+GH_ACCOUNT= choehwanjin
+GH_TAGNAME= 85f6d10
+USE_GITHUB= yes
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_GNOME= cairo gdkpixbuf2 gtk30
+USES= autoreconf gmake libtool pkgconfig
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+NLS_USES= gettext localbase
+
+post-patch-NLS-off:
+ @${REINPLACE_CMD} -e '/^SUBDIRS /s| po||' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e '/^po\/Makefile\.in/d' ${WRKSRC}/configure.in
+
+pre-configure-NLS-on:
+ @(cd ${WRKSRC} && ${LOCALBASE}/bin/glib-gettextize)
+
+.include <bsd.port.mk>
diff --git a/korean/imhangul-gtk3/distinfo b/korean/imhangul-gtk3/distinfo
new file mode 100644
index 000000000000..320730761188
--- /dev/null
+++ b/korean/imhangul-gtk3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1473877928
+SHA256 (choehwanjin-imhangul-3.1.1-85f6d10_GH0.tar.gz) = a2bd9baf56c5b624c035ce6890553fb513feb6404453549a2f523691df86f2cc
+SIZE (choehwanjin-imhangul-3.1.1-85f6d10_GH0.tar.gz) = 256731
diff --git a/korean/imhangul-gtk3/files/patch-Makefile.am b/korean/imhangul-gtk3/files/patch-Makefile.am
new file mode 100644
index 000000000000..66effdce47c6
--- /dev/null
+++ b/korean/imhangul-gtk3/files/patch-Makefile.am
@@ -0,0 +1,10 @@
+--- Makefile.am.orig 2012-12-31 14:14:19 UTC
++++ Makefile.am
+@@ -18,7 +18,6 @@ im_hangul_la_CFLAGS = \
+ -DG_DISABLE_DEPRECATED \
+ -DGDK_PIXBUF_DISABLE_DEPRECATED \
+ -DGDK_DISABLE_DEPRECATED \
+- -DGTK_DISABLE_DEPRECATED \
+ $(GTK_CFLAGS) \
+ $(LIBHANGUL_CFLAGS)
+
diff --git a/korean/imhangul-gtk3/pkg-descr b/korean/imhangul-gtk3/pkg-descr
new file mode 100644
index 000000000000..6c2c5478ab4e
--- /dev/null
+++ b/korean/imhangul-gtk3/pkg-descr
@@ -0,0 +1,7 @@
+Hangul Input Module for GTK+ 3.0
+
+Input method of GTK+ 3.0 widget. To select this modules, click
+right button in gtk30 text widget and select "Input Methods" -
+"Hangul" (not KSC5601).
+
+WWW: http://code.google.com/p/imhangul/
diff --git a/korean/imhangul-gtk3/pkg-plist b/korean/imhangul-gtk3/pkg-plist
new file mode 100644
index 000000000000..124e906cebaf
--- /dev/null
+++ b/korean/imhangul-gtk3/pkg-plist
@@ -0,0 +1,4 @@
+lib/gtk-3.0/immodules/im-hangul.so
+%%NLS%%share/locale/ko/LC_MESSAGES/im-hangul-3.0.mo
+@postexec %D/bin/gtk-query-immodules-3.0 --update-cache
+@postunexec %D/bin/gtk-query-immodules-3.0 --update-cache