aboutsummaryrefslogtreecommitdiff
path: root/korean
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2019-07-19 00:20:11 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2019-07-19 00:20:11 +0000
commit4269e853b2394d38de77edb144d3461b201d62fb (patch)
tree4df5c04b03c8d092dc89bd47264bad615c43c08e /korean
parente4a626528e5247143d9b64dcf88d0bae80cd204c (diff)
downloadports-4269e853b2394d38de77edb144d3461b201d62fb.tar.gz
ports-4269e853b2394d38de77edb144d3461b201d62fb.zip
- Fix plist and build with Python 3.
- Add an upstream patch to fix window close event. - Add NLS option to appease portlint.
Notes
Notes: svn path=/head/; revision=506903
Diffstat (limited to 'korean')
-rw-r--r--korean/ibus-hangul/Makefile17
-rw-r--r--korean/ibus-hangul/files/patch-setup_main.py10
-rw-r--r--korean/ibus-hangul/pkg-message4
-rw-r--r--korean/ibus-hangul/pkg-plist24
4 files changed, 39 insertions, 16 deletions
diff --git a/korean/ibus-hangul/Makefile b/korean/ibus-hangul/Makefile
index 55b958d74b4b..46f86ae380aa 100644
--- a/korean/ibus-hangul/Makefile
+++ b/korean/ibus-hangul/Makefile
@@ -13,11 +13,22 @@ LICENSE= GPLv2
LIB_DEPENDS= libhangul.so:korean/libhangul \
libibus-1.0.so:textproc/ibus
+USES= gmake gnome libtool pkgconfig python
+USE_GNOME= gtk30 intlhack pygobject3
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= NLS
+
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
+NLS_USES_OFF= gettext-tools
+
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-python="${PYTHON_CMD}"
+
+GLIB_SCHEMAS= org.freedesktop.ibus.engine.hangul.gschema.xml
+
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
-USE_GNOME= gtk30 intlhack pygobject3
-USES= gettext gmake libtool pkgconfig python
-USE_PYTHON= py3kplist
.include <bsd.port.mk>
diff --git a/korean/ibus-hangul/files/patch-setup_main.py b/korean/ibus-hangul/files/patch-setup_main.py
new file mode 100644
index 000000000000..060cd3e1e902
--- /dev/null
+++ b/korean/ibus-hangul/files/patch-setup_main.py
@@ -0,0 +1,10 @@
+--- setup/main.py.orig 2018-06-08 14:34:37 UTC
++++ setup/main.py
+@@ -151,6 +151,7 @@ class Setup ():
+ self.__window = self.__builder.get_object("SetupDialog")
+ icon_file = os.path.join(config.pkgdatadir, "icons", "ibus-hangul.svg")
+ self.__window.set_icon_from_file(icon_file)
++ self.__window.connect("destroy", Gtk.main_quit)
+ self.__window.show()
+
+ button = self.__builder.get_object("button_apply")
diff --git a/korean/ibus-hangul/pkg-message b/korean/ibus-hangul/pkg-message
index 5db470cfda23..200c09752546 100644
--- a/korean/ibus-hangul/pkg-message
+++ b/korean/ibus-hangul/pkg-message
@@ -29,7 +29,3 @@ export QT_IM_MODULE=xim
export XMODIFIERS=@im=ibus
export XIM_PROGRAM="ibus-daemon"
export XIM_ARGS="-r --daemonize --xim"
-
-If ibus cannot start or the panel does not appear, please ensure
-that you are using up-to-date python.
-There's a bug in python 2.5, which may prevent the panel from appearing.
diff --git a/korean/ibus-hangul/pkg-plist b/korean/ibus-hangul/pkg-plist
index fa9e6b1f0f5d..87bf8dd4a8ba 100644
--- a/korean/ibus-hangul/pkg-plist
+++ b/korean/ibus-hangul/pkg-plist
@@ -2,23 +2,29 @@ bin/ibus-setup-hangul
libexec/ibus-engine-hangul
libexec/ibus-setup-hangul
share/applications/ibus-setup-hangul.desktop
-share/ibus/component/hangul.xml
%%DATADIR%%/data/symbol.txt
%%DATADIR%%/icons/ibus-hangul.png
%%DATADIR%%/icons/ibus-hangul.svg
+%%PYTHON3%%%%DATADIR%%/setup/__pycache__/config.cpython-36.opt-1.pyc
+%%PYTHON3%%%%DATADIR%%/setup/__pycache__/config.cpython-36.pyc
+%%PYTHON3%%%%DATADIR%%/setup/__pycache__/keycapturedialog.cpython-36.opt-1.pyc
+%%PYTHON3%%%%DATADIR%%/setup/__pycache__/keycapturedialog.cpython-36.pyc
+%%PYTHON3%%%%DATADIR%%/setup/__pycache__/main.cpython-36.opt-1.pyc
+%%PYTHON3%%%%DATADIR%%/setup/__pycache__/main.cpython-36.pyc
%%DATADIR%%/setup/config.py
-%%DATADIR%%/setup/config.pyc
-%%DATADIR%%/setup/config.pyo
+%%PYTHON2%%%%DATADIR%%/setup/config.pyc
+%%PYTHON2%%%%DATADIR%%/setup/config.pyo
%%DATADIR%%/setup/keycapturedialog.py
-%%DATADIR%%/setup/keycapturedialog.pyc
-%%DATADIR%%/setup/keycapturedialog.pyo
+%%PYTHON2%%%%DATADIR%%/setup/keycapturedialog.pyc
+%%PYTHON2%%%%DATADIR%%/setup/keycapturedialog.pyo
%%DATADIR%%/setup/main.py
-%%DATADIR%%/setup/main.pyc
-%%DATADIR%%/setup/main.pyo
+%%PYTHON2%%%%DATADIR%%/setup/main.pyc
+%%PYTHON2%%%%DATADIR%%/setup/main.pyo
%%DATADIR%%/setup/setup.ui
+share/ibus/component/hangul.xml
share/icons/hicolor/64x64/apps/ibus-hangul.png
share/icons/hicolor/64x64/apps/ibus-setup-hangul.png
share/icons/hicolor/scalable/apps/ibus-hangul.svg
share/icons/hicolor/scalable/apps/ibus-setup-hangul.svg
-share/locale/ko/LC_MESSAGES/ibus-hangul.mo
-share/locale/zh_CN/LC_MESSAGES/ibus-hangul.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/ibus-hangul.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/ibus-hangul.mo