aboutsummaryrefslogtreecommitdiff
path: root/korean
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2019-09-01 16:42:05 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2019-09-01 16:42:05 +0000
commit562051b9e35ff9b1f55042ca0d701d8a2fcd724b (patch)
treebabe51c0a01c86afdbcb222b46f3c41aa3436f86 /korean
parent5bf9108d86916024eefeb9f17587faaac9fb1362 (diff)
downloadports-562051b9e35ff9b1f55042ca0d701d8a2fcd724b.tar.gz
ports-562051b9e35ff9b1f55042ca0d701d8a2fcd724b.zip
Add a patch to remove use of gets(3)
PR: 238690 Submitted by: Walter Schwarzenfeld <w.schwarzenfeld at utanet.at> Reported by: emaste Sponsored by: The FreeBSD Foundation
Notes
Notes: svn path=/head/; revision=510708
Diffstat (limited to 'korean')
-rw-r--r--korean/hpscat/Makefile4
-rw-r--r--korean/hpscat/files/patch-hpscat.c45
2 files changed, 11 insertions, 38 deletions
diff --git a/korean/hpscat/Makefile b/korean/hpscat/Makefile
index 6f2db949f1be..c901f461ad78 100644
--- a/korean/hpscat/Makefile
+++ b/korean/hpscat/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hpscat
PORTVERSION= 1.3.1
-PORTEPOCH= 1
+PORTEPOCH= 2
CATEGORIES= korean print
MASTER_SITES= http://ftp.kaist.ac.kr/hangul/print/hpscat/ \
ftp://ftp.kaist.ac.kr/hangul/print/hpscat/ \
@@ -17,7 +17,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ked.tar.gz:ked
MAINTAINER= ports@FreeBSD.org
COMMENT= Hangul Text Printing Utility
-RUN_DEPENDS= hcode:korean/hcode
+RUN_DEPENDS= hcode:korean/hcode
FONTDIR= ${PREFIX}/${FONTDIR_REL}
FONTDIR_REL= share/fonts/ked-${PORTNAME}
diff --git a/korean/hpscat/files/patch-hpscat.c b/korean/hpscat/files/patch-hpscat.c
index 93b54b13bcbb..74ff08df97e4 100644
--- a/korean/hpscat/files/patch-hpscat.c
+++ b/korean/hpscat/files/patch-hpscat.c
@@ -1,38 +1,11 @@
---- hpscat.c.orig 1995-11-23 07:46:12.000000000 -0500
-+++ hpscat.c 2013-06-12 17:10:59.000000000 -0400
-@@ -12,13 +12,14 @@
- bool cheat;
- FILE *fp, *ofp;
-
-+static int open_outfile(char *);
-+
- /****************
- main routine
- ****************/
-
--main(ac,av)
-- int ac;
-- char *av[];
-+int
-+main(int ac, char *av[])
- {
- int i;
- extern void showfile PROT((char *));
-@@ -53,13 +54,13 @@
- exit(0);
- }
-
--int
--open_outfile(s) /* returns -1 if can't write */
-- char *s;
-+static int
-+open_outfile(char *s) /* returns -1 if can't write */
- {
- char ans[80], buf[256];
- sprintf(buf,"%s.ps", s);
-- if(ofp=fopen(buf,"r")) { /* file exists */
-+ ofp=fopen(buf,"r");
-+ if(ofp) { /* file exists */
+--- hpscat.c.orig 2019-08-03 11:25:44 UTC
++++ hpscat.c
+@@ -62,7 +62,7 @@ open_outfile(s) /* returns -1 if can
+ if(ofp=fopen(buf,"r")) { /* file exists */
fclose(ofp);
fprintf(stderr,"output file %s exists...overwrite? ", buf);
- gets(ans);
+- gets(ans);
++ fgets(buf,256,ans);
+ if(ans[0]=='y')
+ unlink(buf);
+ else