aboutsummaryrefslogtreecommitdiff
path: root/lang/Makefile
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2017-08-14 23:20:34 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2017-08-14 23:20:34 +0000
commit0991d7673590f07fe11e4ca09edb215c1f3d34d9 (patch)
tree9d8bebdffd577cd893d3eef6c0c534586f68bdfe /lang/Makefile
parentb74e71d1ac96a17bfa966bb00202786b84447f53 (diff)
downloadports-0991d7673590f07fe11e4ca09edb215c1f3d34d9.tar.gz
ports-0991d7673590f07fe11e4ca09edb215c1f3d34d9.zip
Welcome GCC 7.1, the first release of the GCC 7 series!
In terms of optimizations, GCC now uses a new local register allocator (LRA) for most targets (now also including PowerPC and SPARC), a new store merging pass, is able to determine the return value or range of return values of some calls to the sprintf family of functions as input for futher passes, features improved code hoisting, new interprocedural bitwise constant propagation, interprocedural value range propagation, new loop splitting, improved shrink-wrapping that separates portions of prologues and epilogues, and many more. DWARF 5 is supported through the -gdwarf-5, while DWARF 4 remains the default for the time being. The C and C++ frontends have gained a large number of additional warnings such as -Wpointer-compare, -Wduplicated-branches, -Wrestrict, -Wmemset-elt-size, -Wint-in-bool-context, -Wswitch-unreachable, -Wexpansion-to-defined, -Wregister, -Wvla-larger-than=N, -Wduplicate-decl-specifier, -Wdangling-else, many of which are enabled by default or at least with -Wall. The -Wshadow warning has been split into -Wshadow=global, -Wshadow=local, and -Wshadow=compatible-local . GCC 7 also brings a number of enhancements that help detect buffer overflow and other forms of invalid memory accesses, among others enabled by the -Walloc-size-larger-than= -Walloc-zero, -Walloca, and -Walloca-larger-than= command-line options. -Wformat-overflow=level option detects certain and likely buffer overflow in calls to the sprintf family of formatted output functions; and -Wformat-truncation= and -Wstringop-overflow= have been added as well and -Wnunnull enahcned. So-called fixit hints, that is, notes on how to possibly address a warning or error have seen signficant improvements. The command-line option -fdiagnostics-generate-patch will print a patch in "unified" format after any diagnostics are printed, showing the result of applying all fix-it hints. The C front end now supports type names _FloatN for floating-point types with IEEE interchange formats and _FloatNx for floating-point types with IEEE extended formats. The C++ front end has experimental support for all of the current C++17 draft with the -std=c++1z or -std=gnu++1z flags, including if constexpr, class template argument deduction, auto template parameters, and structured bindings. Experimental support for C++17 is in libstdc++ with lots of new features. libstdc++ Profile Mode and Cilk+ extensions to the C and C++ languages have been deprecated. Fortran added a number of extensions for compatibility with legacy code and improved and add various features. GCC 7 provides a complete implementation of the Go 1.8.1 user package. Notably this release ends the history of Java (GCJ and libgcj) as part of GCC; all traces thereof and options have been removed in favor of OpenJDK, quite simplifying and streamlining building this port, Many new processors such as ARM Cortex-A73, Broadcom Vulcan, Cavium ThunderX models, Qualcomm Falkor (all on the ARM side) and features such as AVX-512 enhancements (on x86-64) as well as optimization changes have been added. On ARM targets (arm*-*-*), a bug introduced in GCC 5 that affects conformance to the procedure call standard (AAPCS) has been fixed. The bug affects some C++ code where class objects are passed by value to functions and could result in incorrect or inconsistent code being generated. This is an ABI change. If the option -Wpsabi is enabled (on by default) the compiler will emit a diagnostic note for code that might be affected. https://gcc.gnu.org/gcc-7/changes.html has a comprehensive set of changes and https://gcc.gnu.org/gcc-7/porting_to.html has a helpful overview of issue you may encountering porting to this new version. PR: 220794
Notes
Notes: svn path=/head/; revision=447971
Diffstat (limited to 'lang/Makefile')
-rw-r--r--lang/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 3f4975224dbb..a5828dd4c9ab 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -105,6 +105,7 @@
SUBDIR += gcc6
SUBDIR += gcc6-aux
SUBDIR += gcc6-devel
+ SUBDIR += gcc7
SUBDIR += gcc7-devel
SUBDIR += gcc8-devel
SUBDIR += gcl