aboutsummaryrefslogtreecommitdiff
path: root/lang/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-12-11 08:44:45 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-12-11 08:44:45 +0000
commit46ce70a6d44849af0fb06744c699c16945f3ac30 (patch)
tree04b7b6c6e8f49fad25d5eca4a0bf43790edeade2 /lang/Makefile
parent42359089810cf18ea2dd9ef6bd162631f2dfb18a (diff)
downloadports-46ce70a6d44849af0fb06744c699c16945f3ac30.tar.gz
ports-46ce70a6d44849af0fb06744c699c16945f3ac30.zip
[NEW] lang/tauthon: Backwards-compatible fork of Python 2.7 interpreter with Python 3.x features
------------------------------------------------------------------------------ Note this is not fully connected yet, and needs further changes to integrate with flavors, addition to Mk/Uses/python.mk (or some equivalent USES=tauthon) that may need discussion first, for instance, on the package name prefix. This is committed to serve as a common test bed and for experimentation. ------------------------------------------------------------------------------ Maintainer: olce.freebsd.ports@certner.fr (Olivier Certner) Tauthon is a backward-compatible fork of Python's 2.7.18 interpreter with new syntax, builtins, and libraries backported from Python 3.x. Python code and C-extensions targeting Python 2.7 or below are expected to run unmodified on Tauthon and produce the same output. But with Tauthon, that code can now use some of the new features from Python 3.x. This is not an official Python release. Because of its new features, while preserving 2.7 compatibility, Tauthon reports 2.8 as its major/minor versions. Non-exhaustive list of new features: - Function Annotations - Keyword-Only Arguments - "async" and "await" Syntax - Argument-less "super" - New Metaclass Syntax - "nonlocal" - "yield from" Syntax - "concurrent.futures" Module - UTF-8 as the default source encoding WWW: https://github.com/naftaliharris/tauthon (Committed with minor changes over submission, particularly a few reorderings in Makefile to appease portlint -CA.) PR: 251019 Submitted by: Olivier Certner (maintainer)
Notes
Notes: svn path=/head/; revision=557705
Diffstat (limited to 'lang/Makefile')
-rw-r--r--lang/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index f9c1ca5a38a0..d922334f2315 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -344,6 +344,7 @@
SUBDIR += squeak
SUBDIR += squirrel
SUBDIR += swi-pl
+ SUBDIR += tauthon
SUBDIR += tcbasic
SUBDIR += tcc
SUBDIR += tcl-manual