aboutsummaryrefslogtreecommitdiff
path: root/lang/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-11-28 22:53:19 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-11-28 22:53:19 +0000
commit4c5a127774f465e855cd93bf56799e88550fd9a9 (patch)
tree41bf091655cdac09bab6ace9cfac2b1759e4cc0b /lang/Makefile
parentb7e2899d017fa9c93495c016ff146a77ca2b008a (diff)
downloadports-4c5a127774f465e855cd93bf56799e88550fd9a9.tar.gz
ports-4c5a127774f465e855cd93bf56799e88550fd9a9.zip
Duktape is an embeddable Javascript engine, with a focus on portability and
compact footprint. Duktape is easy to integrate into a C/C++ project: add duktape.c and duktape.h to your build, and use the Duktape API to call Ecmascript functions from C code and vice versa. Main features: * Embeddable, portable, compact; about 210kB code, 80kB memory, 40kLoC source (excluding comments etc) * Ecmascript E5/E5.1 compliant, some features borrowed from E6 draft * Built-in regular expression engine * Built-in Unicode support * Minimal platform dependencies * Combined reference counting and mark-and-sweep garbage collection with finalization * Custom features like coroutines, built-in logging framework, and built-in CommonJS-based module loading framework * Property virtualization using a subset of Ecmascript E6 Proxy object * Liberal license (MIT)
Notes
Notes: svn path=/head/; revision=373582
Diffstat (limited to 'lang/Makefile')
-rw-r--r--lang/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 6cb5a8884d97..f2483622175f 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -49,6 +49,7 @@
SUBDIR += dlv
SUBDIR += dmd1
SUBDIR += dmd2
+ SUBDIR += duktape
SUBDIR += ecl
SUBDIR += elan
SUBDIR += elixir