aboutsummaryrefslogtreecommitdiff
path: root/lang/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-03-13 15:11:11 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-03-13 15:11:11 +0000
commit515376053bd13c78f55ed6ae88aac683a22579dd (patch)
tree84244662bfb1a5c79c5d1860d3b3f350a11af8aa /lang/Makefile
parent87b5dc169d7e26393a16faadfe41295eb11de150 (diff)
downloadports-515376053bd13c78f55ed6ae88aac683a22579dd.tar.gz
ports-515376053bd13c78f55ed6ae88aac683a22579dd.zip
New port: lang/myrddin
Myrddin is a systems programming language that covers a similar niche as C including desktop, OS, and embedded development, but at the same time making it harder to shoot yourself in the foot. It is designed to be a simple language that runs close to the metal, giving the programmer predictable and transparent behavior and mental model. It also does strong type checking, generics, type inference, closures, and traits. Myrddin is not a language designed to explore the forefront of type theory or compiler technology. It is not a language that is focused on guaranteeing perfect safety. It is satisfied to be a practical, small, fairly well defined, and easy to understand language for code that needs to be close to the hardware. WWW: https://myrlang.org/ Approved by: lme (mentor) Differential Revision: https://reviews.freebsd.org/D9989
Notes
Notes: svn path=/head/; revision=436084
Diffstat (limited to 'lang/Makefile')
-rw-r--r--lang/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index cd1fe3bd2fc3..051821d63344 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -184,6 +184,7 @@
SUBDIR += mosml
SUBDIR += mtasc
SUBDIR += munger
+ SUBDIR += myrddin
SUBDIR += nawk
SUBDIR += nbc
SUBDIR += nbfc