aboutsummaryrefslogtreecommitdiff
path: root/lang/algol68g
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2014-09-04 17:38:04 +0000
committerJohan van Selst <johans@FreeBSD.org>2014-09-04 17:38:04 +0000
commit7ebae9248445f555876ddd6e9d69178224120089 (patch)
tree187263d234665cfbc038f65c54786f481a4661d3 /lang/algol68g
parent2fa1508f9894d45b8fe9c799aeea18275cd86f2b (diff)
downloadports-7ebae9248445f555876ddd6e9d69178224120089.tar.gz
ports-7ebae9248445f555876ddd6e9d69178224120089.zip
Fix misleading option name: the option uses plotutils, not gnuplot
No functional changes PR: 193317 Submitted by: amdmi3
Notes
Notes: svn path=/head/; revision=367294
Diffstat (limited to 'lang/algol68g')
-rw-r--r--lang/algol68g/Makefile25
1 files changed, 9 insertions, 16 deletions
diff --git a/lang/algol68g/Makefile b/lang/algol68g/Makefile
index 12060e2cfbc0..88e56ff6722a 100644
--- a/lang/algol68g/Makefile
+++ b/lang/algol68g/Makefile
@@ -11,8 +11,15 @@ COMMENT= Algol 68 Genie compiler
LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
-OPTIONS_DEFINE= GNUPLOT PGSQL
-OPTIONS_DEFAULT=GNUPLOT PGSQL
+OPTIONS_DEFINE= PLOTUTILS PGSQL
+OPTIONS_DEFAULT=PLOTUTILS PGSQL
+
+PLOTUTILS_DESC= Plotting support via plotutils
+PLOTUTILS_LIB_DEPENDS= libplot.so:${PORTSDIR}/graphics/plotutils
+PLOTUTILS_CONFIGURE_ENABLE=plotutils
+
+PGSQL_USES= pgsql
+PGSQL_CONFIGURE_ENABLE= postgresql
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-compiler
@@ -21,20 +28,6 @@ PLIST_DIRS= include/algol68g
PLIST_FILES= bin/a68g man/man1/a68g.1.gz \
include/algol68g/a68g.h include/algol68g/a68g-config.h
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGNUPLOT}
-LIB_DEPENDS+= libplot.so:${PORTSDIR}/graphics/plotutils
-.else
-CONFIGURE_ARGS+=--disable-plotutils
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
-.else
-CONFIGURE_ARGS+=--disable-postgresql
-.endif
-
post-patch:
# Skip broken check, assume our $CC works
@${REINPLACE_CMD} -Ee 's/.*(\*-freebsd)/\1/' \