aboutsummaryrefslogtreecommitdiff
path: root/lang/angelscript
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-08-24 12:38:55 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-08-24 12:38:55 +0000
commitaa95db6e8ba92fc5719fb074172917aa1e978d4d (patch)
treed49524ee9d422ce53dc091f945dc8b865ae498d5 /lang/angelscript
parentaf66429d6816dd72f6347a53e1e392d70eef6517 (diff)
downloadports-aa95db6e8ba92fc5719fb074172917aa1e978d4d.tar.gz
ports-aa95db6e8ba92fc5719fb074172917aa1e978d4d.zip
lang/angelscript: fix build on powerpc64
Angelscript works on powerpc, but its naming convention is only 32-bit. Define AS_MAX_PORTABILITY when building on powerpc64 to fix build. PR: 239496 Approved by: ndowens@yahoo.com (maintainer timeout), linimon (mentor)
Notes
Notes: svn path=/head/; revision=509720
Diffstat (limited to 'lang/angelscript')
-rw-r--r--lang/angelscript/Makefile5
-rw-r--r--lang/angelscript/files/patch-as_config.h12
2 files changed, 15 insertions, 2 deletions
diff --git a/lang/angelscript/Makefile b/lang/angelscript/Makefile
index 8bef7a3a3920..1143b31793b8 100644
--- a/lang/angelscript/Makefile
+++ b/lang/angelscript/Makefile
@@ -13,12 +13,13 @@ COMMENT= AngelCode Scripting Library
LICENSE= ZLIB
BROKEN_aarch64= Does not build: invokes x86 asm
-BROKEN_powerpc64= Does not build: invokes x86 asm
BROKEN_sparc64= Does not build: invokes x86 asm
-USES= alias gmake zip
+USES= alias compiler:c11 dos2unix gmake zip
USE_LDCONFIG= yes
+DOS2UNIX_FILES= ../../source/as_config.h
+
MAKE_ARGS= CP_SYMLINK="${INSTALL_LIB}"
.include <bsd.port.options.mk>
diff --git a/lang/angelscript/files/patch-as_config.h b/lang/angelscript/files/patch-as_config.h
new file mode 100644
index 000000000000..a2a7c88979c9
--- /dev/null
+++ b/lang/angelscript/files/patch-as_config.h
@@ -0,0 +1,12 @@
+--- ../../source/as_config.h.orig 2019-07-28 15:58:25.283690000 +0200
++++ ../../source/as_config.h 2019-07-28 16:08:34.592212000 +0200
+@@ -953,6 +953,9 @@
+ #define COMPLEX_RETURN_MASK (asOBJ_APP_CLASS_DESTRUCTOR | asOBJ_APP_CLASS_COPY_CONSTRUCTOR | asOBJ_APP_ARRAY)
+ #define THISCALL_PASS_OBJECT_POINTER_ON_THE_STACK
+ #define AS_X86
++ #elif defined(__powerpc64__)
++ #define AS_BIG_ENDIAN
++ #define AS_MAX_PORTABILITY
+ #elif defined(__LP64__)
+ #define AS_X64_GCC
+ #define HAS_128_BIT_PRIMITIVES