aboutsummaryrefslogtreecommitdiff
path: root/lang/basic256
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-06-24 15:21:06 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-06-24 15:21:06 +0000
commit5645612e3f2edf5dcb225d9b8cb85708823a778b (patch)
treedfeed797bd28679d581d3eee995e780fcca83aba /lang/basic256
parent345a302cc7c5b29b4442ebc36ac61a08d060e2c6 (diff)
downloadports-5645612e3f2edf5dcb225d9b8cb85708823a778b.tar.gz
ports-5645612e3f2edf5dcb225d9b8cb85708823a778b.zip
lang/basic256: update to 1.1.2.6
PR: 191340 (based on) Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=359097
Diffstat (limited to 'lang/basic256')
-rw-r--r--lang/basic256/Makefile5
-rw-r--r--lang/basic256/distinfo4
-rw-r--r--lang/basic256/files/patch-BASIC256.pro42
-rw-r--r--lang/basic256/files/patch-BasicMediaPlayer.cpp16
-rw-r--r--lang/basic256/pkg-plist247
5 files changed, 305 insertions, 9 deletions
diff --git a/lang/basic256/Makefile b/lang/basic256/Makefile
index d32ecbb3f2e9..2e0742c22dfc 100644
--- a/lang/basic256/Makefile
+++ b/lang/basic256/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= basic256
-PORTVERSION= 1.1.0.0
+PORTVERSION= 1.1.2.6
CATEGORIES= lang
MASTER_SITES= SF
MASTER_SITE_SUBDIR= kidbasic/${PORTNAME}
@@ -19,7 +19,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USES= bison dos2unix qmake
USE_SDL= sdl mixer
-USE_QT4= corelib gui network xml webkit moc_build rcc_build uic_build
+USE_QT5= buildtools core gui multimedia network printsupport sql widgets
+QMAKE_ARGS+= LOCALBASE="${LOCALBASE}"
QMAKE_SOURCE_PATH= BASIC256.pro
MAKE_JOBS_UNSAFE= yes
diff --git a/lang/basic256/distinfo b/lang/basic256/distinfo
index 66653a7d1fe2..72e6e9040652 100644
--- a/lang/basic256/distinfo
+++ b/lang/basic256/distinfo
@@ -1,2 +1,2 @@
-SHA256 (basic256_1.1.0.0.orig.tar.gz) = e89d039a055c74b13a23890d0200af37f171b5a48a7174fb08acfb35c1506c63
-SIZE (basic256_1.1.0.0.orig.tar.gz) = 2043561
+SHA256 (basic256_1.1.2.6.orig.tar.gz) = f9b7920a4e7d042bcefb05a73c03ec5bb9e70b1118a8612a58a7a1a41d09add4
+SIZE (basic256_1.1.2.6.orig.tar.gz) = 19090301
diff --git a/lang/basic256/files/patch-BASIC256.pro b/lang/basic256/files/patch-BASIC256.pro
index f55e2df5f299..d321e0c1f84e 100644
--- a/lang/basic256/files/patch-BASIC256.pro
+++ b/lang/basic256/files/patch-BASIC256.pro
@@ -1,15 +1,47 @@
---- BASIC256.pro.orig 2014-02-15 18:45:35.000000000 +0100
-+++ BASIC256.pro 2014-02-15 18:46:10.000000000 +0100
-@@ -82,7 +82,7 @@
+--- BASIC256.pro.orig 2014-06-20 21:01:15.000000000 +0200
++++ BASIC256.pro 2014-06-20 21:03:24.000000000 +0200
+@@ -1,8 +1,4 @@
+
+-lessThan(QT_MAJOR_VERSION, 5) {
+- message( FATAL_ERROR "BASIC-256 requires QT 5 or better." )
+-}
+-
+
+ TEMPLATE = app
+ TARGET = basic256
+@@ -13,11 +9,6 @@
+ OBJECTS_DIR = tmp/obj
+ MOC_DIR = tmp/moc
+
+-QT += webkit
+-QT += gui
+-QT += sql
+-QT += widgets
+-QT += printsupport
+
+ RESOURCES += resources/resource.qrc
+ RC_FILE = resources/basic256.rc
+@@ -84,7 +75,7 @@
## TTS Option 2 - use the espeak library
DEFINES += ESPEAK
- INCLUDEPATH += /usr/include/espeak
-+ INCLUDEPATH += %%LOCALBASE%%/include/espeak
++ INCLUDEPATH += $$LOCALBASE/include/espeak
LIBS += -lespeak
LIBS += -lm
-@@ -117,19 +117,19 @@
+@@ -99,28 +90,28 @@
+
+ # Sound - QT Mobility Multimedia AudioOut
+ DEFINES += SOUND_QMOBILITY
+- QT += multimedia
+- INCLUDEPATH += QtMultimediaKit
++ INCLUDEPATH += $$LOCALBASE/include/qt5/QtMultimedia
+ INCLUDEPATH += QtMobility
++ LIBS += -L$$LOCALBASE/lib -lQt5Gui -lQt5Core -lQt5Widgets -lQt5Sql -lQt5Multimedia -lQt5PrintSupport
+
+
+ ########
# rules for make install
########
exampleFiles.files = ./Examples
diff --git a/lang/basic256/files/patch-BasicMediaPlayer.cpp b/lang/basic256/files/patch-BasicMediaPlayer.cpp
new file mode 100644
index 000000000000..c7b5f9a0aec9
--- /dev/null
+++ b/lang/basic256/files/patch-BasicMediaPlayer.cpp
@@ -0,0 +1,16 @@
+--- BasicMediaPlayer.cpp.orig 2014-06-20 20:34:01.000000000 +0200
++++ BasicMediaPlayer.cpp 2014-06-20 20:34:34.000000000 +0200
+@@ -104,11 +104,11 @@
+ }
+
+ double BasicMediaPlayer::length() {
+- return QMediaPlayer::duration() / 1000.0d;
++ return QMediaPlayer::duration() / 1000.0;
+ }
+
+ double BasicMediaPlayer::position() {
+- return QMediaPlayer::position() / 1000.0d;
++ return QMediaPlayer::position() / 1000.0;
+ }
+
+ void BasicMediaPlayer::play() {
diff --git a/lang/basic256/pkg-plist b/lang/basic256/pkg-plist
index 180efa7a78d2..632408a8d41c 100644
--- a/lang/basic256/pkg-plist
+++ b/lang/basic256/pkg-plist
@@ -1,4 +1,248 @@
bin/basic256
+%%DATADIR%%/Examples/basic256_icon.png
+%%DATADIR%%/Examples/basic256_icon_googlePlay.kbs
+%%DATADIR%%/Examples/basic256_icon_googlePlay.png
+%%DATADIR%%/Examples/dice/Data/settings/BASIC256_IDE.ini
+%%DATADIR%%/Examples/sound/README.txt
+%%DATADIR%%/Examples/sound/boing_poing.wav
+%%DATADIR%%/Examples/sound/dial-up-modem-01.mp3
+%%DATADIR%%/Examples/sound/dial-up-modem-01.wav
+%%DATADIR%%/Examples/sound/pacman_x.wav
+%%DATADIR%%/Examples/sound/wavplaystop.kbs
+%%DATADIR%%/help/el_abs.html
+%%DATADIR%%/help/el_acos.html
+%%DATADIR%%/help/el_alert.html
+%%DATADIR%%/help/el_anonymousarrays.html
+%%DATADIR%%/help/el_arc.html
+%%DATADIR%%/help/el_arrays.html
+%%DATADIR%%/help/el_asc.html
+%%DATADIR%%/help/el_asin.html
+%%DATADIR%%/help/el_atan.html
+%%DATADIR%%/help/el_call.html
+%%DATADIR%%/help/el_ceil.html
+%%DATADIR%%/help/el_changedir.html
+%%DATADIR%%/help/el_chord.html
+%%DATADIR%%/help/el_chr.html
+%%DATADIR%%/help/el_circle.html
+%%DATADIR%%/help/el_clg.html
+%%DATADIR%%/help/el_clickb.html
+%%DATADIR%%/help/el_clickclear.html
+%%DATADIR%%/help/el_clickx.html
+%%DATADIR%%/help/el_clicky.html
+%%DATADIR%%/help/el_close.html
+%%DATADIR%%/help/el_cls.html
+%%DATADIR%%/help/el_color.html
+%%DATADIR%%/help/el_commandline.html
+%%DATADIR%%/help/el_compileerrorcodes.html
+%%DATADIR%%/help/el_confirm.html
+%%DATADIR%%/help/el_continuedo.html
+%%DATADIR%%/help/el_continuefor.html
+%%DATADIR%%/help/el_continuewhile.html
+%%DATADIR%%/help/el_cos.html
+%%DATADIR%%/help/el_count.html
+%%DATADIR%%/help/el_countx.html
+%%DATADIR%%/help/el_currentdir.html
+%%DATADIR%%/help/el_day.html
+%%DATADIR%%/help/el_dbclose.html
+%%DATADIR%%/help/el_dbcloseset.html
+%%DATADIR%%/help/el_dbexecute.html
+%%DATADIR%%/help/el_dbfloat.html
+%%DATADIR%%/help/el_dbint.html
+%%DATADIR%%/help/el_dbnull.html
+%%DATADIR%%/help/el_dbopen.html
+%%DATADIR%%/help/el_dbopenset.html
+%%DATADIR%%/help/el_dbrow.html
+%%DATADIR%%/help/el_dbstring.html
+%%DATADIR%%/help/el_degrees.html
+%%DATADIR%%/help/el_dim.html
+%%DATADIR%%/help/el_dir.html
+%%DATADIR%%/help/el_do.html
+%%DATADIR%%/help/el_editvisible.html
+%%DATADIR%%/help/el_else.html
+%%DATADIR%%/help/el_end.html
+%%DATADIR%%/help/el_endfunction.html
+%%DATADIR%%/help/el_endif.html
+%%DATADIR%%/help/el_endsubroutine.html
+%%DATADIR%%/help/el_endwhile.html
+%%DATADIR%%/help/el_eof.html
+%%DATADIR%%/help/el_errorcodes.html
+%%DATADIR%%/help/el_exists.html
+%%DATADIR%%/help/el_exitdo.html
+%%DATADIR%%/help/el_exitfor.html
+%%DATADIR%%/help/el_exitwhile.html
+%%DATADIR%%/help/el_exp.html
+%%DATADIR%%/help/el_explode.html
+%%DATADIR%%/help/el_explodex.html
+%%DATADIR%%/help/el_fastgraphics.html
+%%DATADIR%%/help/el_float.html
+%%DATADIR%%/help/el_floor.html
+%%DATADIR%%/help/el_font.html
+%%DATADIR%%/help/el_for.html
+%%DATADIR%%/help/el_freedb.html
+%%DATADIR%%/help/el_freedbset.html
+%%DATADIR%%/help/el_freefile.html
+%%DATADIR%%/help/el_freenet.html
+%%DATADIR%%/help/el_frombinary.html
+%%DATADIR%%/help/el_fromhex.html
+%%DATADIR%%/help/el_fromoctal.html
+%%DATADIR%%/help/el_fromradix.html
+%%DATADIR%%/help/el_function.html
+%%DATADIR%%/help/el_getbrushcolor.html
+%%DATADIR%%/help/el_getcolor.html
+%%DATADIR%%/help/el_getpenwidth.html
+%%DATADIR%%/help/el_getsetting.html
+%%DATADIR%%/help/el_getslice.html
+%%DATADIR%%/help/el_global.html
+%%DATADIR%%/help/el_gosub.html
+%%DATADIR%%/help/el_goto.html
+%%DATADIR%%/help/el_graphheight.html
+%%DATADIR%%/help/el_graphsize.html
+%%DATADIR%%/help/el_graphvisible.html
+%%DATADIR%%/help/el_graphwidth.html
+%%DATADIR%%/help/el_hour.html
+%%DATADIR%%/help/el_if.html
+%%DATADIR%%/help/el_ifthen.html
+%%DATADIR%%/help/el_imgload.html
+%%DATADIR%%/help/el_imgsave.html
+%%DATADIR%%/help/el_implode.html
+%%DATADIR%%/help/el_include.html
+%%DATADIR%%/help/el_input.html
+%%DATADIR%%/help/el_instr.html
+%%DATADIR%%/help/el_instrx.html
+%%DATADIR%%/help/el_int.html
+%%DATADIR%%/help/el_key.html
+%%DATADIR%%/help/el_kill.html
+%%DATADIR%%/help/el_lasterror.html
+%%DATADIR%%/help/el_lasterrorextra.html
+%%DATADIR%%/help/el_lasterrorline.html
+%%DATADIR%%/help/el_lasterrormessage.html
+%%DATADIR%%/help/el_left.html
+%%DATADIR%%/help/el_length.html
+%%DATADIR%%/help/el_line.html
+%%DATADIR%%/help/el_log.html
+%%DATADIR%%/help/el_log10.html
+%%DATADIR%%/help/el_lower.html
+%%DATADIR%%/help/el_md5.html
+%%DATADIR%%/help/el_mid.html
+%%DATADIR%%/help/el_minute.html
+%%DATADIR%%/help/el_month.html
+%%DATADIR%%/help/el_mouseb.html
+%%DATADIR%%/help/el_mousex.html
+%%DATADIR%%/help/el_mousey.html
+%%DATADIR%%/help/el_msec.html
+%%DATADIR%%/help/el_netaddress.html
+%%DATADIR%%/help/el_netclose.html
+%%DATADIR%%/help/el_netconnect.html
+%%DATADIR%%/help/el_netdata.html
+%%DATADIR%%/help/el_netlisten.html
+%%DATADIR%%/help/el_netread.html
+%%DATADIR%%/help/el_netwrite.html
+%%DATADIR%%/help/el_next.html
+%%DATADIR%%/help/el_numericconstants.html
+%%DATADIR%%/help/el_offerror.html
+%%DATADIR%%/help/el_onerror.html
+%%DATADIR%%/help/el_open.html
+%%DATADIR%%/help/el_operators.html
+%%DATADIR%%/help/el_ostype.html
+%%DATADIR%%/help/el_outputvisible.html
+%%DATADIR%%/help/el_pause.html
+%%DATADIR%%/help/el_penwidth.html
+%%DATADIR%%/help/el_pie.html
+%%DATADIR%%/help/el_pixel.html
+%%DATADIR%%/help/el_plot.html
+%%DATADIR%%/help/el_poly.html
+%%DATADIR%%/help/el_portin.html
+%%DATADIR%%/help/el_portout.html
+%%DATADIR%%/help/el_print.html
+%%DATADIR%%/help/el_printercancel.html
+%%DATADIR%%/help/el_printeroff.html
+%%DATADIR%%/help/el_printeron.html
+%%DATADIR%%/help/el_printerpage.html
+%%DATADIR%%/help/el_programsyntax.html
+%%DATADIR%%/help/el_prompt.html
+%%DATADIR%%/help/el_putslice.html
+%%DATADIR%%/help/el_radians.html
+%%DATADIR%%/help/el_rand.html
+%%DATADIR%%/help/el_read.html
+%%DATADIR%%/help/el_readbyte.html
+%%DATADIR%%/help/el_readline.html
+%%DATADIR%%/help/el_rect.html
+%%DATADIR%%/help/el_redim.html
+%%DATADIR%%/help/el_ref.html
+%%DATADIR%%/help/el_refresh.html
+%%DATADIR%%/help/el_rem.html
+%%DATADIR%%/help/el_removedfeatures.html
+%%DATADIR%%/help/el_replace.html
+%%DATADIR%%/help/el_replacex.html
+%%DATADIR%%/help/el_reset.html
+%%DATADIR%%/help/el_return.html
+%%DATADIR%%/help/el_rgb.html
+%%DATADIR%%/help/el_right.html
+%%DATADIR%%/help/el_say.html
+%%DATADIR%%/help/el_second.html
+%%DATADIR%%/help/el_seek.html
+%%DATADIR%%/help/el_setsetting.html
+%%DATADIR%%/help/el_sin.html
+%%DATADIR%%/help/el_size.html
+%%DATADIR%%/help/el_sound.html
+%%DATADIR%%/help/el_spritecollide.html
+%%DATADIR%%/help/el_spritedim.html
+%%DATADIR%%/help/el_spriteh.html
+%%DATADIR%%/help/el_spritehide.html
+%%DATADIR%%/help/el_spriteload.html
+%%DATADIR%%/help/el_spritemove.html
+%%DATADIR%%/help/el_spriteplace.html
+%%DATADIR%%/help/el_spritepoly.html
+%%DATADIR%%/help/el_spriter.html
+%%DATADIR%%/help/el_sprites.html
+%%DATADIR%%/help/el_spriteshow.html
+%%DATADIR%%/help/el_spriteslice.html
+%%DATADIR%%/help/el_spritev.html
+%%DATADIR%%/help/el_spritew.html
+%%DATADIR%%/help/el_spritex.html
+%%DATADIR%%/help/el_spritey.html
+%%DATADIR%%/help/el_sqr.html
+%%DATADIR%%/help/el_stamp.html
+%%DATADIR%%/help/el_start.html
+%%DATADIR%%/help/el_string.html
+%%DATADIR%%/help/el_stringconstants.html
+%%DATADIR%%/help/el_subroutine.html
+%%DATADIR%%/help/el_system.html
+%%DATADIR%%/help/el_systemrequirements.html
+%%DATADIR%%/help/el_tan.html
+%%DATADIR%%/help/el_techinformation.html
+%%DATADIR%%/help/el_text.html
+%%DATADIR%%/help/el_textheight.html
+%%DATADIR%%/help/el_textwidth.html
+%%DATADIR%%/help/el_then.html
+%%DATADIR%%/help/el_throwerror.html
+%%DATADIR%%/help/el_tobinary.html
+%%DATADIR%%/help/el_tohex.html
+%%DATADIR%%/help/el_tooctal.html
+%%DATADIR%%/help/el_toradix.html
+%%DATADIR%%/help/el_try.html
+%%DATADIR%%/help/el_until.html
+%%DATADIR%%/help/el_upper.html
+%%DATADIR%%/help/el_variables.html
+%%DATADIR%%/help/el_version.html
+%%DATADIR%%/help/el_volume.html
+%%DATADIR%%/help/el_wavplay.html
+%%DATADIR%%/help/el_wavstop.html
+%%DATADIR%%/help/el_wavwait.html
+%%DATADIR%%/help/el_while.html
+%%DATADIR%%/help/el_whileendwhile.html
+%%DATADIR%%/help/el_write.html
+%%DATADIR%%/help/el_writebyte.html
+%%DATADIR%%/help/el_writeline.html
+%%DATADIR%%/help/el_year.html
+%%DATADIR%%/help/en_case.html
+%%DATADIR%%/help/en_expressions.html
+%%DATADIR%%/help/en_try.html
+%%DATADIR%%/help/%%QT_LIBDIR%%/exe/css0d03d48d31bb5717706fbbc1943326b5.css
+%%DATADIR%%/help/%%QT_LIBDIR%%/exe/el.png
+%%DATADIR%%/help/%%QT_LIBDIR%%/tpl/dokuwiki/images/apple-touch-icon.png
+%%DATADIR%%/help/%%QT_LIBDIR%%/tpl/dokuwiki/images/button-html5.png
+%%DATADIR%%/help/wiki_welcome.html
%%DATADIR%%/Examples/15puzzle.kbs
%%DATADIR%%/Examples/15puzzle_new.kbs
%%DATADIR%%/Examples/BASICtest1.kbs
@@ -1715,8 +1959,11 @@ bin/basic256
@dirrm %%DATADIR%%/help
@dirrm %%DATADIR%%/Examples/testing
@dirrm %%DATADIR%%/Examples/sprites
+@dirrm %%DATADIR%%/Examples/sound
@dirrm %%DATADIR%%/Examples/networking
@dirrm %%DATADIR%%/Examples/imgload
+@dirrm %%DATADIR%%/Examples/dice/Data/settings
+@dirrm %%DATADIR%%/Examples/dice/Data
@dirrm %%DATADIR%%/Examples/dice
@dirrm %%DATADIR%%/Examples
@dirrm %%DATADIR%%