aboutsummaryrefslogtreecommitdiff
path: root/lang/bsh
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-05-11 18:34:57 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-05-11 18:34:57 +0000
commit88bfe4bd43787219ab4de75bd68c490c98776dfc (patch)
tree634e1ef4990207301493f26b46d80abe56b9f2b3 /lang/bsh
parent9e8bfe9c71187ea60ac9f3a55c0c7bde80d76033 (diff)
downloadports-88bfe4bd43787219ab4de75bd68c490c98776dfc.tar.gz
ports-88bfe4bd43787219ab4de75bd68c490c98776dfc.zip
Cleanup DIST* variables.
When appropriate: - Try to use DISTVERSION{SUF,PRE}FIX - Replace PORTNAME-PORTVERSION by DISTNAME - Convert MASTER_SITES to use macros - Other light cleanup With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=386097
Diffstat (limited to 'lang/bsh')
-rw-r--r--lang/bsh/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/lang/bsh/Makefile b/lang/bsh/Makefile
index 14c56ed07615..bc48f86b175d 100644
--- a/lang/bsh/Makefile
+++ b/lang/bsh/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= bsh
-PORTVERSION= 2.0.b5
+DISTVERSION= 2.0b5
CATEGORIES= lang java
MASTER_SITES= http://svn.codespot.com/a/apache-extras.org/beanshell/src_releases/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/b/}-src
+DISTNAME= ${PORTNAME}-${DISTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= Java scripting language
@@ -28,7 +28,7 @@ PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar \
bin/${PORTNAME}
do-install:
- ${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}-${PORTVERSION:S/.b/b/}.jar \
+ ${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}-${DISTVERSION}.jar \
${STAGEDIR}${JAVAJARDIR}/${PORTNAME}.jar
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh \
${STAGEDIR}${PREFIX}/bin/${PORTNAME}