aboutsummaryrefslogtreecommitdiff
path: root/lang/chicken5
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-08-22 17:46:21 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-08-22 17:46:21 +0000
commit2bb551b2f174cdb736355bef0541c6d089ae9c67 (patch)
treebcf71b42d1927a4d5bd016c30ce4b9f7255611ef /lang/chicken5
parent157b94aa961dd2275851ed307772fcc0b4ffa9ac (diff)
downloadports-2bb551b2f174cdb736355bef0541c6d089ae9c67.tar.gz
ports-2bb551b2f174cdb736355bef0541c6d089ae9c67.zip
New port: lang/chicken5
CHICKEN is a compiler for the Scheme programming language. CHICKEN produces portable, efficient C, supports almost all of the R5RS Scheme language standard, and includes many enhancements and extensions. WWW: http://www.call-cc.org/ CHICKEN 4 and 5 are not fully compatible. Import the upcoming CHICKEN 5.0.0 as a new port. Binaries and libraries are suffixed with a 5 to avoid conflicts with lang/chicken. Changes: https://code.call-cc.org/dev-snapshots/2018/08/11/NEWS PR: 230535
Notes
Notes: svn path=/head/; revision=477802
Diffstat (limited to 'lang/chicken5')
-rw-r--r--lang/chicken5/Makefile57
-rw-r--r--lang/chicken5/distinfo3
-rw-r--r--lang/chicken5/pkg-descr6
-rw-r--r--lang/chicken5/pkg-message2
-rw-r--r--lang/chicken5/pkg-plist145
5 files changed, 213 insertions, 0 deletions
diff --git a/lang/chicken5/Makefile b/lang/chicken5/Makefile
new file mode 100644
index 000000000000..ca4fa337b8ae
--- /dev/null
+++ b/lang/chicken5/Makefile
@@ -0,0 +1,57 @@
+# Created by: Kimura Fuyuki <fuyuki@hadaly.org>
+# $FreeBSD$
+
+PORTNAME= chicken
+DISTVERSION= 5.0.0rc1
+CATEGORIES= lang scheme
+MASTER_SITES= https://code.call-cc.org/dev-snapshots/2018/08/11/
+PKGNAMESUFFIX= 5
+
+MAINTAINER= tobik@FreeBSD.org
+COMMENT= Scheme-to-C compiler
+
+USES= cpe gmake
+CPE_VENDOR= call-cc
+DATADIR= ${PREFIX}/share/chicken${PKGNAMESUFFIX}
+DOCSDIR= ${PREFIX}/share/doc/chicken${PKGNAMESUFFIX}
+MAKEFILE= GNUmakefile
+USE_LDCONFIG= yes
+MAKE_ARGS= PLATFORM=bsd \
+ PREFIX=${PREFIX} \
+ MANDIR=${PREFIX}/man \
+ LIBDIR="${PREFIX}/lib" \
+ DOCDIR="${DOCSDIR}" \
+ C_COMPILER="${CC}" \
+ CXX_COMPILER="${CXX}" \
+ LIBRARIAN="${AR}" \
+ C_COMPILER_OPTIMIZATION_OPTIONS="${CFLAGS}" \
+ LINKER_OPTIONS="${LDFLAGS}" \
+ PROGRAM_SUFFIX="${PKGNAMESUFFIX}"
+MAKE_JOBS_UNSAFE= yes
+PLIST_SUB= SUFFIX=${PKGNAMESUFFIX}
+TEST_TARGET= check
+
+OPTIONS_DEFINE= DOCS FEATHERS
+OPTIONS_SUB= yes
+
+# XXX: This should be a subpackage and on by default
+FEATHERS_DESC= Install the Feathers debugger (requires Tcl/Tk)
+
+FEATHERS_USES= tk:wrapper,run
+
+post-patch-FEATHERS-off:
+ @${REINPLACE_CMD} \
+ -e 's/feathers.1//g' \
+ -e '/INSTALL_PROGRAM.*_DEBUGGER_/{N;d;}' \
+ -e '/INSTALL_PROGRAM.*feathers/d' \
+ ${WRKSRC}/rules.make
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/c* \
+ ${STAGEDIR}${PREFIX}/lib/chicken${PKGNAMESUFFIX}/?/*.so \
+ ${STAGEDIR}${PREFIX}/lib/libchicken${PKGNAMESUFFIX}.so
+
+post-install-DOCS-on:
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/lang/chicken5/distinfo b/lang/chicken5/distinfo
new file mode 100644
index 000000000000..7b331003a574
--- /dev/null
+++ b/lang/chicken5/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1534348197
+SHA256 (chicken-5.0.0rc1.tar.gz) = fb8af147e7965761dd212b53162b181d4c9473906fd889e719c71624bca65957
+SIZE (chicken-5.0.0rc1.tar.gz) = 3998098
diff --git a/lang/chicken5/pkg-descr b/lang/chicken5/pkg-descr
new file mode 100644
index 000000000000..a8fac70e2fb8
--- /dev/null
+++ b/lang/chicken5/pkg-descr
@@ -0,0 +1,6 @@
+CHICKEN is a compiler for the Scheme programming language. CHICKEN
+produces portable, efficient C, supports almost all of the R5RS
+Scheme language standard, and includes many enhancements and
+extensions.
+
+WWW: http://www.call-cc.org/
diff --git a/lang/chicken5/pkg-message b/lang/chicken5/pkg-message
new file mode 100644
index 000000000000..a3a951c10520
--- /dev/null
+++ b/lang/chicken5/pkg-message
@@ -0,0 +1,2 @@
+Some chicken eggs require the environment variable TZ to be set in
+order to function properly. See environ(7) for more information.
diff --git a/lang/chicken5/pkg-plist b/lang/chicken5/pkg-plist
new file mode 100644
index 000000000000..b30bbda1acf2
--- /dev/null
+++ b/lang/chicken5/pkg-plist
@@ -0,0 +1,145 @@
+bin/chicken%%SUFFIX%%
+bin/chicken-do%%SUFFIX%%
+bin/chicken-install%%SUFFIX%%
+bin/chicken-profile%%SUFFIX%%
+bin/chicken-status%%SUFFIX%%
+bin/chicken-uninstall%%SUFFIX%%
+bin/csc%%SUFFIX%%
+bin/csi%%SUFFIX%%
+%%FEATHERS%%bin/feathers%%SUFFIX%%
+include/chicken%%SUFFIX%%/chicken-config.h
+include/chicken%%SUFFIX%%/chicken.h
+lib/chicken%%SUFFIX%%/9/chicken.base.import.so
+lib/chicken%%SUFFIX%%/9/chicken.bitwise.import.so
+lib/chicken%%SUFFIX%%/9/chicken.blob.import.so
+lib/chicken%%SUFFIX%%/9/chicken.compiler.user-pass.import.so
+lib/chicken%%SUFFIX%%/9/chicken.condition.import.so
+lib/chicken%%SUFFIX%%/9/chicken.continuation.import.so
+lib/chicken%%SUFFIX%%/9/chicken.csi.import.so
+lib/chicken%%SUFFIX%%/9/chicken.errno.import.so
+lib/chicken%%SUFFIX%%/9/chicken.eval.import.so
+lib/chicken%%SUFFIX%%/9/chicken.file.import.so
+lib/chicken%%SUFFIX%%/9/chicken.file.posix.import.so
+lib/chicken%%SUFFIX%%/9/chicken.fixnum.import.so
+lib/chicken%%SUFFIX%%/9/chicken.flonum.import.so
+lib/chicken%%SUFFIX%%/9/chicken.foreign.import.so
+lib/chicken%%SUFFIX%%/9/chicken.format.import.so
+lib/chicken%%SUFFIX%%/9/chicken.gc.import.so
+lib/chicken%%SUFFIX%%/9/chicken.internal.import.so
+lib/chicken%%SUFFIX%%/9/chicken.io.import.so
+lib/chicken%%SUFFIX%%/9/chicken.irregex.import.so
+lib/chicken%%SUFFIX%%/9/chicken.keyword.import.so
+lib/chicken%%SUFFIX%%/9/chicken.load.import.so
+lib/chicken%%SUFFIX%%/9/chicken.locative.import.so
+lib/chicken%%SUFFIX%%/9/chicken.memory.import.so
+lib/chicken%%SUFFIX%%/9/chicken.memory.representation.import.so
+lib/chicken%%SUFFIX%%/9/chicken.pathname.import.so
+lib/chicken%%SUFFIX%%/9/chicken.platform.import.so
+lib/chicken%%SUFFIX%%/9/chicken.plist.import.so
+lib/chicken%%SUFFIX%%/9/chicken.port.import.so
+lib/chicken%%SUFFIX%%/9/chicken.pretty-print.import.so
+lib/chicken%%SUFFIX%%/9/chicken.process-context.import.so
+lib/chicken%%SUFFIX%%/9/chicken.process-context.posix.import.so
+lib/chicken%%SUFFIX%%/9/chicken.process.import.so
+lib/chicken%%SUFFIX%%/9/chicken.process.signal.import.so
+lib/chicken%%SUFFIX%%/9/chicken.random.import.so
+lib/chicken%%SUFFIX%%/9/chicken.read-syntax.import.so
+lib/chicken%%SUFFIX%%/9/chicken.repl.import.so
+lib/chicken%%SUFFIX%%/9/chicken.sort.import.so
+lib/chicken%%SUFFIX%%/9/chicken.string.import.so
+lib/chicken%%SUFFIX%%/9/chicken.syntax.import.so
+lib/chicken%%SUFFIX%%/9/chicken.tcp.import.so
+lib/chicken%%SUFFIX%%/9/chicken.time.import.so
+lib/chicken%%SUFFIX%%/9/chicken.time.posix.import.so
+lib/chicken%%SUFFIX%%/9/srfi-4.import.so
+lib/chicken%%SUFFIX%%/9/types.db
+lib/libchicken%%SUFFIX%%.a
+lib/libchicken%%SUFFIX%%.so
+lib/libchicken%%SUFFIX%%.so.9
+man/man1/chicken-install%%SUFFIX%%.1.gz
+man/man1/chicken-profile%%SUFFIX%%.1.gz
+man/man1/chicken-status%%SUFFIX%%.1.gz
+man/man1/chicken-uninstall%%SUFFIX%%.1.gz
+man/man1/chicken%%SUFFIX%%.1.gz
+man/man1/csc%%SUFFIX%%.1.gz
+man/man1/csi%%SUFFIX%%.1.gz
+%%FEATHERS%%man/man1/feathers%%SUFFIX%%.1.gz
+%%FEATHERS%%%%DATADIR%%/feathers.tcl
+%%DATADIR%%/setup.defaults
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/manual/Accessing external objects.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Acknowledgements.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Bibliography.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Bugs and limitations.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/C interface.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Cross development.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Data representation.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Debugging.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Declarations.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Deployment.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Deviations from the standard.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Egg specification format.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Embedding.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Extension tools.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Extensions to the standard.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Extensions.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Foreign type specifiers.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Getting started.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Included modules.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Interface to external functions and variables.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken base).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken bitwise).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken blob).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken condition).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken continuation).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken csi).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken errno).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken eval).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken file posix).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken file).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken fixnum).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken flonum).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken foreign).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken format).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken gc).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken io).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken irregex).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken keyword).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken load).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken locative).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken memory representation).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken memory).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken module).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken pathname).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken platform).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken plist).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken port).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken pretty-print).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken process signal).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken process).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken process-context posix).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken process-context).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken random).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken read-syntax).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken repl).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken sort).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken string).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken syntax).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken tcp).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken time posix).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken time).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module r4rs.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module r5rs.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module scheme.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module srfi-4.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Modules.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/The User's Manual.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Types.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Units and linking model.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Using the compiler.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Using the interpreter.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/manual.css
+@postexec %D/bin/chicken-install%%SUFFIX%% -update-db
+@postunexec rm -f %D/lib/chicken%%SUFFIX%%/9/modules.db