aboutsummaryrefslogtreecommitdiff
path: root/lang/chicken
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2022-09-08 13:08:19 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2022-09-08 13:08:19 +0000
commit17e9c85e7038cd627570ba122bf020ef3812a39b (patch)
treee8af7e36c702e360611ff07d9dfa0ced4ba2fcab /lang/chicken
parentb2563f98f51a9e84169de2951b105b645a993ab5 (diff)
downloadports-17e9c85e7038cd627570ba122bf020ef3812a39b.tar.gz
ports-17e9c85e7038cd627570ba122bf020ef3812a39b.zip
lang/chicken: restore unsuffixed chicken port
The lang/chicken5 port was introduced to help migrating from v4 in lang/chicken. The latter is not long gone, and we're left with a '5' suffix everywhere. Let's put a copy of chicken v5 in lang/chicken, with a plan to remove lang/chicken5 in two months. The use of PORTEPOCH is necessary because it was there in chicken v4.
Diffstat (limited to 'lang/chicken')
-rw-r--r--lang/chicken/Makefile56
-rw-r--r--lang/chicken/distinfo3
-rw-r--r--lang/chicken/pkg-descr4
-rw-r--r--lang/chicken/pkg-message7
-rw-r--r--lang/chicken/pkg-plist148
5 files changed, 218 insertions, 0 deletions
diff --git a/lang/chicken/Makefile b/lang/chicken/Makefile
new file mode 100644
index 000000000000..989aae528407
--- /dev/null
+++ b/lang/chicken/Makefile
@@ -0,0 +1,56 @@
+PORTNAME= chicken
+DISTVERSION= 5.3.0
+PORTEPOCH= 1
+CATEGORIES= lang scheme
+MASTER_SITES= https://code.call-cc.org/releases/${DISTVERSION}/
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Scheme-to-C compiler
+WWW= https://www.call-cc.org/
+
+LICENSE= BSD3CLAUSE PD
+LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cpe gmake
+CPE_VENDOR= call-cc
+USE_LDCONFIG= yes
+
+MAKEFILE= GNUmakefile
+MAKE_ARGS= C_COMPILER="${CC}" \
+ C_COMPILER_OPTIMIZATION_OPTIONS="${CFLAGS}" \
+ CXX_COMPILER="${CXX}" \
+ DOCDIR="${DOCSDIR}" \
+ LIBDIR="${PREFIX}/lib" \
+ LIBRARIAN="${AR}" \
+ LINKER_OPTIONS="${LDFLAGS}" \
+ MANDIR=${PREFIX}/man \
+ PREFIX=${PREFIX}
+# parallel build not supported
+MAKE_JOBS_UNSAFE= yes
+TEST_TARGET= check
+
+DATADIR= ${PREFIX}/share/chicken
+DOCSDIR= ${PREFIX}/share/doc/chicken
+
+PLIST_SUB= BINARYVERSION=${_CHICKEN_BINARYVERSION}
+
+OPTIONS_DEFINE= DOCS FEATHERS
+OPTIONS_SUB= yes
+
+# XXX: This should be a subpackage and on by default
+FEATHERS_DESC= Install the Feathers debugger (requires Tcl/Tk)
+
+FEATHERS_USES= tk:wrapper,run
+
+_CHICKEN_BINARYVERSION= 11
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/c* \
+ ${STAGEDIR}${PREFIX}/lib/chicken/${_CHICKEN_BINARYVERSION}/*.so \
+ ${STAGEDIR}${PREFIX}/lib/libchicken.so
+
+post-install-DOCS-on:
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/lang/chicken/distinfo b/lang/chicken/distinfo
new file mode 100644
index 000000000000..fff5f495bc54
--- /dev/null
+++ b/lang/chicken/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1637825548
+SHA256 (chicken-5.3.0.tar.gz) = c3ad99d8f9e17ed810912ef981ac3b0c2e2f46fb0ecc033b5c3b6dca1bdb0d76
+SIZE (chicken-5.3.0.tar.gz) = 4069549
diff --git a/lang/chicken/pkg-descr b/lang/chicken/pkg-descr
new file mode 100644
index 000000000000..3490c323a9c2
--- /dev/null
+++ b/lang/chicken/pkg-descr
@@ -0,0 +1,4 @@
+CHICKEN is a compiler for the Scheme programming language. CHICKEN
+produces portable, efficient C, supports almost all of the R5RS
+Scheme language standard, and includes many enhancements and
+extensions.
diff --git a/lang/chicken/pkg-message b/lang/chicken/pkg-message
new file mode 100644
index 000000000000..a12ee8a409e1
--- /dev/null
+++ b/lang/chicken/pkg-message
@@ -0,0 +1,7 @@
+[
+{ message: <<EOM
+Some chicken eggs require the environment variable TZ to be set in
+order to function properly. See environ(7) for more information.
+EOM
+ type: install }
+]
diff --git a/lang/chicken/pkg-plist b/lang/chicken/pkg-plist
new file mode 100644
index 000000000000..dbee61e7025d
--- /dev/null
+++ b/lang/chicken/pkg-plist
@@ -0,0 +1,148 @@
+bin/chicken
+bin/chicken-do
+bin/chicken-install
+bin/chicken-profile
+bin/chicken-status
+bin/chicken-uninstall
+bin/csc
+bin/csi
+%%FEATHERS%%bin/feathers
+include/chicken/chicken-config.h
+include/chicken/chicken.h
+lib/chicken/%%BINARYVERSION%%/chicken.base.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.bitwise.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.blob.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.compiler.user-pass.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.condition.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.continuation.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.csi.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.errno.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.eval.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.file.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.file.posix.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.fixnum.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.flonum.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.foreign.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.format.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.gc.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.internal.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.io.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.irregex.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.keyword.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.load.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.locative.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.memory.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.memory.representation.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.pathname.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.platform.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.plist.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.port.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.pretty-print.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.process-context.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.process-context.posix.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.process.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.process.signal.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.random.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.read-syntax.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.repl.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.sort.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.string.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.syntax.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.tcp.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.time.import.so
+lib/chicken/%%BINARYVERSION%%/chicken.time.posix.import.so
+lib/chicken/%%BINARYVERSION%%/srfi-4.import.so
+lib/chicken/%%BINARYVERSION%%/types.db
+lib/libchicken.a
+lib/libchicken.so
+lib/libchicken.so.%%BINARYVERSION%%
+man/man1/chicken-do.1.gz
+man/man1/chicken-install.1.gz
+man/man1/chicken-profile.1.gz
+man/man1/chicken-status.1.gz
+man/man1/chicken-uninstall.1.gz
+man/man1/chicken.1.gz
+man/man1/csc.1.gz
+man/man1/csi.1.gz
+%%FEATHERS%%man/man1/feathers.1.gz
+%%FEATHERS%%%%DATADIR%%/feathers.tcl
+%%DATADIR%%/setup.defaults
+%%PORTDOCS%%%%DOCSDIR%%/DEPRECATED
+@comment %%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/manual/Accessing external objects.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Acknowledgements.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Bibliography.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Bugs and limitations.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/C interface.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Cross development.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Data representation.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Debugging.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Declarations.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Deployment.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Deviations from the standard.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Egg specification format.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Embedding.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Extension tools.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Extensions to the standard.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Extensions.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Foreign type specifiers.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Getting started.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Included modules.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Interface to external functions and variables.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken base).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken bitwise).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken blob).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken condition).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken continuation).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken csi).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken errno).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken eval).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken file posix).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken file).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken fixnum).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken flonum).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken foreign).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken format).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken gc).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken io).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken irregex).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken keyword).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken load).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken locative).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken memory representation).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken memory).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken module).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken pathname).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken platform).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken plist).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken port).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken pretty-print).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken process signal).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken process).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken process-context posix).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken process-context).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken random).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken read-syntax).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken repl).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken sort).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken string).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken syntax).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken tcp).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken time posix).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken time).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module (chicken type).html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module r4rs.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module r5rs.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module scheme.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Module srfi-4.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Modules.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/The User's Manual.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Types.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Units and linking model.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Using the compiler.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Using the interpreter.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/manual.css
+@postexec %D/bin/chicken-install -update-db
+@postunexec rm -f %D/lib/chicken/%%BINARYVERSION%%/modules.db