aboutsummaryrefslogtreecommitdiff
path: root/lang/cocor
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2009-03-25 12:35:49 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2009-03-25 12:35:49 +0000
commit578a084158e82c07af6b0ea8f60bc118fe5f20f9 (patch)
tree042ff878f6f465b2914e79a28b0637ad947ec843 /lang/cocor
parent127c2957dc0be71440acb8d617195b744f04ceca (diff)
downloadports-578a084158e82c07af6b0ea8f60bc118fe5f20f9.tar.gz
ports-578a084158e82c07af6b0ea8f60bc118fe5f20f9.zip
Fix make -j
Notes
Notes: svn path=/head/; revision=230958
Diffstat (limited to 'lang/cocor')
-rw-r--r--lang/cocor/Makefile5
-rw-r--r--lang/cocor/files/patch-taste-unix.mk29
-rw-r--r--lang/cocor/files/patch-taste_cp::unix.mk31
3 files changed, 62 insertions, 3 deletions
diff --git a/lang/cocor/Makefile b/lang/cocor/Makefile
index 93fbfb50a90d..042e737759fe 100644
--- a/lang/cocor/Makefile
+++ b/lang/cocor/Makefile
@@ -19,7 +19,6 @@ COMMENT= A compiler generator that combines the functionality of lex and yacc
WRKSRC= ${WRKDIR}
ALL_TARGET= all1
MAKE_ENV+= CRFRAMES=${WRKSRC}/frames
-USE_GMAKE= yes
CFLAGS+= -I${WRKSRC}/cplus2
PLIST_SUB+= FRAMES=${CRFRAMES}
CRFRAMES?= ${PREFIX}/lib/cocor
@@ -34,6 +33,10 @@ pre-patch:
${CHMOD} +x ${WRKSRC}/dos2unix.sh
cd ${WRKSRC} && ./dos2unix.sh unix.mk && ${MAKE} -f unix.mk dos2unix
+post-patch:
+ ${REINPLACE_CMD} -e "s,^MAKE,#MAKE," ${WRKSRC}/Makefile
+ ${RM} ${WRKSRC}/taste/unix.mk.orig
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cocor ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/docs/cocor.1 ${PREFIX}/man/man1
diff --git a/lang/cocor/files/patch-taste-unix.mk b/lang/cocor/files/patch-taste-unix.mk
new file mode 100644
index 000000000000..d6ddd8c3fcac
--- /dev/null
+++ b/lang/cocor/files/patch-taste-unix.mk
@@ -0,0 +1,29 @@
+--- taste/unix.mk.orig 2009-03-25 13:30:16.000000000 +0100
++++ taste/unix.mk 2009-03-25 13:30:36.000000000 +0100
+@@ -27,7 +27,7 @@
+ $(CC) $(CFLAGS) -otaste taste.o tl.o tc.o\
+ tastes.o tastep.o
+
+-tastep.o: taste.atg
++tastep.o taste.o: taste.atg
+ $(COCOR) taste.atg
+ $(CC) $(CFLAGS) -c taste.c tastep.c tastes.c
+
+@@ -35,7 +35,7 @@
+ $(CC) $(CFLAGS) -opretty pretty.o prettypr.o \
+ prettys.o prettyp.o
+
+-prettyp.o: pretty.atg
++prettyp.o pretty.o: pretty.atg
+ $(COCOR) pretty.atg
+ $(CC) $(CFLAGS) -c pretty.c prettyp.c prettys.c
+
+@@ -43,7 +43,7 @@
+ $(CC) $(CFLAGS) -oxref xref.o crossref.o \
+ xrefs.o xrefp.o
+
+-xrefp.o: xref.atg
++xrefp.o xref.o: xref.atg
+ $(COCOR) xref.atg
+ $(CC) $(CFLAGS) -c xref.c xrefp.c xrefs.c
+
diff --git a/lang/cocor/files/patch-taste_cp::unix.mk b/lang/cocor/files/patch-taste_cp::unix.mk
index b723ce5105ef..c44cc34badeb 100644
--- a/lang/cocor/files/patch-taste_cp::unix.mk
+++ b/lang/cocor/files/patch-taste_cp::unix.mk
@@ -1,5 +1,5 @@
---- taste_cp/unix.mk.orig Sat Jan 18 01:58:29 2003
-+++ taste_cp/unix.mk Sat Jan 18 01:59:37 2003
+--- taste_cp/unix.mk.orig 2009-03-25 13:31:23.000000000 +0100
++++ taste_cp/unix.mk 2009-03-25 13:33:00.000000000 +0100
@@ -8,17 +8,17 @@
#CC sets the name of the compiler to use (cc, gcc, etc)
@@ -21,3 +21,30 @@
$(CC) -c $(CFLAGS) $< -o $@
all: taste pretty xref
+@@ -38,7 +38,7 @@
+ $(CC) $(CFLAGS) -otaste taste.o tl.o tc.o\
+ tastes.o tastep.o $(LIB)
+
+-tastep.o: taste.atg
++tastep.o taste.o: taste.atg
+ $(COCOR) taste.atg
+ $(CC) $(CFLAGS) -c taste.c?? tastep.c?? tastes.c??
+
+@@ -46,7 +46,7 @@
+ $(CC) $(CFLAGS) -opretty pretty.o prettypr.o \
+ prettys.o prettyp.o $(LIB)
+
+-prettyp.o: pretty.atg
++prettyp.o pretty.o: pretty.atg
+ $(COCOR) pretty.atg
+ $(CC) $(CFLAGS) -c pretty.c?? prettyp.c?? prettys.c??
+
+@@ -54,7 +54,7 @@
+ $(CC) $(CFLAGS) -oxref xref.o crossref.o \
+ xrefs.o xrefp.o $(LIB)
+
+-xrefp.o: xref.atg
++xrefp.o xref.o: xref.atg
+ $(COCOR) xref.atg
+ $(CC) $(CFLAGS) -c xref.c?? xrefp.c?? xrefs.c??
+