aboutsummaryrefslogtreecommitdiff
path: root/lang/dmd2
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2011-03-03 05:13:38 +0000
committerCy Schubert <cy@FreeBSD.org>2011-03-03 05:13:38 +0000
commit1fa2f8be00d1e174734ef292b2864762c4714469 (patch)
tree02e07c51f0e7fcd4603d51272cbdac24516bde1d /lang/dmd2
parentdd3ba2e2ba385893d061156990b1b0c6aaff2940 (diff)
downloadports-1fa2f8be00d1e174734ef292b2864762c4714469.tar.gz
ports-1fa2f8be00d1e174734ef292b2864762c4714469.zip
Notes
Diffstat (limited to 'lang/dmd2')
-rw-r--r--lang/dmd2/Makefile4
-rw-r--r--lang/dmd2/distinfo4
-rw-r--r--lang/dmd2/files/patch-phobos-std-c-freebsd-socket.d80
-rw-r--r--lang/dmd2/pkg-plist1
4 files changed, 4 insertions, 85 deletions
diff --git a/lang/dmd2/Makefile b/lang/dmd2/Makefile
index 8e66da19efd2..b3e47c533abe 100644
--- a/lang/dmd2/Makefile
+++ b/lang/dmd2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dmd
PKGNAMESUFFIX= 2
-PORTVERSION= 2.051
+PORTVERSION= 2.052
CATEGORIES= lang
MASTER_SITES= http://ftp.digitalmars.com/
DISTNAME= dmd.${PORTVERSION}
@@ -72,7 +72,7 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/dmd2/linux/bin/dmd.conf ${PREFIX}/etc/dmd2.conf
.endif
${INSTALL_PROGRAM} ${WRKSRC}/dmd ${PREFIX}/bin/dmd2
- ${INSTALL_DATA} ${WRKSRC}/../phobos/generated/freebsd/release/libphobos2.a ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/../phobos/generated/freebsd/release/32/libphobos2.a ${PREFIX}/lib
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKDIR}/dmd2/linux/bin/dmd.conf ${EXAMPLESDIR}/dmd2.conf
cd ${WRKDIR}/dmd2 && ${COPYTREE_SHARE} samples ${EXAMPLESDIR}
diff --git a/lang/dmd2/distinfo b/lang/dmd2/distinfo
index 2a764db5b048..bffce6c8a13c 100644
--- a/lang/dmd2/distinfo
+++ b/lang/dmd2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dmd.2.051.zip) = 7540a3763c82e98dc3ca30e3b2ffb09ae06d4b7f45a8d9ac6bf43a76dc6c68a2
-SIZE (dmd.2.051.zip) = 10747172
+SHA256 (dmd.2.052.zip) = decd1fa193dd8f60cb41b4b7f887a761a766c557b0568d24b15aadc08d0f6742
+SIZE (dmd.2.052.zip) = 12669839
diff --git a/lang/dmd2/files/patch-phobos-std-c-freebsd-socket.d b/lang/dmd2/files/patch-phobos-std-c-freebsd-socket.d
deleted file mode 100644
index 7ce83d9b8747..000000000000
--- a/lang/dmd2/files/patch-phobos-std-c-freebsd-socket.d
+++ /dev/null
@@ -1,80 +0,0 @@
---- /dev/null
-+++ ../phobos/std/c/freebsd/socket.d
-@@ -0,0 +1,77 @@
-+// Written in the D programming language.
-+
-+/*
-+ * This module is just for making std.socket work under FreeBSD, and these
-+ * definitions should actually be in druntime. (core.sys.posix.netdb or sth)
-+ */
-+module std.c.freebsd.socket;
-+
-+import core.sys.posix.sys.socket;
-+
-+extern(C):
-+
-+enum // <sys/socket.h> __BSD_VISIBLE
-+{
-+ AF_APPLETALK = 16,
-+ AF_IPX = 23,
-+}
-+
-+enum // <sys/socket.h> __BSD_VISIBLE
-+{
-+ SOCK_RDM = 4,
-+}
-+
-+enum // <sys/socket.h> __BSD_VISIBLE
-+{
-+ MSG_NOSIGNAL = 0x20000,
-+}
-+
-+enum // <netinet/in.h> __BSD_VISIBLE
-+{
-+ IPPROTO_IGMP = 2,
-+ IPPROTO_GGP = 3,
-+ IPPROTO_PUP = 12,
-+ IPPROTO_IDP = 22,
-+ IPPROTO_ND = 77,
-+ IPPROTO_MAX = 256,
-+}
-+
-+enum // <netinet/in.h>
-+{
-+ INADDR_LOOPBACK = 0x7f000001,
-+ INADDR_NONE = 0xffffffff,
-+}
-+
-+
-+/*========== <netdb.h> ==========*/
-+
-+struct hostent
-+{
-+ char* h_name;
-+ char** h_aliases;
-+ int h_addrtype;
-+ int h_length;
-+ char** h_addr_list;
-+}
-+
-+struct servent
-+{
-+ char* s_name;
-+ char** s_aliases;
-+ int s_port;
-+ char* s_proto;
-+}
-+
-+struct protoent
-+{
-+ char* p_name;
-+ char** p_aliases;
-+ int p_proto;
-+}
-+
-+hostent* gethostbyaddr(in void*, socklen_t, int); // obsolete
-+hostent* gethostbyname(in char*); // obsolete
-+protoent* getprotobyname(in char *);
-+protoent* getprotobynumber(int);
-+servent* getservbyname(in char*, in char*);
-+servent* getservbyport(int, in char*);
diff --git a/lang/dmd2/pkg-plist b/lang/dmd2/pkg-plist
index 210d1b9b783d..d907e094f2df 100644
--- a/lang/dmd2/pkg-plist
+++ b/lang/dmd2/pkg-plist
@@ -122,7 +122,6 @@ include/d/phobos2/std/bitmanip.d
include/d/phobos2/std/boxer.d
include/d/phobos2/std/c/fenv.d
include/d/phobos2/std/c/freebsd/socket.d
-include/d/phobos2/std/c/freebsd/socket.d.orig
include/d/phobos2/std/c/linux/linux.d
include/d/phobos2/std/c/linux/pthread.d
include/d/phobos2/std/c/linux/socket.d