aboutsummaryrefslogtreecommitdiff
path: root/lang/ecl/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2015-09-15 10:48:36 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2015-09-15 10:48:36 +0000
commit3858e592a340fcc67cc42f1f164eae138d85e737 (patch)
tree1b6a166aa4365e9c857c98eb1b5640a579a1f1b3 /lang/ecl/Makefile
parent143758dcf6f4aa47ebc7d57ad471a6cfb3dfc378 (diff)
downloadports-3858e592a340fcc67cc42f1f164eae138d85e737.tar.gz
ports-3858e592a340fcc67cc42f1f164eae138d85e737.zip
- Switch to options helpers
- Add missing files to plist (THREADS option) PR: 203051 Submitted by: amdmi3
Notes
Notes: svn path=/head/; revision=396952
Diffstat (limited to 'lang/ecl/Makefile')
-rw-r--r--lang/ecl/Makefile71
1 files changed, 26 insertions, 45 deletions
diff --git a/lang/ecl/Makefile b/lang/ecl/Makefile
index 57b5e3a472c0..f570fc468396 100644
--- a/lang/ecl/Makefile
+++ b/lang/ecl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ecl
PORTVERSION= 15.3.7
+PORTREVISION= 1
CATEGORIES= lang lisp
MASTER_SITES= SF/${PORTNAME}s/${PORTNAME}s/15.3/
@@ -33,53 +34,33 @@ DFFI_DESC= Dynamic foreign-function support
OPTIONS_SUB= yes
PLIST_SUB= VERSION="${PORTVERSION}"
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ${ARCH}
-.endif
-
-.if ${PORT_OPTIONS:MASDF}
-CONFIGURE_ARGS+=--with-asdf=yes
-.else
-CONFIGURE_ARGS+=--with-asdf=no
-.endif
-
-.if ${PORT_OPTIONS:MCLX}
-USE_XORG= x11
-CONFIGURE_ARGS+=--with-clx=yes
-.else
-CONFIGURE_ARGS+=--with-clx=no
-.endif
-
-.if ${PORT_OPTIONS:MSOCKETS}
-CONFIGURE_ARGS+=--with-tcp=yes
-.else
-CONFIGURE_ARGS+=--with-tcp=no
-.endif
-
-.if ${PORT_OPTIONS:MDFFI}
-CONFIGURE_ARGS+=--with-dffi=system
-LIB_DEPENDS+= libffi.so:${PORTSDIR}/devel/libffi
-.else
-CONFIGURE_ARGS+=--with-dffi=no
-.endif
-
-.if ${PORT_OPTIONS:MTHREADS}
-CONFIGURE_ARGS+=--enable-threads=yes
-LDFLAGS+= -lpthread
-LIB_DEPENDS+= libgc-threaded.so:${PORTSDIR}/devel/boehm-gc-threaded
-.else
-CONFIGURE_ARGS+=--enable-threads=no
-LIB_DEPENDS+= libgc.so:${PORTSDIR}/devel/boehm-gc
-.endif
-
-.if ${PORT_OPTIONS:MTHREADS}
-post-patch:
+BROKEN_ia64= does not compile
+BROKEN_sparc64= does not compile
+
+ASDF_CONFIGURE_ON= --with-asdf=yes
+ASDF_CONFIGURE_OFF= --with-asdf=no
+
+CLX_USE= XORG=x11
+CLX_CONFIGURE_ON= --with-clx=yes
+CLX_CONFIGURE_OFF= --with-clx=no
+
+SOCKETS_CONFIGURE_ON= --with-tcp=yes
+SOCKETS_CONFIGURE_OFF= --with-tcp=no
+
+DFFI_LIB_DEPENDS= libffi.so:${PORTSDIR}/devel/libffi
+DFFI_CONFIGURE_ON= --with-dffi=system
+DFFI_CONFIGURE_OFF= --with-dffi=no
+
+THREADS_CONFIGURE_ON= --enable-threads=yes
+THREADS_LDFLAGS= -lpthread
+THREADS_LIB_DEPENDS= libgc-threaded.so:${PORTSDIR}/devel/boehm-gc-threaded
+THREADS_CONFIGURE_OFF= --enable-threads=no
+THREADS_LIB_DEPENDS_OFF= libgc.so:${PORTSDIR}/devel/boehm-gc
+
+post-patch-THREADS-on:
@${REINPLACE_CMD} -e 's|-lgc|-lgc-threaded|' ${WRKSRC}/src/configure
-.endif
post-install:
${RMDIR} ${STAGEDIR}${PREFIX}/include/ecl/gc/private
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>