aboutsummaryrefslogtreecommitdiff
path: root/lang/ecl/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-25 12:58:33 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-25 12:58:33 +0000
commitd945d5ea982deadca9e8b17c2e7f4f928fe6d9ee (patch)
treeb03cfdc045d4887da1bbcf9872d0180f879152a5 /lang/ecl/Makefile
parent3580698ace693e3fa8ae6efd6422c8ffe0baf00b (diff)
downloadports-d945d5ea982deadca9e8b17c2e7f4f928fe6d9ee.tar.gz
ports-d945d5ea982deadca9e8b17c2e7f4f928fe6d9ee.zip
lang category: Remove $PTHREAD_LIBS
Note: ecl did not pass check-plist (pre-existing), PR 198897 submitted. approved by: PTHREAD blanket
Notes
Notes: svn path=/head/; revision=382211
Diffstat (limited to 'lang/ecl/Makefile')
-rw-r--r--lang/ecl/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/lang/ecl/Makefile b/lang/ecl/Makefile
index 78e840ce3c80..fc8eaa17b444 100644
--- a/lang/ecl/Makefile
+++ b/lang/ecl/Makefile
@@ -70,7 +70,7 @@ CONFIGURE_ARGS+=--with-dffi=no
.if ${PORT_OPTIONS:MTHREADS}
CONFIGURE_ARGS+=--enable-threads=yes
-LDFLAGS+= ${PTHREAD_LIBS}
+LDFLAGS+= -lpthread
LIB_DEPENDS+= libgc-threaded.so:${PORTSDIR}/devel/boehm-gc-threaded
.else
CONFIGURE_ARGS+=--enable-threads=no
@@ -79,8 +79,7 @@ LIB_DEPENDS+= libgc.so:${PORTSDIR}/devel/boehm-gc
.if ${PORT_OPTIONS:MTHREADS}
post-patch:
- @${REINPLACE_CMD} -e 's|-lgc|-lgc-threaded|' \
- -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/src/configure
+ @${REINPLACE_CMD} -e 's|-lgc|-lgc-threaded|' ${WRKSRC}/src/configure
.endif
.include <bsd.port.post.mk>