aboutsummaryrefslogtreecommitdiff
path: root/lang/eisl
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-26 06:50:40 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-26 06:51:29 +0000
commitf2cf9b9781ebbb7594c67df2da1cd8a6c9d1bd10 (patch)
tree433ca48dd2814b33e4da799e8d6f06267bb02ec1 /lang/eisl
parent922486b14b714ab59c295c6aef71217435cf891f (diff)
downloadports-f2cf9b9781ebbb7594c67df2da1cd8a6c9d1bd10.tar.gz
ports-f2cf9b9781ebbb7594c67df2da1cd8a6c9d1bd10.zip
lang/eisl: Update 2.50 -> 2.50-114; Broken on riscv64
Diffstat (limited to 'lang/eisl')
-rw-r--r--lang/eisl/Makefile5
-rw-r--r--lang/eisl/distinfo6
-rw-r--r--lang/eisl/files/patch-extension.c31
3 files changed, 7 insertions, 35 deletions
diff --git a/lang/eisl/Makefile b/lang/eisl/Makefile
index 6c7097cb0550..882b4c6c2963 100644
--- a/lang/eisl/Makefile
+++ b/lang/eisl/Makefile
@@ -1,6 +1,7 @@
PORTNAME= eisl
DISTVERSIONPREFIX= v
-DISTVERSION= 2.50
+DISTVERSION= 2.50-114
+DISTVERSIONSUFFIX= -g1216d9e
CATEGORIES= lang devel
MAINTAINER= yuri@FreeBSD.org
@@ -9,6 +10,8 @@ COMMENT= Interpreter and compiler compatible with ISLisp standard
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/documents/license.txt
+BROKEN_riscv64= hard-float 'd' ABI can't be used for a target that doesn't support the D instruction set extension (ignoring target-abi)
+
USES= gmake ncurses:base
USE_GITHUB= yes
diff --git a/lang/eisl/distinfo b/lang/eisl/distinfo
index 6991dedc0173..a31ebdbc2c27 100644
--- a/lang/eisl/distinfo
+++ b/lang/eisl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1655278281
-SHA256 (sasagawa888-eisl-v2.50_GH0.tar.gz) = 7a06b0e2396f7b036c7a5e8fa77cbe1e437e676406c7fb3b320e322a428998a9
-SIZE (sasagawa888-eisl-v2.50_GH0.tar.gz) = 1757697
+TIMESTAMP = 1658817282
+SHA256 (sasagawa888-eisl-v2.50-114-g1216d9e_GH0.tar.gz) = 11d3cfd226d5e302fa8302b39f9c8034c8780c1a6039072fcacc46e063d95d8a
+SIZE (sasagawa888-eisl-v2.50-114-g1216d9e_GH0.tar.gz) = 1893120
diff --git a/lang/eisl/files/patch-extension.c b/lang/eisl/files/patch-extension.c
deleted file mode 100644
index 8cd8a1c673d1..000000000000
--- a/lang/eisl/files/patch-extension.c
+++ /dev/null
@@ -1,31 +0,0 @@
-- disable wiringPi.h to unbreak on arm until upstream fixes this for good, see https://github.com/sasagawa888/eisl/issues/180
-
---- extension.c.orig 2022-07-19 08:14:48 UTC
-+++ extension.c
-@@ -1,7 +1,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <math.h>
--#ifdef __arm__
-+#if 0 && defined(__arm__)
- #include <wiringPi.h>
- #include <wiringPiSPI.h>
- #endif
-@@ -47,7 +47,7 @@ initexsubr (void)
- defsubr ("EISL-TEST", f_eisl_test);
-
-
--#ifdef __arm__
-+#if 0 && defined(__arm__)
- defsubr ("WIRINGPI-SETUP-GPIO", f_wiringpi_setup_gpio);
- defsubr ("WIRINGPI-SPI-SETUP-CH-SPEED", f_wiringpi_spi_setup_ch_speed);
- defsubr ("PWM-SET-MODE", f_pwm_set_mode);
-@@ -454,7 +454,7 @@ f_instance (int arglist)
- }
-
- // ----------for Raspberry PI
--#ifdef __arm__
-+#if 0 && defined(__arm__)
- int
- f_wiringpi_setup_gpio (int arglist __unused)
- {