aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang-java
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2019-05-28 21:38:10 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2019-05-28 21:38:10 +0000
commit3eb67b2b7d340d556fe51b10ce90c981030d88a2 (patch)
treefe4a354bc54af0635f5bb95a02dc55d8fce36eef /lang/erlang-java
parent48e1b561182e02d304eeb570cb2cff504f10fb31 (diff)
downloadports-3eb67b2b7d340d556fe51b10ce90c981030d88a2.tar.gz
ports-3eb67b2b7d340d556fe51b10ce90c981030d88a2.zip
lang/erlang-java: add APP_VERSION check.
Check that the specified APP_VERSION matches the value in vsn.mk, as there is no other way to know if the Makefile is correct when updating the port.
Notes
Notes: svn path=/head/; revision=502921
Diffstat (limited to 'lang/erlang-java')
-rw-r--r--lang/erlang-java/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/erlang-java/Makefile b/lang/erlang-java/Makefile
index 25c83948546c..425bacd43c24 100644
--- a/lang/erlang-java/Makefile
+++ b/lang/erlang-java/Makefile
@@ -26,7 +26,6 @@ MAKE_JOBS_UNSAFE=yes
PLIST_SUB= APP_VERSION=${APP_VERSION}
-# always check the app version in otp_versions.table
APP_VERSION= 1.9.1
APP_DIR= ${PREFIX}/lib/erlang/lib/jinterface-${APP_VERSION}
@@ -42,6 +41,9 @@ do-build:
${RM} -r ${WRKSRC}/lib/jinterface/priv/com
do-install:
+ @if [ ! $$(${CAT} ${WRKSRC}/lib/jinterface/vsn.mk | ${CUT} -w -f3) = ${APP_VERSION} ]; then \
+ ${ECHO_MSG} "===> APP_VERSION (${APP_VERSION}) in Makefile does not match value in lib/jinterface/vsn.mk"; exit 1; \
+ fi
@${MKDIR} ${STAGEDIR}${APP_DIR}
@${MKDIR} ${STAGEDIR}${APP_DIR}/priv
cd ${WRKSRC}/lib/jinterface && ${COPYTREE_SHARE} ebin ${STAGEDIR}${APP_DIR}