aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang-runtime22
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2021-04-08 07:58:18 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2021-04-10 19:25:39 +0000
commitf634fc8e1c03d7c163e0b2e70566e8e19c2437e9 (patch)
tree36a8a8579d64a9d4ccdc1a3862cec19c327331e2 /lang/erlang-runtime22
parent184fb3b97dad08d285e583c05a20ad8d71875d3d (diff)
Diffstat (limited to 'lang/erlang-runtime22')
-rw-r--r--lang/erlang-runtime22/Makefile53
1 files changed, 28 insertions, 25 deletions
diff --git a/lang/erlang-runtime22/Makefile b/lang/erlang-runtime22/Makefile
index 2b221dd7a44d..c8c9d4da162a 100644
--- a/lang/erlang-runtime22/Makefile
+++ b/lang/erlang-runtime22/Makefile
@@ -21,19 +21,20 @@ GH_PROJECT= otp:otp corba:corba
GH_TAGNAME= 4.5.2:corba
USE_PERL5= build
-DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
+DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
WRKSRC= ${WRKSRC_otp}
GNU_CONFIGURE= yes
-MAKE_JOBS_UNSAFE=yes
+MAKE_JOBS_UNSAFE= yes
SUB_FILES= pkg-message
SUB_LIST= ERLANG_LIB=${ERLANG_LIB}
ERLANG_LIB= ${PORTNAME}${PORTVERSION:C/\..*//}
-OPTIONS_DEFINE= CORBA DIRTY DTRACE HIPE JAVA KQUEUE NATIVE ODBC OPENSSL SCTP THREADS WX
-OPTIONS_DEFAULT=CORBA DIRTY DTRACE KQUEUE OPENSSL SCTP THREADS
+OPTIONS_DEFINE= CORBA DIRTY DTRACE HIPE JAVA KQUEUE NATIVE ODBC OPENSSL \
+ SCTP THREADS WX
+OPTIONS_DEFAULT= CORBA DIRTY DTRACE KQUEUE OPENSSL SCTP THREADS
OPTIONS_EXCLUDE_powerpc64= HIPE
OPTIONS_EXCLUDE_riscv64= DTRACE
@@ -54,9 +55,9 @@ OPTIONS_EXCLUDE+= DTRACE
OPTIONS_EXCLUDE_DragonFly= HIPE NATIVE SCTP
# ld(1) fails to link probes: missing __dtrace_erlang___* symbols
OPTIONS_EXCLUDE_aarch64= DTRACE
-OPTIONS_EXCLUDE_armv6= DTRACE
-OPTIONS_EXCLUDE_armv7= DTRACE
-OPTIONS_EXCLUDE_i386= DTRACE NATIVE HIPE
+OPTIONS_EXCLUDE_armv6= DTRACE
+OPTIONS_EXCLUDE_armv7= DTRACE
+OPTIONS_EXCLUDE_i386= DTRACE HIPE NATIVE
# If you run Erlang and get a message resembling "WARNING: number of
# probes fixed does not match the number of defined probes (54 != 132,
@@ -64,25 +65,27 @@ OPTIONS_EXCLUDE_i386= DTRACE NATIVE HIPE
CONFIGURE_ENABLE= smp-support
-DIRTY_CONFIGURE_ENABLE= dirty-schedulers
-DTRACE_CFLAGS= -fno-omit-frame-pointer
-DTRACE_CONFIGURE_WITH= dynamic-trace=dtrace
-DTRACE_VARS= STRIP=""
-HIPE_CONFIGURE_ENABLE= hipe
-JAVA_CONFIGURE_ENV= ac_cv_prog_JAVAC="${JAVAC}"
-JAVA_CONFIGURE_WITH= javac
-JAVA_VARS= USE_JAVA=yes
-KQUEUE_CONFIGURE_ENABLE=kernel-poll
-NATIVE_CONFIGURE_ENABLE=native-libs
-ODBC_CONFIGURE_WITH= odbc
-ODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
-OPENSSL_CONFIGURE_WITH= ssl=${OPENSSLBASE}
-OPENSSL_USES= ssl
-SCTP_CONFIGURE_ENABLE= sctp
+DIRTY_CONFIGURE_ENABLE= dirty-schedulers
+DTRACE_CFLAGS= -fno-omit-frame-pointer
+DTRACE_CONFIGURE_WITH= dynamic-trace=dtrace
+DTRACE_VARS= STRIP=""
+HIPE_CONFIGURE_ENABLE= hipe
+JAVA_CONFIGURE_ENV= ac_cv_prog_JAVAC="${JAVAC}"
+JAVA_CONFIGURE_WITH= javac
+JAVA_VARS= USE_JAVA=yes
+KQUEUE_CONFIGURE_ENABLE= kernel-poll
+NATIVE_CONFIGURE_ENABLE= native-libs
+ODBC_CONFIGURE_WITH= odbc
+ODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
+OPENSSL_CONFIGURE_WITH= ssl=${OPENSSLBASE}
+OPENSSL_USES= ssl
+SCTP_CONFIGURE_ENABLE= sctp
THREADS_CONFIGURE_ENABLE= threads
-WX_CONFIGURE_WITH= wx-config=${WX_CONFIG}
-WX_USES= gl
-WX_VARS= USE_WX=2.8+ WX_COMPS="wx contrib" USE_GL="gl glu"
+WX_CONFIGURE_WITH= wx-config=${WX_CONFIG}
+WX_USES= gl
+WX_VARS= USE_GL="gl glu" \
+ USE_WX=2.8+ \
+ WX_COMPS="wx contrib"
.include <bsd.port.pre.mk>