aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2021-10-05 12:13:11 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2021-10-05 12:25:18 +0000
commit0168601702bdf14c5d16e05dbab86b4d60e99351 (patch)
treec08fe4ddc2c1f145f4d5f8d9e83f2910738f95d4 /lang/erlang/Makefile
parent04a84011590c313baddb82333137426fbd572f90 (diff)
downloadports-0168601702bdf14c5d16e05dbab86b4d60e99351.tar.gz
ports-0168601702bdf14c5d16e05dbab86b4d60e99351.zip
Diffstat (limited to 'lang/erlang/Makefile')
-rw-r--r--lang/erlang/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index baa0bf975b30..7058953e95fa 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -2,7 +2,7 @@
PORTNAME= erlang
DISTVERSIONPREFIX= OTP-
-DISTVERSION= 24.1.1
+DISTVERSION= 24.1.2
PORTREVISION= 0
PORTEPOCH= 4
CATEGORIES= lang parallel java
@@ -32,7 +32,6 @@ CONFIGURE_ARGS= --enable-dirty-schedulers \
--enable-threads
MAKE_ARGS= all
-
SUB_FILES= pkg-message
SUB_LIST= TOOLS_VSN=${TOOLS_VSN}
@@ -59,7 +58,7 @@ OPTIONS_EXCLUDE_armv6= DTRACE
OPTIONS_EXCLUDE_armv7= DTRACE
OPTIONS_EXCLUDE_i386= DTRACE
OPTIONS_EXCLUDE_riscv64= DTRACE
-OPTIONS_SUB= yes
+OPTIONS_SUB= yes
CHUNKS_DESC= Enable in-line documentation in Erlang console
CORBA_DESC= Enable Corba support
@@ -75,7 +74,8 @@ WX_DESC= Enable WX application
# probes fixed does not match the number of defined probes (54 != 132,
# respectively)" you probably misconfigured DTrace in some way.
-CHUNKS_MAKE_ARGS+= docs DOC_TARGETS=chunks
+CHUNKS_MAKE_ARGS+= DOC_TARGETS=chunks \
+ docs
DIRTY_CONFIGURE_WITH= dirty-schedulers
DTRACE_CONFIGURE_WITH= dynamic-trace=dtrace
DTRACE_CFLAGS= -fno-omit-frame-pointer