aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2019-05-29 17:29:03 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2019-05-29 17:29:03 +0000
commit593758c8ce82f3ec43d0d3c3ca1f63153e696142 (patch)
tree51396fb2816ae1f5856c45e7d3378991e62fb11f /lang/erlang/Makefile
parenta6427f8cfe66da6bcb0297a51e69f6ca0fcd1bca (diff)
downloadports-593758c8ce82f3ec43d0d3c3ca1f63153e696142.tar.gz
ports-593758c8ce82f3ec43d0d3c3ca1f63153e696142.zip
Notes
Diffstat (limited to 'lang/erlang/Makefile')
-rw-r--r--lang/erlang/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 3ffc95261578..bcb131fe988d 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -115,6 +115,15 @@ MAKE_ARGS+= ARCH=arm
.endif
pre-configure:
+ @if [ ! $$(${CAT} ${WRKSRC}/lib/erl_interface/vsn.mk | ${GREP} "EI_VSN *=" | ${CUT} -w -f3) = ${EI_VSN} ]; then \
+ ${ECHO_MSG} "===> EI_VSN (${EI_VSN}) in Makefile does not match value in lib/erl_interface/vsn.mk"; exit 1; \
+ fi
+ @if [ ! $$(${CAT} ${WRKSRC}/lib/tools/vsn.mk | ${GREP} "TOOLS_VSN *=" | ${CUT} -w -f3) = ${TOOLS_VSN} ]; then \
+ ${ECHO_MSG} "===> TOOLS_VSN (${TOOLS_VSN}) in Makefile does not match value in lib/tools/vsn.mk"; exit 1; \
+ fi
+ @if [ ! $$(${CAT} ${WRKSRC}/lib/snmp/vsn.mk | ${GREP} -E "SNMP_VSN *=" | ${CUT} -w -f3) = ${SNMP_VSN} ]; then \
+ ${ECHO_MSG} "===> SNMP_VSN (${SNMP_VSN}) in Makefile does not match value in lib/snmp/vsn.mk"; exit 1; \
+ fi
@cd ${WRKSRC} && ./otp_build autoconf
pre-configure-WX-off: