aboutsummaryrefslogtreecommitdiff
path: root/lang/expect
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-01-17 12:38:24 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-01-17 12:38:24 +0000
commit6534d28dcd376873853b1c75fb4873c0cf33b401 (patch)
treebdb53e9ee29c872fa5986873be1cd5d486ff46bc /lang/expect
parent93ba8b2caf32387d01ca66cdb57c825549dc1092 (diff)
downloadports-6534d28dcd376873853b1c75fb4873c0cf33b401.tar.gz
ports-6534d28dcd376873853b1c75fb4873c0cf33b401.zip
lang/expect: install manpages along with sample tools
PR: 194130 Submitted by: w.schwarzenfeld@utanet.at
Notes
Notes: svn path=/head/; revision=406307
Diffstat (limited to 'lang/expect')
-rw-r--r--lang/expect/Makefile2
-rw-r--r--lang/expect/files/patch-Makefile.in15
-rw-r--r--lang/expect/files/patch-configure12
-rw-r--r--lang/expect/files/patch-exp_main_sub.c8
-rw-r--r--lang/expect/pkg-plist34
5 files changed, 40 insertions, 31 deletions
diff --git a/lang/expect/Makefile b/lang/expect/Makefile
index db62ab0d81b6..979fbadf32a8 100644
--- a/lang/expect/Makefile
+++ b/lang/expect/Makefile
@@ -3,7 +3,7 @@
PORTNAME= expect
PORTVERSION= 5.45
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang tcl tk
MASTER_SITES= SF/expect/Expect/${PORTVERSION}
DISTNAME= ${PORTNAME}${PORTVERSION}
diff --git a/lang/expect/files/patch-Makefile.in b/lang/expect/files/patch-Makefile.in
index c8d6c04d1386..11fd970b6871 100644
--- a/lang/expect/files/patch-Makefile.in
+++ b/lang/expect/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2010-09-30 19:14:07.000000000 +0200
-+++ Makefile.in 2014-02-28 12:00:40.000000000 +0100
-@@ -236,10 +236,10 @@
+--- Makefile.in.orig 2010-09-30 17:14:07 UTC
++++ Makefile.in
+@@ -236,10 +236,10 @@ install-libraries: libraries $(SCRIPTS)
$(INSTALL_DATA) $(srcdir)/$$i $(DESTDIR)$(includedir) ; \
done;
# install standalone scripts and their man pages, if requested
@@ -13,3 +13,12 @@
rm -f $$i ; \
else true; fi ; \
done
+@@ -259,7 +259,7 @@ install-doc: doc
+ $(INSTALL_DATA) $(srcdir)/libexpect.man $(DESTDIR)$(mandir)/man3/libexpect.3
+ -for i in $(SCRIPT_MANPAGE_LIST) ; do \
+ if [ -f $(srcdir)/example/$$i.man ] ; then \
+- $(INSTALL_DATA) $(srcdir)/example/$$i.man $(DESTDIR)$(mandir)/man1/$$i.1 ; \
++ $(INSTALL_DATA) $(srcdir)/example/$$i.man $(DESTDIR)$(datadir)/$$i.1 ; \
+ else true; fi ; \
+ done
+
diff --git a/lang/expect/files/patch-configure b/lang/expect/files/patch-configure
index d8ca39262353..408a46516afc 100644
--- a/lang/expect/files/patch-configure
+++ b/lang/expect/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2010-09-16 22:46:47.000000000 +0200
-+++ configure 2014-02-21 14:43:41.000000000 +0100
-@@ -8103,7 +8103,7 @@
+--- configure.orig 2010-09-16 20:46:47 UTC
++++ configure
+@@ -8103,7 +8103,7 @@ fi
# This configuration from FreeBSD Ports.
SHLIB_CFLAGS="-fPIC"
SHLIB_LD="${CC} -shared"
@@ -9,7 +9,7 @@
SHLIB_SUFFIX=".so"
LDFLAGS=""
if test $doRpath = yes; then
-@@ -8123,7 +8123,7 @@
+@@ -8123,7 +8123,7 @@ fi
# Version numbers are dot-stripped by system policy.
TCL_TRIM_DOTS=`echo ${VERSION} | tr -d .`
UNSHARED_LIB_SUFFIX='${TCL_TRIM_DOTS}.a'
@@ -18,7 +18,7 @@
TCL_LIB_VERSIONS_OK=nodots
;;
Darwin-*)
-@@ -16349,9 +16349,9 @@
+@@ -16349,9 +16349,9 @@ rm -f conftest*
if test x"${TK_BIN_DIR}" != x ; then
SHLIB_LD_LIBS="${SHLIB_LD_LIBS} \"`${CYGPATH} ${TK_BIN_DIR}/${TK_STUB_LIB_FILE}`\""
fi
@@ -30,7 +30,7 @@
fi
# Some packages build their own stubs libraries
eval eval "PKG_STUB_LIB_FILE=${PACKAGE_NAME}stub${UNSHARED_LIB_SUFFIX}"
-@@ -16368,10 +16368,10 @@
+@@ -16368,10 +16368,10 @@ rm -f conftest*
if test x"${TK_BIN_DIR}" != x ; then
SHLIB_LD_LIBS="${SHLIB_LD_LIBS} ${TK_STUB_LIB_SPEC}"
fi
diff --git a/lang/expect/files/patch-exp_main_sub.c b/lang/expect/files/patch-exp_main_sub.c
index b270539bc1c9..1fc2ab7de0f5 100644
--- a/lang/expect/files/patch-exp_main_sub.c
+++ b/lang/expect/files/patch-exp_main_sub.c
@@ -1,6 +1,6 @@
---- exp_main_sub.c 2002/08/24 08:04:43 1.1
-+++ exp_main_sub.c 2002/08/24 08:15:33
-@@ -593,6 +593,9 @@
+--- exp_main_sub.c.orig 2010-08-27 22:01:15 UTC
++++ exp_main_sub.c
+@@ -672,6 +672,9 @@ char **argv;
char *args; /* ptr to string-rep of all args */
char *debug_init;
@@ -10,7 +10,7 @@
exp_argv0 = argv[0];
#ifdef TCL_DEBUGGER
-@@ -768,18 +771,23 @@
+@@ -853,18 +856,23 @@ char **argv;
expDiagLog("set argc %s\r\n",argc_rep);
if (exp_cmdfilename) {
diff --git a/lang/expect/pkg-plist b/lang/expect/pkg-plist
index 11fdfbec3d9c..62cdd751a31c 100644
--- a/lang/expect/pkg-plist
+++ b/lang/expect/pkg-plist
@@ -3,41 +3,41 @@ include/expect.h
include/expect_comm.h
include/expect_tcl.h
include/tcldbg.h
+lib/expect%%EXPECT_VER%%/libexpect%%LIBEXPECT_VER%%.so
+lib/expect%%EXPECT_VER%%/pkgIndex.tcl
+lib/libexpect.so
+lib/libexpect.so.1
+man/man1/expect.1.gz
+man/man3/libexpect.3.gz
%%DATADIR%%/autoexpect
+%%DATADIR%%/autoexpect.1
%%DATADIR%%/autopasswd
%%DATADIR%%/cryptdir
+%%DATADIR%%/cryptdir.1
%%DATADIR%%/decryptdir
+%%DATADIR%%/decryptdir.1
%%DATADIR%%/dislocate
+%%DATADIR%%/dislocate.1
%%DATADIR%%/ftp-rfc
%%DATADIR%%/kibitz
+%%DATADIR%%/kibitz.1
%%DATADIR%%/lpunlock
%%DATADIR%%/mkpasswd
+%%DATADIR%%/mkpasswd.1
%%DATADIR%%/multixterm
+%%DATADIR%%/multixterm.1
%%DATADIR%%/passmass
+%%DATADIR%%/passmass.1
%%DATADIR%%/rftp
%%DATADIR%%/rlogin-cwd
%%DATADIR%%/timed-read
%%DATADIR%%/timed-run
%%DATADIR%%/tknewsbiff
+%%DATADIR%%/tknewsbiff.1
%%DATADIR%%/tkpasswd
%%DATADIR%%/unbuffer
+%%DATADIR%%/unbuffer.1
%%DATADIR%%/weather
%%DATADIR%%/xkibitz
+%%DATADIR%%/xkibitz.1
%%DATADIR%%/xpstat
-man/man1/autoexpect.1.gz
-man/man1/cryptdir.1.gz
-man/man1/decryptdir.1.gz
-man/man1/dislocate.1.gz
-man/man1/expect.1.gz
-man/man1/kibitz.1.gz
-man/man1/mkpasswd.1.gz
-man/man1/multixterm.1.gz
-man/man1/passmass.1.gz
-man/man1/tknewsbiff.1.gz
-man/man1/unbuffer.1.gz
-man/man1/xkibitz.1.gz
-man/man3/libexpect.3.gz
-lib/expect%%EXPECT_VER%%/pkgIndex.tcl
-lib/expect%%EXPECT_VER%%/libexpect%%LIBEXPECT_VER%%.so
-lib/libexpect.so.1
-lib/libexpect.so