aboutsummaryrefslogtreecommitdiff
path: root/lang/expect
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2020-02-05 11:46:34 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2020-02-05 11:46:34 +0000
commita3a7f9127de7518d7fd119d07d8c5eb00a18f4f7 (patch)
tree77ec963ac4b4ea4cd05562032e550662b87f98b8 /lang/expect
parent0798546a5e12aeb178a6a88036310b6d109bd925 (diff)
downloadports-a3a7f9127de7518d7fd119d07d8c5eb00a18f4f7.tar.gz
ports-a3a7f9127de7518d7fd119d07d8c5eb00a18f4f7.zip
lang/expect: register LDCONFIG path
Because expect installs its shared libraries as symlinks libexpect.so.1 -> lib/expect5.45.4/libexpect5.45.4.so programs and libraries linked with -lexpect will fail to locate the final .so file. See https://lists.freebsd.org/pipermail/freebsd-tcltk/2020-February/000677.html Reported by: Daniel Morante <daniel@morante.net>
Notes
Notes: svn path=/head/; revision=525268
Diffstat (limited to 'lang/expect')
-rw-r--r--lang/expect/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/lang/expect/Makefile b/lang/expect/Makefile
index 28ea8d4dcadb..a461e2ddaba8 100644
--- a/lang/expect/Makefile
+++ b/lang/expect/Makefile
@@ -3,10 +3,10 @@
PORTNAME= expect
PORTVERSION= 5.45.4
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= lang tcl tk
-MASTER_SITES= SF/expect/Expect/${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/Expect/${PORTVERSION}
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= tcltk@FreeBSD.org
@@ -16,7 +16,7 @@ LICENSE= PD
LICENSE_FILE= ${WRKSRC}/license.terms
USES= tcl:tea autoreconf
-USE_LDCONFIG= yes
+USE_LDCONFIG= ${LOCALBASE}/lib/${DISTNAME}
WRKSRC= ${WRKDIR}/${DISTNAME}
PLIST_SUB+= PORTVERSION=${PORTVERSION}
@@ -25,8 +25,8 @@ SUB_LIST+= MANPREFIX=${MANPREFIX}
TEST_TARGET= test
post-install:
- ${LN} -sf expect${PORTVERSION}/libexpect${PORTVERSION}.so \
- ${STAGEDIR}${PREFIX}/lib/libexpect.so.1
- ${LN} -sf libexpect.so.1 ${STAGEDIR}${PREFIX}/lib/libexpect.so
+ ${LN} -sf ${DISTNAME}/lib${DISTNAME}.so \
+ ${STAGEDIR}${PREFIX}/lib/lib${PORTNAME}.so.1
+ ${LN} -sf lib${PORTNAME}.so.1 ${STAGEDIR}${PREFIX}/lib/lib${PORTNAME}.so
.include <bsd.port.mk>