aboutsummaryrefslogtreecommitdiff
path: root/lang/ficl
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-29 20:27:23 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-29 20:27:23 +0000
commit023f8c2c26494f45cbb369c78de14eb0597dfe47 (patch)
tree6831ad116cf2223f8cd2303255def7c25918a15c /lang/ficl
parenta0c5f9da204d3c258c7cfb29ff9dc069e607c5dc (diff)
downloadports-023f8c2c26494f45cbb369c78de14eb0597dfe47.tar.gz
ports-023f8c2c26494f45cbb369c78de14eb0597dfe47.zip
Notes
Diffstat (limited to 'lang/ficl')
-rw-r--r--lang/ficl/Makefile16
-rw-r--r--lang/ficl/files/LICENSE.txt24
-rw-r--r--lang/ficl/files/patch-ficlplatform_unix.h11
-rw-r--r--lang/ficl/files/patch-vm.c2
4 files changed, 43 insertions, 10 deletions
diff --git a/lang/ficl/Makefile b/lang/ficl/Makefile
index 7a059c68cd16..73a54862bf27 100644
--- a/lang/ficl/Makefile
+++ b/lang/ficl/Makefile
@@ -3,21 +3,17 @@
PORTNAME= ficl
PORTVERSION= 4.1.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-all/${PORTNAME}${PORTVERSION:C/([[:digit:]]+\.[[:digit:]]+)\.0/\1/}
MAINTAINER= pavelivolkov@gmail.com
COMMENT= Forth Inspired Command Language
-LICENSE= unknown
-LICENSE_NAME= BSD-style
-LICENSE_TEXT= Description of the license can be obtained from the following URL: http://ficl.sourceforge.net/license.html
-LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${PATCHDIR}/LICENSE.txt
-OPTIONS_DEFINE= DOCS
-
-ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= this port is not tested on anything other than i386 and amd64
USE_LDCONFIG= YES
@@ -29,8 +25,10 @@ PLIST_FILES= bin/${PORTNAME} include/ficl.h include/ficlcompatibility.h \
include/ficltokens.h lib/lib${PORTNAME}.so \
lib/lib${PORTNAME}.so.${PORTVERSION} lib/lib${PORTNAME}.a
-PORTDOCS= *
PORTDATA= *
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/lang/ficl/files/LICENSE.txt b/lang/ficl/files/LICENSE.txt
new file mode 100644
index 000000000000..0e9afee74a86
--- /dev/null
+++ b/lang/ficl/files/LICENSE.txt
@@ -0,0 +1,24 @@
+Copyright (c) 1997-2001 John Sadler (john_sadler@alum.mit.edu)
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND ANY
+EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY
+DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
+DAMAGE.
diff --git a/lang/ficl/files/patch-ficlplatform_unix.h b/lang/ficl/files/patch-ficlplatform_unix.h
new file mode 100644
index 000000000000..abd3b5789103
--- /dev/null
+++ b/lang/ficl/files/patch-ficlplatform_unix.h
@@ -0,0 +1,11 @@
+--- ficlplatform/unix.h.orig 2010-09-15 18:29:10 UTC
++++ ficlplatform/unix.h
+@@ -13,7 +13,7 @@
+ #else
+ #define FICL_PLATFORM_ALIGNMENT (4)
+ #endif
+-#define FICL_PLATFORM_INLINE inline
++#define FICL_PLATFORM_INLINE static inline
+
+ #define FICL_PLATFORM_HAS_FTRUNCATE (1)
+ #if defined(__amd64__)
diff --git a/lang/ficl/files/patch-vm.c b/lang/ficl/files/patch-vm.c
index 7ca07989a136..d054175c24e7 100644
--- a/lang/ficl/files/patch-vm.c
+++ b/lang/ficl/files/patch-vm.c
@@ -1,6 +1,6 @@
--- vm.c.orig 2010-09-13 18:43:04 UTC
+++ vm.c
-@@ -280,12 +280,12 @@ void ficlVmInnerLoop(ficlVm *vm, ficlWor
+@@ -280,12 +280,12 @@ void ficlVmInnerLoop(ficlVm *vm, ficlWord *fw)
if (once)
count = 1;