aboutsummaryrefslogtreecommitdiff
path: root/lang/fpc-docs
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-08 17:40:37 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-08 17:40:37 +0000
commit8bcb9866bba8e7c12b6b195965e1543ceb1bb55d (patch)
tree0cfec72411a59c10992ac4e185e1e0ba414c07a1 /lang/fpc-docs
parent61c6513a51f2ba93885bd466d6929f81db47065c (diff)
downloadports-8bcb9866bba8e7c12b6b195965e1543ceb1bb55d.tar.gz
ports-8bcb9866bba8e7c12b6b195965e1543ceb1bb55d.zip
Notes
Diffstat (limited to 'lang/fpc-docs')
-rw-r--r--lang/fpc-docs/Makefile51
-rw-r--r--lang/fpc-docs/distinfo2
-rw-r--r--lang/fpc-docs/pkg-descr9
3 files changed, 62 insertions, 0 deletions
diff --git a/lang/fpc-docs/Makefile b/lang/fpc-docs/Makefile
new file mode 100644
index 000000000000..ff88a7f35ecc
--- /dev/null
+++ b/lang/fpc-docs/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: Free Pascal Compiler Docs
+# Date created: 9 February 2004
+# Whom: John Merryweather Cooper
+#
+# $FreeBSD$
+#
+
+PORTNAME= docs
+PORTVERSION= 1.0.10
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ http://planetmirror.com/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.jp.freepascal.org/mirror/fpc/dist/FreeBSD/ \
+ ftp://freepascal.stack.nl/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.no.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.us.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= freepascal
+PKGNAMEPREFIX= fpc-
+DISTNAME= ${PKGNAMEPREFIX}${PORTVERSION}.ELF
+EXTRACT_SUFX= .tar
+
+MAINTAINER= coop9211@uidaho.edu
+COMMENT= Free Pascal compiler Adobe Acrobat(tm) documentation
+
+DOCSDIR= ${PREFIX}/share/doc/fpc
+NO_BUILD= yes
+PORTDOCS= fcl.pdf fpdoc.pdf prog.pdf ref.pdf units.pdf user.pdf
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 470000
+EXTRACT_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
+TAR= ${LOCALBASE}/bin/gtar
+.endif
+
+do-extract:
+# unpack distribution
+ @${MKDIR} ${WRKSRC}
+ @${TAR} xf ${DISTDIR}/${DISTNAME}.tar --directory ${WRKSRC}
+# unpack docs distribution
+ @${MKDIR} ${WRKSRC}/docs
+ @${TAR} zxf ${WRKSRC}/docs.tar.gz --directory ${WRKSRC}/docs
+
+do-install:
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_MAN} ${WRKSRC}/docs/${f} ${DOCSDIR}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/lang/fpc-docs/distinfo b/lang/fpc-docs/distinfo
new file mode 100644
index 000000000000..54527a31654e
--- /dev/null
+++ b/lang/fpc-docs/distinfo
@@ -0,0 +1,2 @@
+MD5 (fpc-1.0.10.ELF.tar) = 6ad56eb115152174683499da3ece7667
+SIZE (fpc-1.0.10.ELF.tar) = 17448960
diff --git a/lang/fpc-docs/pkg-descr b/lang/fpc-docs/pkg-descr
new file mode 100644
index 000000000000..6005c632f714
--- /dev/null
+++ b/lang/fpc-docs/pkg-descr
@@ -0,0 +1,9 @@
+This is the documentation, in Adobe Acrobat(tm) format, for Free
+Pascal, a 32 bit Turbo Pascal-compatible Pascal compiler for DOS,
+Linux, Win32, OS/2, (based on an older version) the AmigaOS,
+FreeBSD/ELF, and BeOS.
+
+WWW: http://www.freepascal.org/
+
+--
+John Merryweather Cooper <coop9211@uidaho.edu>