aboutsummaryrefslogtreecommitdiff
path: root/lang/fpc
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2024-01-05 15:45:56 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2024-01-05 15:50:01 +0000
commit74dbced73dda83b3f93437d593605e18a3085380 (patch)
treed722ffa8d2850da5f3cb4231f700ead28e3df651 /lang/fpc
parentdf0a8c2e34bcb6a9c9a6874fa9507e9b291f1c15 (diff)
downloadports-74dbced73dda83b3f93437d593605e18a3085380.tar.gz
ports-74dbced73dda83b3f93437d593605e18a3085380.zip
lang/fpc: Fix issues on stage-qa on i386
- Add ptc unit - graph unit installs new unit files - Bump PORTREVISION PR: 276012 Reported by: danfe
Diffstat (limited to 'lang/fpc')
-rw-r--r--lang/fpc/Makefile4
-rw-r--r--lang/fpc/files/patch-packages-graph_fpmake.pp53
-rw-r--r--lang/fpc/pkg-plist17
3 files changed, 73 insertions, 1 deletions
diff --git a/lang/fpc/Makefile b/lang/fpc/Makefile
index 5c08282cb2eb..ee606e068310 100644
--- a/lang/fpc/Makefile
+++ b/lang/fpc/Makefile
@@ -1,6 +1,6 @@
PORTNAME= fpc
PORTVERSION= 3.2.2
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= lang
MASTER_SITES= SF/freepascal/Source/${PORTVERSION}:source \
https://downloads.freepascal.org/${PORTNAME}/dist/${PORTVERSION}/source/:source \
@@ -142,6 +142,8 @@ post-patch:
${WRKSRC}/packages/opencl/fpmake.pp
@${REINPLACE_CMD} -i "" -e 's|linux|freebsd,linux|g' \
${WRKSRC}/packages/proj4/fpmake.pp
+ @${REINPLACE_CMD} -i "" -e 's|linux|freebsd,linux|g' \
+ ${WRKSRC}/packages/ptc/fpmake.pp
@${REINPLACE_CMD} -i "" -e 's|os2|freebsd,os2|g' \
${WRKSRC}/packages/rexx/fpmake.pp
@${REINPLACE_CMD} -i "" -e 's|linux|freebsd,linux|g' \
diff --git a/lang/fpc/files/patch-packages-graph_fpmake.pp b/lang/fpc/files/patch-packages-graph_fpmake.pp
new file mode 100644
index 000000000000..5f63cba06101
--- /dev/null
+++ b/lang/fpc/files/patch-packages-graph_fpmake.pp
@@ -0,0 +1,53 @@
+--- packages/graph/fpmake.pp 2021-05-13 06:42:31.000000000 -0500
++++ packages/graph/fpmake.pp 2024-01-05 10:37:36.481679000 -0500
+@@ -29,13 +29,13 @@
+ P.OSes:=[go32v2,win32,win64,linux,freebsd,darwin,msdos];
+
+ P.Dependencies.Add('sdl',[i386,powerpc],[win32,linux,freebsd,darwin]);
+- P.Dependencies.Add('ptc',[win32,win64,linux]);
++ P.Dependencies.Add('ptc',[win32,win64,linux,freebsd]);
+
+ // Dependencies for ptc, due to fpcmake bug:
+- P.Dependencies.Add('fcl-base',[win32,win64,linux]);
++ P.Dependencies.Add('fcl-base',[win32,win64,linux,freebsd]);
+ P.Dependencies.Add('x11',[freebsd,linux]); // ptc only depends on reebsd and linux on x11
+- P.Dependencies.Add('hermes',[win32,win64,linux]);
+- P.Dependencies.Add('opengl',[win32,win64,linux]);
++ P.Dependencies.Add('hermes',[win32,win64,freebsd,linux]);
++ P.Dependencies.Add('opengl',[win32,win64,freebsd,linux]);
+
+ P.SourcePath.Add('src');
+ P.SourcePath.Add('src/ptcgraph');
+@@ -52,7 +52,7 @@
+ P.IncludePath.Add('src/unix',[freebsd,linux]); // Darwin has own.
+ P.IncludePath.Add('src/go32v2',[go32v2]);
+
+- T:=P.Targets.AddUnit('ggigraph.pp',[linux,freebsd]);
++ T:=P.Targets.AddUnit('ggigraph.pp',[freebsd,linux]);
+ with T.Dependencies do
+ begin
+ AddInclude('graphh.inc');
+@@ -117,7 +117,7 @@
+ begin
+ AddUnit('graph');
+ end;
+- T:=P.Targets.AddUnit('ptcgraph.pp',[win32,win64,linux]);
++ T:=P.Targets.AddUnit('ptcgraph.pp',[win32,win64,freebsd,linux]);
+ with T.Dependencies do
+ begin
+ AddInclude('graphh.inc');
+@@ -129,12 +129,12 @@
+ AddInclude('fills.inc');
+ AddInclude('gtext.inc');
+ end;
+- T:=P.Targets.AddUnit('ptccrt.pp',[win32,win64,linux]);
++ T:=P.Targets.AddUnit('ptccrt.pp',[win32,win64,freebsd,linux]);
+ with T.Dependencies do
+ begin
+ AddUnit('ptcgraph');
+ end;
+- T:=P.Targets.AddUnit('ptcmouse.pp',[win32,win64,linux]);
++ T:=P.Targets.AddUnit('ptcmouse.pp',[win32,win64,freebsd,linux]);
+ with T.Dependencies do
+ begin
+ AddUnit('ptcgraph');
diff --git a/lang/fpc/pkg-plist b/lang/fpc/pkg-plist
index 796a1cf70bff..e99b67e51e25 100644
--- a/lang/fpc/pkg-plist
+++ b/lang/fpc/pkg-plist
@@ -151,6 +151,7 @@ lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/paszlib.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/pcap.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/postgres.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/proj4.fpm
+lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/ptc.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/pthreads.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/pxlib.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/regexpr.fpm
@@ -1660,6 +1661,14 @@ lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/ggigraph.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/ggigraph.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/graph.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/graph.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/ptccrt.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/ptccrt.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/ptcgraph.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/ptcgraph.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/ptcmouse.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/ptcmouse.ppu
+%%FPC_I386%%lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/sdlgraph.o
+%%FPC_I386%%lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/graph/sdlgraph.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/gtk2/atk.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/gtk2/atk.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/gtk2/gdk2.o
@@ -2134,6 +2143,12 @@ lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/postgres/postgres3dyn.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/postgres/postgres3dyn.rsj
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/proj4/proj.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/proj4/proj.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ptc/ptc.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ptc/ptc.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ptc/ptceventqueue.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ptc/ptceventqueue.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ptc/ptcwrapper.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ptc/ptcwrapper.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/pthreads/pthreads.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/pthreads/pthreads.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/pxlib/pxlib.o
@@ -2454,6 +2469,8 @@ lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl_net.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl_net.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl_ttf.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdl_ttf.ppu
+%%FPC_I386%%lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdlutils.o
+%%FPC_I386%%lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/sdlutils.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/smpeg.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sdl/smpeg.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sqlite/sqlite.o