aboutsummaryrefslogtreecommitdiff
path: root/lang/gauche
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-06-26 07:45:07 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-06-26 07:45:07 +0000
commit018e4d80fe3672c6790112d341318f3dea506f3b (patch)
treed811c0d9b9d01507b87eaa1127c82bb2fb518012 /lang/gauche
parent22ab108762fb5896e2f4431626fd669705a01ade (diff)
downloadports-018e4d80fe3672c6790112d341318f3dea506f3b.tar.gz
ports-018e4d80fe3672c6790112d341318f3dea506f3b.zip
- Update Gauche to version 0.9.8
- Ensure that installed xDBM ports would be ignored unless explicitly selected in the OPTIONS dialog
Notes
Notes: svn path=/head/; revision=505143
Diffstat (limited to 'lang/gauche')
-rw-r--r--lang/gauche/Makefile6
-rw-r--r--lang/gauche/distinfo6
-rw-r--r--lang/gauche/files/patch-src_Makefile.in2
-rw-r--r--lang/gauche/pkg-plist24
4 files changed, 26 insertions, 12 deletions
diff --git a/lang/gauche/Makefile b/lang/gauche/Makefile
index ec70184addba..2cfb6590f056 100644
--- a/lang/gauche/Makefile
+++ b/lang/gauche/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gauche
-PORTVERSION= 0.9.7
+PORTVERSION= 0.9.8
CATEGORIES= lang scheme
MASTER_SITES= SF/${PORTNAME}/Gauche
DISTNAME= Gauche-${PORTVERSION}
@@ -45,9 +45,12 @@ AXTLS_CONFIGURE_ON= --with-tls=axtls
EUCJP_DESC= EUC-JP encoding support
EUCJP_CONFIGURE_ON= --enable-multibyte=euc-jp
GDBM_LIB_DEPENDS= libgdbm.so:databases/gdbm
+GDBM_CONFIGURE_ON= --with-dbm=gdbm,ndbm
+GDBM_CONFIGURE_OFF= --with-dbm=ndbm
MBEDTLS_LIB_DEPENDS= libmbedtls.so:security/mbedtls
MBEDTLS_CONFIGURE_ON= --with-tls=mbedtls
SLIB_DESC= Create catalogue for SLIB port
+# Gauche's slib module to use Aubrey Jaffer's SLIB
SLIB_BUILD_DEPENDS= ${LOCALBASE}/share/slib/require.scm:lang/slib
SLIB_CONFIGURE_ON= --with-slib=${LOCALBASE}/share/slib
SLIB_CONFIGURE_OFF= --with-slib=${WRKDIR}
@@ -68,6 +71,7 @@ CONFIGURE_ARGS+= --with-tls=none
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's,/bash,/sh,' ${WRKSRC}/src/gen-features.sh
# required for sparc64, no-op elsewhere
@${REINPLACE_CMD} -e \
'/^VPATH = /s,$$,/src,' ${WRKSRC}/gc/Makefile.in
diff --git a/lang/gauche/distinfo b/lang/gauche/distinfo
index 0f9e6ddf0b75..c62694d7ecac 100644
--- a/lang/gauche/distinfo
+++ b/lang/gauche/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1545335535
-SHA256 (Gauche-0.9.7.tgz) = 2d33bd942e3fc2f2dcc8e5217c9130c885a0fd1cb11a1856e619a83a23f336a0
-SIZE (Gauche-0.9.7.tgz) = 6861031
+TIMESTAMP = 1560671305
+SHA256 (Gauche-0.9.8.tgz) = 3eb30d1051d8b48999fe46511c9f6983057735312c9832b7db13f9db140db74b
+SIZE (Gauche-0.9.8.tgz) = 7101599
diff --git a/lang/gauche/files/patch-src_Makefile.in b/lang/gauche/files/patch-src_Makefile.in
index d09850a16034..d67136f25bd6 100644
--- a/lang/gauche/files/patch-src_Makefile.in
+++ b/lang/gauche/files/patch-src_Makefile.in
@@ -3,7 +3,7 @@
@@ -267,7 +267,7 @@ test-extra$(EXEEXT) : $(LIBGAUCHE).$(SOEXT) $(test_ext
# need to relink gosh-noconsole.exe (windows no-console version).
relink :
- $(RELINK) $(libgauche_LDFLAGS) $(LIBGAUCHE).$(SOEXT) $(libgauche_OBJECTS) $(libgc_pic_LIBRARY) $(GC_ATOMIC_OPS_LIBS) $(LIBS)
+ $(RELINK) $(libgauche_LDFLAGS) $(LIBGAUCHE).$(SOEXT) $(libgauche_OBJECTS) $(libgc_pic_LIBRARY) $(ATOMIC_OPS_LIBS) $(LIBS)
- $(RELINK) $(gosh_LDFLAGS) -o gosh$(EXEEXT) $(gosh_OBJECTS) $(gosh_LDADD) $(LIBS)
+ $(RELINK) $(gosh_LDFLAGS) -o gosh-relinked$(EXEEXT) $(gosh_OBJECTS) $(gosh_LDADD) $(LIBS)
$(RELINK) -o gauche-config$(EXEEXT) gauche-config.$(OBJEXT) $(LIBS)
diff --git a/lang/gauche/pkg-plist b/lang/gauche/pkg-plist
index 187cce99179b..b9dc8f00775a 100644
--- a/lang/gauche/pkg-plist
+++ b/lang/gauche/pkg-plist
@@ -9,6 +9,7 @@ lib/gauche-0.97/%%VERSION%%/%%TARGET%%/data--queue.so
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/data--sparse.so
%%GDBM%%lib/gauche-0.97/%%VERSION%%/%%TARGET%%/dbm--gdbm.so
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/dbm--ndbm.so
+@comment lib/gauche-0.97/%%VERSION%%/%%TARGET%%/dbm--odbm.so
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/file--util.so
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/gauche--charconv.so
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/gauche--collection.so
@@ -33,7 +34,7 @@ lib/gauche-0.97/%%VERSION%%/%%TARGET%%/gauche-package
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/gosh
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/libgauche-0.97.so
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/libgauche-0.97.so.0
-lib/gauche-0.97/%%VERSION%%/%%TARGET%%/libgauche-0.97.so.0.7
+lib/gauche-0.97/%%VERSION%%/%%TARGET%%/libgauche-0.97.so.0.8
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/libgauche-static-0.97.a
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/math--mt-random.so
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/os--windows.so
@@ -48,6 +49,7 @@ lib/gauche-0.97/%%VERSION%%/%%TARGET%%/rfc--zlib.so
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/srfi-1.so
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/srfi-13.so
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/srfi-133.so
+lib/gauche-0.97/%%VERSION%%/%%TARGET%%/srfi-144.so
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/srfi-19.so
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/srfi-43.so
lib/gauche-0.97/%%VERSION%%/%%TARGET%%/sxml--serializer.so
@@ -117,7 +119,7 @@ lib/gauche-0.97/%%VERSION%%/include/gc_version.h
lib/gauche-0.97/site/%%TARGET%%/.keepme
lib/libgauche-0.97.so
lib/libgauche-0.97.so.0
-lib/libgauche-0.97.so.0.7
+lib/libgauche-0.97.so.0.8
lib/libgauche-static-0.97.a
man/man1/gauche-cesconv.1.gz
man/man1/gauche-config.1.gz
@@ -142,12 +144,14 @@ share/gauche-0.97/%%VERSION%%/lib/compat/norational.scm
share/gauche-0.97/%%VERSION%%/lib/compat/r7rs-srfi-tests.scm
share/gauche-0.97/%%VERSION%%/lib/compat/stk.scm
share/gauche-0.97/%%VERSION%%/lib/control/job.scm
+share/gauche-0.97/%%VERSION%%/lib/control/mapper.scm
share/gauche-0.97/%%VERSION%%/lib/control/thread-pool.scm
share/gauche-0.97/%%VERSION%%/lib/crypt/bcrypt.scm
share/gauche-0.97/%%VERSION%%/lib/data/cache.scm
share/gauche-0.97/%%VERSION%%/lib/data/heap.scm
share/gauche-0.97/%%VERSION%%/lib/data/ideque.scm
share/gauche-0.97/%%VERSION%%/lib/data/imap.scm
+share/gauche-0.97/%%VERSION%%/lib/data/priority-map.scm
share/gauche-0.97/%%VERSION%%/lib/data/queue.scm
share/gauche-0.97/%%VERSION%%/lib/data/random.scm
share/gauche-0.97/%%VERSION%%/lib/data/ring-buffer.scm
@@ -160,6 +164,7 @@ share/gauche-0.97/%%VERSION%%/lib/dbm/dump
share/gauche-0.97/%%VERSION%%/lib/dbm/fsdbm.scm
%%GDBM%%share/gauche-0.97/%%VERSION%%/lib/dbm/gdbm.scm
share/gauche-0.97/%%VERSION%%/lib/dbm/ndbm.scm
+@comment share/gauche-0.97/%%VERSION%%/lib/dbm/odbm.scm
share/gauche-0.97/%%VERSION%%/lib/dbm/restore
share/gauche-0.97/%%VERSION%%/lib/file/filter.scm
share/gauche-0.97/%%VERSION%%/lib/file/util.scm
@@ -183,7 +188,6 @@ share/gauche-0.97/%%VERSION%%/lib/gauche/condutil.scm
share/gauche-0.97/%%VERSION%%/lib/gauche/config.scm
share/gauche-0.97/%%VERSION%%/lib/gauche/configure.scm
share/gauche-0.97/%%VERSION%%/lib/gauche/connection.scm
-share/gauche-0.97/%%VERSION%%/lib/gauche/defvalues.scm
share/gauche-0.97/%%VERSION%%/lib/gauche/dictionary.scm
share/gauche-0.97/%%VERSION%%/lib/gauche/experimental/app.scm
share/gauche-0.97/%%VERSION%%/lib/gauche/experimental/lamb.scm
@@ -198,6 +202,7 @@ share/gauche-0.97/%%VERSION%%/lib/gauche/interactive.scm
share/gauche-0.97/%%VERSION%%/lib/gauche/interactive/ed.scm
share/gauche-0.97/%%VERSION%%/lib/gauche/interactive/editable-reader.scm
share/gauche-0.97/%%VERSION%%/lib/gauche/interactive/info.scm
+share/gauche-0.97/%%VERSION%%/lib/gauche/interactive/init.scm
share/gauche-0.97/%%VERSION%%/lib/gauche/interactive/toplevel.scm
share/gauche-0.97/%%VERSION%%/lib/gauche/interpolate.scm
share/gauche-0.97/%%VERSION%%/lib/gauche/lazy.scm
@@ -291,6 +296,7 @@ share/gauche-0.97/%%VERSION%%/lib/rfc/tls/mbed.scm
share/gauche-0.97/%%VERSION%%/lib/rfc/uri.scm
share/gauche-0.97/%%VERSION%%/lib/rfc/zlib.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/base.scm
+share/gauche-0.97/%%VERSION%%/lib/scheme/bitwise.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/box.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/case-lambda.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/char.scm
@@ -298,8 +304,11 @@ share/gauche-0.97/%%VERSION%%/lib/scheme/charset.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/comparator.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/complex.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/cxr.scm
+share/gauche-0.97/%%VERSION%%/lib/scheme/division.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/eval.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/file.scm
+share/gauche-0.97/%%VERSION%%/lib/scheme/fixnum.scm
+share/gauche-0.97/%%VERSION%%/lib/scheme/flonum.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/generator.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/hash-table.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/ideque.scm
@@ -309,6 +318,8 @@ share/gauche-0.97/%%VERSION%%/lib/scheme/list-queue.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/list.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/load.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/lseq.scm
+share/gauche-0.97/%%VERSION%%/lib/scheme/mapping.scm
+share/gauche-0.97/%%VERSION%%/lib/scheme/mapping/hash.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/process-context.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/r5rs.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/read.scm
@@ -320,7 +331,6 @@ share/gauche-0.97/%%VERSION%%/lib/scheme/vector.scm
share/gauche-0.97/%%VERSION%%/lib/scheme/write.scm
share/gauche-0.97/%%VERSION%%/lib/slib.scm
%%SLIB%%share/gauche-0.97/%%VERSION%%/lib/slibcat
-share/gauche-0.97/%%VERSION%%/lib/srfi-0.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-1.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-106.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-11.scm
@@ -344,6 +354,7 @@ share/gauche-0.97/%%VERSION%%/lib/srfi-14/query.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-14/set.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-141.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-143.scm
+share/gauche-0.97/%%VERSION%%/lib/srfi-144.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-146.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-146/hash.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-151.scm
@@ -354,12 +365,10 @@ share/gauche-0.97/%%VERSION%%/lib/srfi-158.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-18.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-19.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-25.scm
-share/gauche-0.97/%%VERSION%%/lib/srfi-26.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-27.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-29.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-29/bundle.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-29/format.scm
-share/gauche-0.97/%%VERSION%%/lib/srfi-31.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-37.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-39.scm
share/gauche-0.97/%%VERSION%%/lib/srfi-4.scm
@@ -402,6 +411,7 @@ share/gauche-0.97/%%VERSION%%/lib/srfi/134.scm
share/gauche-0.97/%%VERSION%%/lib/srfi/14.scm
share/gauche-0.97/%%VERSION%%/lib/srfi/141.scm
share/gauche-0.97/%%VERSION%%/lib/srfi/143.scm
+share/gauche-0.97/%%VERSION%%/lib/srfi/144.scm
share/gauche-0.97/%%VERSION%%/lib/srfi/145.scm
share/gauche-0.97/%%VERSION%%/lib/srfi/146.scm
share/gauche-0.97/%%VERSION%%/lib/srfi/149.scm
@@ -472,7 +482,6 @@ share/gauche-0.97/%%VERSION%%/lib/text/gettext.scm
share/gauche-0.97/%%VERSION%%/lib/text/html-lite.scm
share/gauche-0.97/%%VERSION%%/lib/text/info.scm
share/gauche-0.97/%%VERSION%%/lib/text/line-edit.scm
-share/gauche-0.97/%%VERSION%%/lib/text/mexpr.scm
share/gauche-0.97/%%VERSION%%/lib/text/parse.scm
share/gauche-0.97/%%VERSION%%/lib/text/progress.scm
share/gauche-0.97/%%VERSION%%/lib/text/sql.scm
@@ -480,6 +489,7 @@ share/gauche-0.97/%%VERSION%%/lib/text/template.scm
share/gauche-0.97/%%VERSION%%/lib/text/tr.scm
share/gauche-0.97/%%VERSION%%/lib/text/tree.scm
share/gauche-0.97/%%VERSION%%/lib/text/unicode.scm
+share/gauche-0.97/%%VERSION%%/lib/text/unicode/codeset.scm
share/gauche-0.97/%%VERSION%%/lib/text/unicode/ucd.scm
share/gauche-0.97/%%VERSION%%/lib/util/combinations.scm
share/gauche-0.97/%%VERSION%%/lib/util/digest.scm