aboutsummaryrefslogtreecommitdiff
path: root/lang/gawk/Makefile
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2013-06-29 09:30:23 +0000
committerJohan van Selst <johans@FreeBSD.org>2013-06-29 09:30:23 +0000
commit6c3d62a0a143af4f9637dfd059a57f145233cf6d (patch)
treea4934a5ff519b81b3dcab796a9eb9b3bdc48ad5f /lang/gawk/Makefile
parent38c3a19ed68d57f0b98b00e0da38662268b66619 (diff)
downloadports-6c3d62a0a143af4f9637dfd059a57f145233cf6d.tar.gz
ports-6c3d62a0a143af4f9637dfd059a57f145233cf6d.zip
- Make optional dependency on libmpfr explicit in GNU awk
This adds support for multiple-precision floating-point computation PR: ports/180004 Submitted by: Dan Lukes <dan@obluda.cz>
Notes
Notes: svn path=/head/; revision=322035
Diffstat (limited to 'lang/gawk/Makefile')
-rw-r--r--lang/gawk/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/lang/gawk/Makefile b/lang/gawk/Makefile
index d5891d5b1f6c..a01d1ec07ac4 100644
--- a/lang/gawk/Makefile
+++ b/lang/gawk/Makefile
@@ -11,6 +11,9 @@ COMMENT= The GNU version of Awk
LIB_DEPENDS= sigsegv:${PORTSDIR}/devel/libsigsegv
+OPTIONS_DEFINE= MPFR
+MPFR_DESC?= Support multiple-precision floating-point computation
+
INFO= gawk gawkinet
USE_XZ= true
@@ -35,6 +38,12 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+.if ${PORT_OPTIONS:MMPFR}
+LIB_DEPENDS= mpfr:${PORTSDIR}/math/mpfr
+.else
+CONFIGURE_ARGS+=--without-gmp --without-mpfr
+.endif
+
post-patch:
@${RM} -f ${WRKSRC}/doc/*.info
@${REINPLACE_CMD} -e 's/ -export-dynamic/ -Wl,--export-dynamic/' \