aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc14-devel/Makefile
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2024-02-26 11:03:30 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2024-02-26 22:50:54 +0000
commit5ee63cc45413954077b2b0c0546b8342585b41ba (patch)
treeb61b80c4ede8f5a34aa7a659742b7ae2eca96e12 /lang/gcc14-devel/Makefile
parent85301c5e75c2d5492ea1733b33c9cf6d480023ae (diff)
downloadports-5ee63cc45413954077b2b0c0546b8342585b41ba.tar.gz
ports-5ee63cc45413954077b2b0c0546b8342585b41ba.zip
lang/gcc14-devel: Update to 14.0.1.s20240225
Also require to choose a BOOSTRAP option: building GCC with bootstrap disabled is intended to be possible only when GCC is built with some pre-installed GCC, however Clang is the default compiler on FreeBSD. Indeed, bugs have already been encountered when trying to build GCC with Clang without bootstrap on FreBSD. See for example commit a4831f4933d006071d96a861506ff0db44d1d3ac.
Diffstat (limited to 'lang/gcc14-devel/Makefile')
-rw-r--r--lang/gcc14-devel/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/lang/gcc14-devel/Makefile b/lang/gcc14-devel/Makefile
index fa7e603e72e0..8a9dcc71df00 100644
--- a/lang/gcc14-devel/Makefile
+++ b/lang/gcc14-devel/Makefile
@@ -1,5 +1,5 @@
PORTNAME= gcc
-PORTVERSION= 14.0.1.s20240218
+PORTVERSION= 14.0.1.s20240225
PORTEPOCH= 1
CATEGORIES= lang
MASTER_SITES= GCC/snapshots/${DIST_VERSION}
@@ -48,8 +48,8 @@ OPTIONS_DEFAULT_i386= STANDARD_BOOTSTRAP
OPTIONS_DEFAULT_powerpc=LTO_BOOTSTRAP
OPTIONS_DEFAULT_powerpc64=LTO_BOOTSTRAP
OPTIONS_DEFAULT_powerpc64le=LTO_BOOTSTRAP
-OPTIONS_RADIO= BOOTSTRAP
-OPTIONS_RADIO_BOOTSTRAP= LTO_BOOTSTRAP STANDARD_BOOTSTRAP
+OPTIONS_SINGLE= BOOTSTRAP
+OPTIONS_SINGLE_BOOTSTRAP= LTO_BOOTSTRAP STANDARD_BOOTSTRAP
LTO_BOOTSTRAP_DESC= Build using a full LTO bootstrap
STANDARD_BOOTSTRAP_DESC= Build using a full bootstrap without LTO
GRAPHITE_DESC= Support for Graphite loop optimizations
@@ -90,9 +90,7 @@ LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
CONFIGURE_OUTSOURCE= yes
-.if empty(PORT_OPTIONS:M*BOOTSTRAP)
-CONFIGURE_ARGS+=--disable-bootstrap
-.elif ${PORT_OPTIONS:MLTO_BOOTSTRAP}
+.if ${PORT_OPTIONS:MLTO_BOOTSTRAP}
CONFIGURE_ARGS+=--with-build-config=bootstrap-lto-noplugin
ALL_TARGET= bootstrap-lean
PIE_UNSAFE= yes