aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc47/Makefile
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2014-02-15 14:27:04 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2014-02-15 14:27:04 +0000
commit4fc52987316149366bc4dadd043dbe72954305c1 (patch)
treecde9c7120fa7626c25ce43ceabd87e948378a3e5 /lang/gcc47/Makefile
parent5fb0c8b5e639796f7a3dd44aa8c174f8c2a5382a (diff)
downloadports-4fc52987316149366bc4dadd043dbe72954305c1.tar.gz
ports-4fc52987316149366bc4dadd043dbe72954305c1.zip
Notes
Diffstat (limited to 'lang/gcc47/Makefile')
-rw-r--r--lang/gcc47/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 83d9d1376d7f..12380468b63c 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gcc47
-PORTVERSION= 4.7.4.20140118
+PORTVERSION= 4.7.4.20140208
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${DISTVERSION}
@@ -70,6 +70,7 @@ CONFIGURE_ARGS+=--disable-bootstrap
ALL_TARGET= bootstrap-lean
.endif
CONFIGURE_ARGS+=--disable-nls \
+ --enable-gnu-indirect-function \
--libdir=${TARGLIB} \
--libexecdir=${LIBEXEC} \
--program-suffix=${SUFFIX} \
@@ -129,6 +130,7 @@ full-regression-test: build
post-install:
${RM} -f ${STAGEDIR}${TARGLIB}/*.la
+ ${RM} -f ${STAGEDIR}${PREFIX}/man/man7/*
# Add target libraries and include files to packaging list.
${RM} -f ${WRKDIR}/PLIST.lib
.for d in ${TARGLIB:S/^${PREFIX}\///} ${LIBEXEC:S/^${PREFIX}\///} include/gcj include/gnu include/java include/javax
@@ -139,8 +141,5 @@ post-install:
fi
.endfor
cd ${WRKDIR} ; ${SED} -i -e "/PLIST.lib/ r PLIST.lib" ${TMPPLIST}
- @if type ccache-update-links >/dev/null 2>&1; then \
- ccache-update-links -v; \
- fi
.include <bsd.port.post.mk>