aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc48
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2016-08-16 07:21:05 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2016-08-16 07:21:05 +0000
commit0190464df7a4c339a63cc0e942eb68d1fe5b23ae (patch)
treebf7447a5f098cc412fefc577ab8ad2fd29cd68bb /lang/gcc48
parent15687caa958a8cc703f629c2bddc6400b34eda23 (diff)
downloadports-0190464df7a4c339a63cc0e942eb68d1fe5b23ae.tar.gz
ports-0190464df7a4c339a63cc0e942eb68d1fe5b23ae.zip
GCC uses an AWK script to generate source code that helps process
command-line options. According to POSIX, string comparisons (and hence sorting) are to be performed based on the locale's collating order. Alas GNU AWK only does so in POSIX mode, whereas starting with FreeBSD 11 we do so by default, running into a bug (or false assumption) with that script used by GCC. Setting MAKE_ARGS such that AWK is always invoked in the C locale works around this bug. PR: 210122, 211742 Submitted by: jkim
Notes
Notes: svn path=/head/; revision=420267
Diffstat (limited to 'lang/gcc48')
-rw-r--r--lang/gcc48/Makefile5
-rw-r--r--lang/gcc48/distinfo1
2 files changed, 5 insertions, 1 deletions
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 12da71889146..73e45fbab0e5 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -90,7 +90,10 @@ CONFIGURE_ARGS+=--disable-nls \
${ICONV_CONFIGURE_ARG} \
--with-pkgversion="FreeBSD Ports Collection" \
--with-system-zlib
-MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
+# On FreeBSD 11 and above AWK uses the locale's collating order which
+# runs into a bug in GCC (PR 211742).
+MAKE_ARGS+= MAKEINFOFLAGS="--no-split" \
+ AWK="${SETENV} LC_ALL=C ${AWK:Q}"
USE_LDCONFIG= ${TARGLIB}
PLIST_SUB= GCC_VERSION=${GCC_VERSION} \
GNU_HOST=${CONFIGURE_TARGET} \
diff --git a/lang/gcc48/distinfo b/lang/gcc48/distinfo
index b618f6667a4f..ccdd01732668 100644
--- a/lang/gcc48/distinfo
+++ b/lang/gcc48/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1471299749
SHA256 (gcc-4.8.5.tar.bz2) = 22fb1e7e0f68a63cee631d85b20461d1ea6bda162f03096350e38c8d427ecf23
SIZE (gcc-4.8.5.tar.bz2) = 86165587