aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc8
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2018-07-22 12:29:08 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2018-07-22 12:29:08 +0000
commit28deb461c434c5efcf8c58693ebbffd2cbb3a1c4 (patch)
tree2438b2cf4fc8d30123b9d5269fd8a87105ae180f /lang/gcc8
parent62e075e8d1e6081ec7e6f60464db2e3a7566fabf (diff)
downloadports-28deb461c434c5efcf8c58693ebbffd2cbb3a1c4.tar.gz
ports-28deb461c434c5efcf8c58693ebbffd2cbb3a1c4.zip
Forward port r469788 from lang/gcc6:
Filter the -mretpoline command-line option, which is understood by recent versions of clang (and used in the context of the Spectre security issues), but not GCC (which uses different options for the same) from CFLAGS and CXXFLAGS. This avoids the build of this port via bootstrap, which is the default and leverages both the system compiler (clang in most cases) plus a just built version GCC, to fail due to the latter not knowing -mretpoline. PR: 228205 Submitted by: rozhuk.im@gmail.com
Notes
Notes: svn path=/head/; revision=475105
Diffstat (limited to 'lang/gcc8')
-rw-r--r--lang/gcc8/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/lang/gcc8/Makefile b/lang/gcc8/Makefile
index 1b5bdcf23144..adf1c651218c 100644
--- a/lang/gcc8/Makefile
+++ b/lang/gcc8/Makefile
@@ -35,6 +35,8 @@ USES= compiler cpe gmake iconv libtool makeinfo perl5 tar:xz
USE_BINUTILS= yes
USE_PERL5= build
SSP_UNSAFE= yes
+CFLAGS:= ${CFLAGS:N-mretpoline}
+CXXFLAGS:= ${CXXFLAGS:N-mretpoline}
OPTIONS_DEFINE= BOOTSTRAP GRAPHITE
OPTIONS_DEFAULT= BOOTSTRAP