aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc8
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-12-15 15:52:45 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-12-15 15:52:45 +0000
commite5c9675c8ef55f3c9fdeb545fe6e1e12e41fa8e3 (patch)
tree148e4f66d713532ec7281356a2d1f1fe93528a80 /lang/gcc8
parente3c9aedcdeca86f009fdbf4c7dc9e4b68e34bcb5 (diff)
downloadports-e5c9675c8ef55f3c9fdeb545fe6e1e12e41fa8e3.tar.gz
ports-e5c9675c8ef55f3c9fdeb545fe6e1e12e41fa8e3.zip
Fix dependency loop on powerpc64
Notes
Notes: svn path=/head/; revision=487531
Diffstat (limited to 'lang/gcc8')
-rw-r--r--lang/gcc8/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/gcc8/Makefile b/lang/gcc8/Makefile
index 1d33510c66a1..d11acb1e402e 100644
--- a/lang/gcc8/Makefile
+++ b/lang/gcc8/Makefile
@@ -60,7 +60,9 @@ CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
.elif ${ARCH} == powerpc64
CONFIGURE_ENV+= UNAME_m="powerpc64"
-USE_GCC= yes
+USE_GCC= 5 # This port requires at least GCC 4.9, and we need
+ # to ensure not to cause a dependency on itself (so
+ # USE_GCC=yes or USE_GCC=X+ are not an option).
.elif ${ARCH} == powerpcspe
CONFIGURE_ARGS+= --with-cpu=8540 --enable-e500_double --without-fp