aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc8
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2020-03-09 19:41:30 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2020-03-09 19:41:30 +0000
commiteac6bba2850f7029e53d6e56c8ba4b3fec1d7582 (patch)
treeeed3941bb04bc4e9427c299296b335228e57388c /lang/gcc8
parentb55ffa5de01197b91bb327e8b91a8ec92fe320d3 (diff)
downloadports-eac6bba2850f7029e53d6e56c8ba4b3fec1d7582.tar.gz
ports-eac6bba2850f7029e53d6e56c8ba4b3fec1d7582.zip
Update to the GCC 8.4 release which fixes at least 209 bugs compared
to the previous. Multilib support on amd64 has been merged upstream, thus obsoleting files/patch-amd64-gcc-multilib-support .
Notes
Notes: svn path=/head/; revision=528120
Diffstat (limited to 'lang/gcc8')
-rw-r--r--lang/gcc8/Makefile3
-rw-r--r--lang/gcc8/distinfo6
-rw-r--r--lang/gcc8/files/patch-amd64-gcc-multilib-support73
3 files changed, 4 insertions, 78 deletions
diff --git a/lang/gcc8/Makefile b/lang/gcc8/Makefile
index 7d7c85f9e539..75dd45b56501 100644
--- a/lang/gcc8/Makefile
+++ b/lang/gcc8/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 8.3.0
-PORTREVISION= 3
+PORTVERSION= 8.4.0
CATEGORIES= lang
MASTER_SITES= GCC
PKGNAMESUFFIX= ${SUFFIX}
diff --git a/lang/gcc8/distinfo b/lang/gcc8/distinfo
index 161c2e307046..ae1b44bf00b6 100644
--- a/lang/gcc8/distinfo
+++ b/lang/gcc8/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1550871391
-SHA256 (gcc-8.3.0.tar.xz) = 64baadfe6cc0f4947a84cb12d7f0dfaf45bb58b7e92461639596c21e02d97d2c
-SIZE (gcc-8.3.0.tar.xz) = 63694700
+TIMESTAMP = 1583358481
+SHA256 (gcc-8.4.0.tar.xz) = e30a6e52d10e1f27ed55104ad233c30bd1e99cfb5ff98ab022dc941edd1b2dd4
+SIZE (gcc-8.4.0.tar.xz) = 63713440
diff --git a/lang/gcc8/files/patch-amd64-gcc-multilib-support b/lang/gcc8/files/patch-amd64-gcc-multilib-support
deleted file mode 100644
index ffae93210614..000000000000
--- a/lang/gcc8/files/patch-amd64-gcc-multilib-support
+++ /dev/null
@@ -1,73 +0,0 @@
---- UTC
-Index: gcc/config.gcc
-===================================================================
---- gcc/config.gcc (revision 269726)
-+++ gcc/config.gcc (working copy)
-@@ -4925,8 +4925,11 @@
- ;;
- i[34567]86-*-dragonfly* | x86_64-*-dragonfly*)
- ;;
-- i[34567]86-*-freebsd* | x86_64-*-freebsd*)
-+ i[34567]86-*-freebsd*)
- ;;
-+ x86_64-*-freebsd*)
-+ tmake_file="${tmake_file} i386/t-freebsd64"
-+ ;;
- ia64*-*-linux*)
- ;;
-
-Index: gcc/config/i386/freebsd64.h
-===================================================================
---- gcc/config/i386/freebsd64.h (revision 269733)
-+++ gcc/config/i386/freebsd64.h (working copy)
-@@ -31,7 +31,7 @@
-
- #undef LINK_SPEC
- #define LINK_SPEC "\
-- %{m32:-m elf_i386_fbsd} \
-+ %{m32:-m elf_i386_fbsd}%{!m32:-m elf_x86_64_fbsd} \
- %{p:%nconsider using '-pg' instead of '-p' with gprof(1)} \
- %{v:-V} \
- %{assert*} %{R*} %{rpath*} %{defsym*} \
-@@ -42,3 +42,6 @@
- -dynamic-linker %(fbsd_dynamic_linker) } \
- %{static:-Bstatic}} \
- %{symbolic:-Bsymbolic}"
-+
-+#undef MULTILIB_DEFAULTS
-+#define MULTILIB_DEFAULTS { "m64" }
-Index: gcc/config/i386/t-freebsd64
-===================================================================
---- gcc/config/i386/t-freebsd64 (nonexistent)
-+++ gcc/config/i386/t-freebsd64 (working copy)
-@@ -0,0 +1,30 @@
-+# Copyright (C) 2019 Free Software Foundation, Inc.
-+#
-+# This file is part of GCC.
-+#
-+# GCC is free software; you can redistribute it and/or modify
-+# it under the terms of the GNU General Public License as published by
-+# the Free Software Foundation; either version 3, or (at your option)
-+# any later version.
-+#
-+# GCC is distributed in the hope that it will be useful,
-+# but WITHOUT ANY WARRANTY; without even the implied warranty of
-+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+# GNU General Public License for more details.
-+#
-+# You should have received a copy of the GNU General Public License
-+# along with GCC; see the file COPYING3. If not see
-+# <http://www.gnu.org/licenses/>.
-+
-+# The 32-bit libraries are found in /usr/lib32
-+
-+# To support i386 and x86-64, the directory structrue
-+# should be:
-+#
-+# /lib has x86-64 libraries.
-+# /lib32 has i386 libraries.
-+#
-+
-+MULTILIB_OPTIONS = m32
-+MULTILIB_DIRNAMES = 32
-+MULTILIB_OSDIRNAMES = ../lib32