aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2017-03-26 20:01:07 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2017-03-26 20:01:07 +0000
commitf0653f107896de841ebac88d1fd8740182e632ad (patch)
tree26899aff253dec56e5d0dfa487a5cfbeb0d0ae2e /lang/gcc
parent85dbd6bedd3431240af63f8bb782e9d3d2ae3e5c (diff)
downloadports-f0653f107896de841ebac88d1fd8740182e632ad.tar.gz
ports-f0653f107896de841ebac88d1fd8740182e632ad.zip
Use relative links for the generic g++, gcc, and gfortran.
Replace a shell for-loop with a bmake .for-loop on the way. Reported by: danfe Reviewed by: danfe
Notes
Notes: svn path=/head/; revision=436983
Diffstat (limited to 'lang/gcc')
-rw-r--r--lang/gcc/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 1b7644fab29d..7899f9ce75ff 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gcc
PORTVERSION= 4.9.4
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= GCC/releases/gcc-${DISTVERSION}
@@ -163,8 +164,8 @@ post-stage:
cd ${WRKDIR} ; ${SED} -i -e "/PLIST.lib/ r PLIST.lib" ${TMPPLIST}
# This is the canonical GCC port, so add key commands without
# version numbers as part of their names.
- for c in gfortran g++ gcc; do \
- ${LN} -s ${PREFIX}/bin/"$$c"${SUFFIX} ${STAGEDIR}${PREFIX}/bin/$$c ; \
- done
+.for c in gfortran g++ gcc
+ ${LN} -s ${c}${SUFFIX} ${STAGEDIR}${PREFIX}/bin/${c}
+.endfor
.include <bsd.port.post.mk>