aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2017-02-03 16:00:56 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2017-02-03 16:00:56 +0000
commitf0c445178884e0f02d8353c37ede6420345c3f8b (patch)
treebf8512443604a6476dd28f96a030df64ae5457b6 /lang/gcc
parentafd9ff837a4b4e3f2a4ee04b1ba008847a0b87ce (diff)
downloadports-f0c445178884e0f02d8353c37ede6420345c3f8b.tar.gz
ports-f0c445178884e0f02d8353c37ede6420345c3f8b.zip
Remove traces of armv6hf which no longer exists as an arch. [1]
Remove an extraneous definition of DISTVERSION (which in general we only need for ports tracking weekly GCC snapshots) and simplify the definition of GCC_VERSION. Reported by: andreast [1]
Notes
Notes: svn path=/head/; revision=433249
Diffstat (limited to 'lang/gcc')
-rw-r--r--lang/gcc/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 1b3f6acc2a1c..1b7644fab29d 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -25,12 +25,11 @@ BUILD_DEPENDS+= runtest:misc/dejagnu
CONFLICTS= gcc49*
CPE_VENDOR= gnu
-# DISTVERSION relates to downloads, GCC_VERSION and SUFFIX to names
-# of executables and directories once installed.
-DISTVERSION= ${PORTVERSION}
-GCC_VERSION= ${PORTVERSION:C/(.+)\.[0-9]{8}/\1/}
+# GCC_VERSION and SUFFIX relate to names of executables and directories
+# once installed.
+GCC_VERSION= ${PORTVERSION}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
-ONLY_FOR_ARCHS= amd64 armv6 armv6hf i386 powerpc powerpc64 sparc64
+ONLY_FOR_ARCHS= amd64 armv6 i386 powerpc powerpc64 sparc64
USES= compiler cpe gmake iconv libtool makeinfo perl5 tar:bzip2
USE_BINUTILS= yes
USE_PERL5= build
@@ -65,7 +64,7 @@ CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
CONFIGURE_ENV+= UNAME_m="powerpc64"
.endif
-.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
+.if ${ARCH} == "armv6"
# Override sys.mk including -O in CFLAGS which breaks libgomp building.
CFLAGS:= ${CFLAGS:S/-O/-O2/g}
. if ${COMPILER_TYPE} == clang