aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2016-08-24 20:05:40 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2016-08-24 20:05:40 +0000
commitf7939668a6dcb361423b23c8607a15b01dc73288 (patch)
tree314d75f364ccf54aa953f014ed5fc906237d1f40 /lang/gcc
parent57118fe481f755fc9896e34e103bc18e0cefd1f3 (diff)
downloadports-f7939668a6dcb361423b23c8607a15b01dc73288.tar.gz
ports-f7939668a6dcb361423b23c8607a15b01dc73288.zip
Default powerpc64 to bootstrapping (option BOOTSTRAP) since otherwise
GCC can be mis-built, leading to an internal compiler error building libgcc/libgcov.c, at least on FreeBSD 11. Adjust OPTIONS_DEFINE_powerpc64 and OPTIONS_DEFAULT_powerpc64 incrementally (with +=) to avoid overwriting settings defined at the top of the Makefile (or child ports). [1] Submitted by: swills [1] Reported by: swills
Notes
Notes: svn path=/head/; revision=420820
Diffstat (limited to 'lang/gcc')
-rw-r--r--lang/gcc/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index f922d3d62181..551be7766464 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -42,12 +42,13 @@ OPTIONS_DEFINE_i386= JAVA
OPTIONS_DEFINE_amd64= JAVA
OPTIONS_DEFAULT_i386= JAVA
OPTIONS_DEFAULT_amd64= JAVA
+OPTIONS_DEFAULT_powerpc64= BOOTSTRAP
OPTIONS_EXCLUDE_DragonFly= JAVA
BOOTSTRAP_DESC= Build using a full bootstrap
.if exists(/usr/lib32/libc.so)
-OPTIONS_DEFINE_powerpc64= MULTILIB
-OPTIONS_DEFAULT_powerpc64= MULTILIB
+OPTIONS_DEFINE_powerpc64+= MULTILIB
+OPTIONS_DEFAULT_powerpc64+= MULTILIB
MULTILIB_DESC= Build support for 32-bit and 64-bit targets
MULTILIB_CONFIGURE_ENABLE= multilib
.else