aboutsummaryrefslogtreecommitdiff
path: root/lang/gdc
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-01-08 14:47:38 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-01-08 14:47:38 +0000
commit9e06994f34ebcae7c401a17bf8da5d48294eeb54 (patch)
treebd2c1c1ca26c286231d42a5c55c16680a5e47315 /lang/gdc
parent93705f051ceb9bbae010397f7ac3a3e812776e7e (diff)
downloadports-9e06994f34ebcae7c401a17bf8da5d48294eeb54.tar.gz
ports-9e06994f34ebcae7c401a17bf8da5d48294eeb54.zip
Notes
Diffstat (limited to 'lang/gdc')
-rw-r--r--lang/gdc/Makefile10
-rw-r--r--lang/gdc/distinfo18
-rw-r--r--lang/gdc/pkg-plist13
3 files changed, 26 insertions, 15 deletions
diff --git a/lang/gdc/Makefile b/lang/gdc/Makefile
index e0b391a134d0..4fc5d773e52b 100644
--- a/lang/gdc/Makefile
+++ b/lang/gdc/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gdc
-PORTVERSION= 0.19
-PORTREVISION= 2
+PORTVERSION= 0.21
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GCC} \
${MASTER_SITE_SOURCEFORGE:S/%SUBDIR%/dgcc/g:S/$/:gdc/g}
@@ -51,7 +50,7 @@ TARGET_GCC= 3.4 # default
.if ${TARGET_GCC} == 4.0
GCC_VERSION= 4.0.4
-GCC_REVISION= 20060720
+GCC_REVISION= 20061228
GCC_VERSIONSTRING= 4.0-${GCC_REVISION}
GCC_MASTER_SITE_SUBDIR= snapshots/${GCC_VERSIONSTRING}
.else
@@ -118,6 +117,11 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gcc/gdc ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/gcc/cc1d ${PREFIX}/bin
${INSTALL_SCRIPT} ${GCCDIR}/d/dmd-script ${PREFIX}/bin/gdmd
+.ifndef NOPORTDOCS
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${GCCDIR}/d/GDC.html ${DOCSDIR}
+ ${INSTALL_DATA} ${GCCDIR}/d/README ${DOCSDIR}/README.gdc
+.endif
${INSTALL_MAN} ${GCCDIR}/d/gdc.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${GCCDIR}/d/dmd-script.1 ${PREFIX}/man/man1/gdmd.1
@(cd ${WRKSRC} && ${GMAKE} install-target-libphobos)
diff --git a/lang/gdc/distinfo b/lang/gdc/distinfo
index 6947b440bb18..1e6e00460ddd 100644
--- a/lang/gdc/distinfo
+++ b/lang/gdc/distinfo
@@ -1,15 +1,15 @@
-MD5 (gdc-0.19-src.tar.bz2) = 4e6d32b58e7a68b67a54e5890245ead0
-SHA256 (gdc-0.19-src.tar.bz2) = 1cf22ae9904c0654674b486ee4a78f9e887e223b125349301e31d89a34466e8e
-SIZE (gdc-0.19-src.tar.bz2) = 924379
+MD5 (gdc-0.21-src.tar.bz2) = 32098080a6ef7dfa19a4223ea9cb05ca
+SHA256 (gdc-0.21-src.tar.bz2) = c5bef02fb94d508e56990d86ded13da447d4e0664c2c41b037eefae96cd97425
+SIZE (gdc-0.21-src.tar.bz2) = 978636
MD5 (gcc-core-3.4.6.tar.bz2) = 5324ace5145b12afd9ca867af7ec084d
SHA256 (gcc-core-3.4.6.tar.bz2) = 3aab171d86e5a6c14cb9de35467a0472a7d5ef1d5b79a1df72ca533f8e82a133
SIZE (gcc-core-3.4.6.tar.bz2) = 13366790
MD5 (gcc-g++-3.4.6.tar.bz2) = ef81fd74bc9fd964120af47243a1360f
SHA256 (gcc-g++-3.4.6.tar.bz2) = f186937402752d25317adf2832b0b1d316334e158ae380471ab62509e4ea90b1
SIZE (gcc-g++-3.4.6.tar.bz2) = 2511332
-MD5 (gcc-core-4.0-20060720.tar.bz2) = 5a306612feac33a98b3dcb394613e583
-SHA256 (gcc-core-4.0-20060720.tar.bz2) = e0542a581dbcd4bdba72d27569100ebbaa7eb30b22abd7d297d8cdae55f2c03b
-SIZE (gcc-core-4.0-20060720.tar.bz2) = 13775528
-MD5 (gcc-g++-4.0-20060720.tar.bz2) = 1eacaad525f6ad0afa517e262547c483
-SHA256 (gcc-g++-4.0-20060720.tar.bz2) = 51c72539eb72e2fb3ea79f95be92bcc599726f28024cf7b2744e27a908f37ce6
-SIZE (gcc-g++-4.0-20060720.tar.bz2) = 2717701
+MD5 (gcc-core-4.0-20061228.tar.bz2) = 395ea3b0c07b42a6eeb41112dd54ea89
+SHA256 (gcc-core-4.0-20061228.tar.bz2) = cf9c479a1ec99a4dac71f243e5d2d58f556e8e88aac912e51fa5571e516637eb
+SIZE (gcc-core-4.0-20061228.tar.bz2) = 13787783
+MD5 (gcc-g++-4.0-20061228.tar.bz2) = a03201faeeaceb2188125c87404fc560
+SHA256 (gcc-g++-4.0-20061228.tar.bz2) = 280297708243d2a3d9f36c0729d4c1267ad9c7390248d3ca0c00832c090816ff
+SIZE (gcc-g++-4.0-20061228.tar.bz2) = 2721301
diff --git a/lang/gdc/pkg-plist b/lang/gdc/pkg-plist
index 983faf0d3d40..012d6e5ffb71 100644
--- a/lang/gdc/pkg-plist
+++ b/lang/gdc/pkg-plist
@@ -5,13 +5,10 @@ include/d/%%GCC_VER%%/etc/gamma.d
include/d/%%GCC_VER%%/etc/c/zlib.d
include/d/%%GCC_VER%%/etc/c/zlib/crc32.h
include/d/%%GCC_VER%%/etc/c/zlib/deflate.h
-include/d/%%GCC_VER%%/etc/c/zlib/infblock.h
-include/d/%%GCC_VER%%/etc/c/zlib/infcodes.h
include/d/%%GCC_VER%%/etc/c/zlib/inffast.h
include/d/%%GCC_VER%%/etc/c/zlib/inffixed.h
include/d/%%GCC_VER%%/etc/c/zlib/inflate.h
include/d/%%GCC_VER%%/etc/c/zlib/inftrees.h
-include/d/%%GCC_VER%%/etc/c/zlib/infutil.h
include/d/%%GCC_VER%%/etc/c/zlib/trees.h
include/d/%%GCC_VER%%/etc/c/zlib/zconf.h
include/d/%%GCC_VER%%/etc/c/zlib/zconf.in.h
@@ -28,11 +25,13 @@ include/d/%%GCC_VER%%/gcc/unwind.d
include/d/%%GCC_VER%%/std/array.d
include/d/%%GCC_VER%%/std/asserterror.d
include/d/%%GCC_VER%%/std/base64.d
+include/d/%%GCC_VER%%/std/bind.d
include/d/%%GCC_VER%%/std/bitarray.d
include/d/%%GCC_VER%%/std/boxer.d
include/d/%%GCC_VER%%/std/compiler.d
include/d/%%GCC_VER%%/std/conv.d
include/d/%%GCC_VER%%/std/cover.d
+include/d/%%GCC_VER%%/std/cpuid.d
include/d/%%GCC_VER%%/std/cstream.d
include/d/%%GCC_VER%%/std/ctype.d
include/d/%%GCC_VER%%/std/date.d
@@ -56,6 +55,7 @@ include/d/%%GCC_VER%%/std/perf.d
include/d/%%GCC_VER%%/std/process.d
include/d/%%GCC_VER%%/std/random.d
include/d/%%GCC_VER%%/std/regexp.d
+include/d/%%GCC_VER%%/std/signals.d
include/d/%%GCC_VER%%/std/socket.d
include/d/%%GCC_VER%%/std/socketstream.d
include/d/%%GCC_VER%%/std/stdarg.d
@@ -67,6 +67,8 @@ include/d/%%GCC_VER%%/std/switcherr.d
include/d/%%GCC_VER%%/std/syserror.d
include/d/%%GCC_VER%%/std/system.d
include/d/%%GCC_VER%%/std/thread.d
+include/d/%%GCC_VER%%/std/traits.d
+include/d/%%GCC_VER%%/std/typetuple.d
include/d/%%GCC_VER%%/std/uni.d
include/d/%%GCC_VER%%/std/uri.d
include/d/%%GCC_VER%%/std/utf.d
@@ -74,6 +76,7 @@ include/d/%%GCC_VER%%/std/zip.d
include/d/%%GCC_VER%%/std/zlib.d
include/d/%%GCC_VER%%/std/c/dirent.d
include/d/%%GCC_VER%%/std/c/fenv.d
+include/d/%%GCC_VER%%/std/c/locale.d
include/d/%%GCC_VER%%/std/c/math.d
include/d/%%GCC_VER%%/std/c/process.d
include/d/%%GCC_VER%%/std/c/stdarg.d
@@ -94,6 +97,7 @@ include/d/%%GCC_VER%%/std/c/skyos/compat.d
include/d/%%GCC_VER%%/std/c/skyos/skyos.d
include/d/%%GCC_VER%%/std/c/unix/unix.d
include/d/%%GCC_VER%%/std/c/windows/com.d
+include/d/%%GCC_VER%%/std/c/windows/stat.d
include/d/%%GCC_VER%%/std/c/windows/windows.d
include/d/%%GCC_VER%%/std/c/windows/winsock.d
include/d/%%GCC_VER%%/std/typeinfo/ti_AC.d
@@ -152,6 +156,8 @@ include/d/%%GCC_VER%%/%%CONF_TARGET%%/gcc/configunix.d
include/d/%%GCC_VER%%/%%CONF_TARGET%%/phobos-ver-syms
lib/libgphobos.a
lib/libgphobos.spec
+%%PORTDOCS%%%%DOCSDIR%%/GDC.html
+%%PORTDOCS%%%%DOCSDIR%%/README.gdc
@dirrm include/d/%%GCC_VER%%/etc/c/zlib
@dirrm include/d/%%GCC_VER%%/etc/c
@dirrm include/d/%%GCC_VER%%/etc
@@ -170,3 +176,4 @@ lib/libgphobos.spec
@dirrm include/d/%%GCC_VER%%/%%CONF_TARGET%%
@dirrm include/d/%%GCC_VER%%
@dirrm include/d
+%%PORTDOCS%%@dirrm %%DOCSDIR%%