aboutsummaryrefslogtreecommitdiff
path: root/lang/gforth
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2011-12-11 17:17:01 +0000
committerJohan van Selst <johans@FreeBSD.org>2011-12-11 17:17:01 +0000
commited159cd4eb0cee7eecf5ce2caa97ebaff34385fe (patch)
tree9ff8932ce7684032bb22c574583a9f1f31fe12e7 /lang/gforth
parentdd11bf0e93bfc1060524219bd2073184491795b1 (diff)
downloadports-ed159cd4eb0cee7eecf5ce2caa97ebaff34385fe.tar.gz
ports-ed159cd4eb0cee7eecf5ce2caa97ebaff34385fe.zip
- Update GNU Forth to 0.7.0
- Remove patches (and autoconf run) that are no longer needed - Fix build with ffcall and libffi (requires libtool, libltdl) - Remove emacs config file for now (will try and fix this soon) - Adopt port Feature safe: yes
Notes
Notes: svn path=/head/; revision=287190
Diffstat (limited to 'lang/gforth')
-rw-r--r--lang/gforth/Makefile37
-rw-r--r--lang/gforth/distinfo4
-rw-r--r--lang/gforth/files/patch-Makefile.in20
-rw-r--r--lang/gforth/files/patch-comp-i.fs16
-rw-r--r--lang/gforth/files/patch-configure21
-rw-r--r--lang/gforth/files/patch-engine_main.c22
-rw-r--r--lang/gforth/pkg-plist98
7 files changed, 114 insertions, 104 deletions
diff --git a/lang/gforth/Makefile b/lang/gforth/Makefile
index 36370159ab8c..f4f190fd4f32 100644
--- a/lang/gforth/Makefile
+++ b/lang/gforth/Makefile
@@ -6,32 +6,29 @@
#
PORTNAME= gforth
-PORTVERSION= 0.6.2
-PORTREVISION= 3
+PORTVERSION= 0.7.0
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gforth
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= johans@FreeBSD.org
COMMENT= Fast and portable Forth system
+LIB_DEPENDS= ffi:${PORTSDIR}/devel/libffi
+BUILD_DEPENDS= ${LOCALBASE}/include/avcall.h:${PORTSDIR}/devel/ffcall
+
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -fno-reorder-blocks -fno-inline
USE_GMAKE= yes
+USE_AUTOTOOLS= libtool libltdl
+USE_LDCONFIG= ${PREFIX}/lib/gforth/${PORTVERSION}/libcc-named
ALL_TARGET= all info
-USE_EMACS= yes
-EMACS_NO_BUILD_DEPENDS= yes
-EMACS_NO_RUN_DEPENDS= yes
-OPTIONS= FFCALL "Use ffcall" on
-
-CFLAGS+= -fno-reorder-blocks -fno-inline
STRIP= #none
PLIST_SUB= PORTVERSION="${PORTVERSION}" \
- EMACS_DIR="${EMACS_SITE_LISPDIR}" \
WORDSIZE=${WORDSIZE} BYTEORDER=${BYTEORDER}
DOC_FILES= AUTHORS BUGS Benchres COPYING COPYING.DOC \
@@ -44,14 +41,6 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_FFCALL)
-BUILD_DEPENDS= ${LOCALBASE}/include/avcall.h:${PORTSDIR}/devel/ffcall
-.endif
-
-.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
-BROKEN= Does not compile
-.endif
-
.if ${ARCH} == i386 || ${ARCH} == "powerpc"
WORDSIZE=32
.else
@@ -64,7 +53,11 @@ BYTEORDER=b
BYTEORDER=l
.endif
-post-install: install-doc install-el remove-empty-files remove-empty-dirs
+post-patch:
+ ${REINPLACE_CMD} 's:@CC@:& -I${LOCALBASE}/include -L${LOCALBASE}/lib:' \
+ ${WRKSRC}/envos.fs.in
+
+post-install: install-doc remove-empty-files remove-empty-dirs
install-doc:
.if !defined(NOPORTDOCS)
@@ -74,10 +67,6 @@ install-doc:
.endfor
.endif
-# Install Emacs syntax file
-install-el:
- @${INSTALL_DATA} ${WRKSRC}/gforth.el ${PREFIX}/${EMACS_SITE_LISPDIR}
-
# Remove unused file
remove-empty-files:
@${RM} -f ${DATADIR}/site-forth/siteinit.fs
diff --git a/lang/gforth/distinfo b/lang/gforth/distinfo
index b71e951cef9c..382dc74a02b5 100644
--- a/lang/gforth/distinfo
+++ b/lang/gforth/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gforth-0.6.2.tar.gz) = 28a201ae78b073ef350d7ac4a8283233029c6afe6072620ac6dd6db1d192d462
-SIZE (gforth-0.6.2.tar.gz) = 1925536
+SHA256 (gforth-0.7.0.tar.gz) = 4841e3d25329d5aa29876a641d1e681809719fa5de3982007ecaf74d8056fffe
+SIZE (gforth-0.7.0.tar.gz) = 2277918
diff --git a/lang/gforth/files/patch-Makefile.in b/lang/gforth/files/patch-Makefile.in
new file mode 100644
index 000000000000..91cd03515474
--- /dev/null
+++ b/lang/gforth/files/patch-Makefile.in
@@ -0,0 +1,20 @@
+--- Makefile.in.orig 2008-11-01 18:22:27.000000000 +0100
++++ Makefile.in 2011-12-11 16:03:54.000000000 +0100
+@@ -430,7 +430,7 @@ ENGINES = gforth$(EC)$(EXE) gforth-ditc$
+
+ ENGINES_FAST = gforth-fast$(OPT)$(EC)$(EXE) #gforth-native$(OPT)$(EC)$(EXE)
+
+-GEN = $(ENGINES) $(ENGINES_FAST) gforth.elc
++GEN = $(ENGINES) $(ENGINES_FAST)
+
+ # things that need a working forth system to be generated
+ FORTH_GEN_ENGINE=engine/prim.i engine/prim_lab.i engine/prim_names.i \
+@@ -613,7 +613,7 @@ install: gforth$(EC)$(EXE) $(FORTH_SRC)
+ $(INSTALL_DATA) $(srcdir)/$$i $(DESTDIR)$(datadir)/gforth/$(VERSION)/$$i; \
+ done
+ $(INSTALL_DATA) $(kernel_fi) $(DESTDIR)$(datadir)/gforth/$(VERSION)
+- @if test -d "$(DESTDIR)$(emacssitelispdir)"; then \
++ @if test -r gforth.elc -a -d "$(DESTDIR)$(emacssitelispdir)"; then \
+ $(INSTALL_DATA) gforth.el $(DESTDIR)$(emacssitelispdir); \
+ $(INSTALL_DATA) gforth.elc $(DESTDIR)$(emacssitelispdir); \
+ else \
diff --git a/lang/gforth/files/patch-comp-i.fs b/lang/gforth/files/patch-comp-i.fs
deleted file mode 100644
index dd3abb7e8b2b..000000000000
--- a/lang/gforth/files/patch-comp-i.fs
+++ /dev/null
@@ -1,16 +0,0 @@
-Index: comp-i.fs
-===================================================================
-RCS file: /usr/local/lib/cvs-repository/src-master/gforth/comp-i.fs,v
-retrieving revision 1.14
-diff -u -r1.14 comp-i.fs
---- comp-i.fs 2003/08/25 14:17:43 1.14
-+++ comp-i.fs 2004/03/10 16:26:46
-@@ -43,7 +43,7 @@
- if
- ." : images have the same base address; producing only a data-relocatable image" cr
- else
-- offset abs expected-offset <> abort" images produced by different engines"
-+ \ offset abs expected-offset <> abort" images produced by different engines"
- ." offset=" offset . cr
- 0 image1 i-field + ! 0 image2 i-field + !
- endif
diff --git a/lang/gforth/files/patch-configure b/lang/gforth/files/patch-configure
deleted file mode 100644
index dfe8191ccbbe..000000000000
--- a/lang/gforth/files/patch-configure
+++ /dev/null
@@ -1,21 +0,0 @@
---- configure.orig 2003-08-25 10:03:42.000000000 +0200
-+++ configure 2010-10-09 20:40:43.000000000 +0200
-@@ -3584,9 +3584,6 @@
- else
- LIBOBJS="$LIBOBJS ../arch/power/_sync_cache_range.$ac_objext"
- fi
--
-- #long long is broken on (at least) gcc-2.95.* for PPC
-- test x$ac_cv_sizeof_long_long = x && ac_cv_sizeof_long_long=0
- ;;
- *)
- { echo "$as_me:$LINENO: WARNING: Using a generic machine description" >&5
-@@ -8079,8 +8076,8 @@
- if (x) {
- label1:
- asm("$i");
-- label2:
- }
-+ label2:
- return (&&label2)-(&&label1);
- }
diff --git a/lang/gforth/files/patch-engine_main.c b/lang/gforth/files/patch-engine_main.c
deleted file mode 100644
index e28faa1f4cd5..000000000000
--- a/lang/gforth/files/patch-engine_main.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- engine/main.c.orig Sun Aug 24 12:06:29 2003
-+++ engine/main.c Sat Oct 21 11:36:19 2006
-@@ -70,8 +70,18 @@
-
- void engine_callback(Xt* fcall, void * alist)
- {
-+ Cell *rp = RP;
-+ Cell *sp = SP;
-+ Float *fp = FP;
-+ Address lp = LP;
-+
- clist = (va_alist)alist;
-- engine(fcall, SP, RP, FP, LP);
-+ engine(fcall, sp, rp, fp, lp);
-+
-+ RP = rp;
-+ SP = sp;
-+ FP = fp;
-+ LP = lp;
- }
- #endif
-
diff --git a/lang/gforth/pkg-plist b/lang/gforth/pkg-plist
index b427a5c504ba..c88e8bf565a8 100644
--- a/lang/gforth/pkg-plist
+++ b/lang/gforth/pkg-plist
@@ -14,9 +14,26 @@ bin/gforthmi-%%PORTVERSION%%
bin/vmgen-%%PORTVERSION%%
@exec ln -fs %f %B/vmgen
@unexec rm -f %B/vmgen
+include/gforth/%%PORTVERSION%%/config.h
+include/gforth/%%PORTVERSION%%/libcc.h
lib/gforth/%%PORTVERSION%%/gforth-ditc
lib/gforth/%%PORTVERSION%%/gforth.fi
-%%EMACS_DIR%%/gforth.el
+lib/gforth/%%PORTVERSION%%/libcc-named/cstr.so.0
+lib/gforth/%%PORTVERSION%%/libcc-named/cstr.so
+lib/gforth/%%PORTVERSION%%/libcc-named/cstr.la
+lib/gforth/%%PORTVERSION%%/libcc-named/cstr.a
+lib/gforth/%%PORTVERSION%%/libcc-named/socket.so.0
+lib/gforth/%%PORTVERSION%%/libcc-named/socket.so
+lib/gforth/%%PORTVERSION%%/libcc-named/socket.la
+lib/gforth/%%PORTVERSION%%/libcc-named/socket.a
+lib/gforth/%%PORTVERSION%%/libcc-named/libffi.so.0
+lib/gforth/%%PORTVERSION%%/libcc-named/libffi.so
+lib/gforth/%%PORTVERSION%%/libcc-named/libffi.la
+lib/gforth/%%PORTVERSION%%/libcc-named/libffi.a
+lib/gforth/%%PORTVERSION%%/libcc-named/fflib.so.0
+lib/gforth/%%PORTVERSION%%/libcc-named/fflib.so
+lib/gforth/%%PORTVERSION%%/libcc-named/fflib.la
+lib/gforth/%%PORTVERSION%%/libcc-named/fflib.a
%%DATADIR%%/%%PORTVERSION%%/TAGS
%%DATADIR%%/%%PORTVERSION%%/add.fs
%%DATADIR%%/%%PORTVERSION%%/ans-report.fs
@@ -26,9 +43,17 @@ lib/gforth/%%PORTVERSION%%/gforth.fi
%%DATADIR%%/%%PORTVERSION%%/arch/386/disasm.fs
%%DATADIR%%/%%PORTVERSION%%/arch/alpha/asm.fs
%%DATADIR%%/%%PORTVERSION%%/arch/alpha/disasm.fs
+%%DATADIR%%/%%PORTVERSION%%/arch/alpha/testasm.fs
+%%DATADIR%%/%%PORTVERSION%%/arch/amd64/asm.fs
+%%DATADIR%%/%%PORTVERSION%%/arch/amd64/disasm.fs
%%DATADIR%%/%%PORTVERSION%%/arch/mips/asm.fs
%%DATADIR%%/%%PORTVERSION%%/arch/mips/disasm.fs
%%DATADIR%%/%%PORTVERSION%%/arch/mips/insts.fs
+%%DATADIR%%/%%PORTVERSION%%/arch/mips/testasm.fs
+%%DATADIR%%/%%PORTVERSION%%/arch/mips/testdisasm.fs
+%%DATADIR%%/%%PORTVERSION%%/arch/power/asm.fs
+%%DATADIR%%/%%PORTVERSION%%/arch/power/disasm.fs
+%%DATADIR%%/%%PORTVERSION%%/arch/power/inst.fs
%%DATADIR%%/%%PORTVERSION%%/asm/README
%%DATADIR%%/%%PORTVERSION%%/asm/basic.fs
%%DATADIR%%/%%PORTVERSION%%/asm/bitmask.fs
@@ -41,6 +66,7 @@ lib/gforth/%%PORTVERSION%%/gforth.fi
%%DATADIR%%/%%PORTVERSION%%/blocks.fs
%%DATADIR%%/%%PORTVERSION%%/bubble.fs
%%DATADIR%%/%%PORTVERSION%%/bufio.fs
+%%DATADIR%%/%%PORTVERSION%%/build-ec.in
%%DATADIR%%/%%PORTVERSION%%/chains.fs
%%DATADIR%%/%%PORTVERSION%%/code.fs
%%DATADIR%%/%%PORTVERSION%%/colorize.fs
@@ -51,15 +77,21 @@ lib/gforth/%%PORTVERSION%%/gforth.fi
%%DATADIR%%/%%PORTVERSION%%/compat/control.fs
%%DATADIR%%/%%PORTVERSION%%/compat/defer.fs
%%DATADIR%%/%%PORTVERSION%%/compat/exception.fs
+%%DATADIR%%/%%PORTVERSION%%/compat/execute-parsing.fs
%%DATADIR%%/%%PORTVERSION%%/compat/loops.fs
%%DATADIR%%/%%PORTVERSION%%/compat/required.fs
%%DATADIR%%/%%PORTVERSION%%/compat/strcomp.fs
%%DATADIR%%/%%PORTVERSION%%/compat/struct.fs
%%DATADIR%%/%%PORTVERSION%%/compat/vocabulary.fs
+%%DATADIR%%/%%PORTVERSION%%/complex.fs
%%DATADIR%%/%%PORTVERSION%%/cross.fs
+%%DATADIR%%/%%PORTVERSION%%/cstr.fs
%%DATADIR%%/%%PORTVERSION%%/debug.fs
%%DATADIR%%/%%PORTVERSION%%/debugs.fs
+%%DATADIR%%/%%PORTVERSION%%/depth-changes.fs
+%%DATADIR%%/%%PORTVERSION%%/dis-gdb.fs
%%DATADIR%%/%%PORTVERSION%%/doc/makedoc.fs
+%%DATADIR%%/%%PORTVERSION%%/dosekey.fs
%%DATADIR%%/%%PORTVERSION%%/doskey.fs
%%DATADIR%%/%%PORTVERSION%%/ds2texi.fs
%%DATADIR%%/%%PORTVERSION%%/ec/README
@@ -69,6 +101,7 @@ lib/gforth/%%PORTVERSION%%/gforth.fi
%%DATADIR%%/%%PORTVERSION%%/ec/nesting.fs
%%DATADIR%%/%%PORTVERSION%%/ec/shex.fs
%%DATADIR%%/%%PORTVERSION%%/ekey.fs
+%%DATADIR%%/%%PORTVERSION%%/endtry-iferror.fs
%%DATADIR%%/%%PORTVERSION%%/environ.fs
%%DATADIR%%/%%PORTVERSION%%/envos.dos
%%DATADIR%%/%%PORTVERSION%%/envos.fs
@@ -79,17 +112,20 @@ lib/gforth/%%PORTVERSION%%/gforth.fi
%%DATADIR%%/%%PORTVERSION%%/except.fs
%%DATADIR%%/%%PORTVERSION%%/extend.fs
%%DATADIR%%/%%PORTVERSION%%/fflib.fs
+%%DATADIR%%/%%PORTVERSION%%/fft.fs
%%DATADIR%%/%%PORTVERSION%%/fi2c.fs
%%DATADIR%%/%%PORTVERSION%%/fib.fs
%%DATADIR%%/%%PORTVERSION%%/filedump.fs
%%DATADIR%%/%%PORTVERSION%%/fixpath.fs
%%DATADIR%%/%%PORTVERSION%%/float.fs
+%%DATADIR%%/%%PORTVERSION%%/fsl-util.4th
%%DATADIR%%/%%PORTVERSION%%/glocals.fs
%%DATADIR%%/%%PORTVERSION%%/glosgen.fs
%%DATADIR%%/%%PORTVERSION%%/gray.fs
%%DATADIR%%/%%PORTVERSION%%/hash.fs
%%DATADIR%%/%%PORTVERSION%%/history.fs
%%DATADIR%%/%%PORTVERSION%%/httpd.fs
+%%DATADIR%%/%%PORTVERSION%%/install-tags.fs
%%DATADIR%%/%%PORTVERSION%%/intcomp.fs
%%DATADIR%%/%%PORTVERSION%%/kernel/accept.fs
%%DATADIR%%/%%PORTVERSION%%/kernel/aliases.fs
@@ -121,8 +157,11 @@ lib/gforth/%%PORTVERSION%%/gforth.fi
%%DATADIR%%/%%PORTVERSION%%/kernel/tools.fs
%%DATADIR%%/%%PORTVERSION%%/kernel/toolsext.fs
%%DATADIR%%/%%PORTVERSION%%/kernel/vars.fs
-%%DATADIR%%/%%PORTVERSION%%/kernl%%WORDSIZE%%%%BYTEORDER%%.fi
+%%DATADIR%%/%%PORTVERSION%%/kernel/xchars.fs
+%%DATADIR%%/%%PORTVERSION%%/kernl64l.fi
%%DATADIR%%/%%PORTVERSION%%/lib.fs
+%%DATADIR%%/%%PORTVERSION%%/libcc.fs
+%%DATADIR%%/%%PORTVERSION%%/libffi.fs
%%DATADIR%%/%%PORTVERSION%%/locals.fs
%%DATADIR%%/%%PORTVERSION%%/locate.fs
%%DATADIR%%/%%PORTVERSION%%/look.fs
@@ -136,20 +175,25 @@ lib/gforth/%%PORTVERSION%%/gforth.fi
%%DATADIR%%/%%PORTVERSION%%/make-app.fs
%%DATADIR%%/%%PORTVERSION%%/matrix.fs
%%DATADIR%%/%%PORTVERSION%%/mini-oof.fs
+%%DATADIR%%/%%PORTVERSION%%/mkdir.fs
%%DATADIR%%/%%PORTVERSION%%/moof-exm.fs
%%DATADIR%%/%%PORTVERSION%%/moofglos.fs
%%DATADIR%%/%%PORTVERSION%%/more.fs
%%DATADIR%%/%%PORTVERSION%%/objects.fs
%%DATADIR%%/%%PORTVERSION%%/objexamp.fs
%%DATADIR%%/%%PORTVERSION%%/oldlib.fs
+%%DATADIR%%/%%PORTVERSION%%/onebench.fs
%%DATADIR%%/%%PORTVERSION%%/oof.fs
%%DATADIR%%/%%PORTVERSION%%/oofsampl.fs
%%DATADIR%%/%%PORTVERSION%%/other.fs
%%DATADIR%%/%%PORTVERSION%%/prim
%%DATADIR%%/%%PORTVERSION%%/prims2x.fs
+%%DATADIR%%/%%PORTVERSION%%/prims2x0.6.2.fs
%%DATADIR%%/%%PORTVERSION%%/proxy.fs
%%DATADIR%%/%%PORTVERSION%%/quotes.fs
%%DATADIR%%/%%PORTVERSION%%/random.fs
+%%DATADIR%%/%%PORTVERSION%%/recover-endtry.fs
+%%DATADIR%%/%%PORTVERSION%%/regexp.fs
%%DATADIR%%/%%PORTVERSION%%/savesys.fs
%%DATADIR%%/%%PORTVERSION%%/search.fs
%%DATADIR%%/%%PORTVERSION%%/see-ext.fs
@@ -162,43 +206,59 @@ lib/gforth/%%PORTVERSION%%/gforth.fi
%%DATADIR%%/%%PORTVERSION%%/startup.fs
%%DATADIR%%/%%PORTVERSION%%/string.fs
%%DATADIR%%/%%PORTVERSION%%/struct.fs
+%%DATADIR%%/%%PORTVERSION%%/struct0x.fs
%%DATADIR%%/%%PORTVERSION%%/stuff.fs
%%DATADIR%%/%%PORTVERSION%%/table.fs
%%DATADIR%%/%%PORTVERSION%%/tags.fs
%%DATADIR%%/%%PORTVERSION%%/tasker.fs
%%DATADIR%%/%%PORTVERSION%%/termsize.fs
%%DATADIR%%/%%PORTVERSION%%/test/checkans.fs
+%%DATADIR%%/%%PORTVERSION%%/test/coreext.fs
+%%DATADIR%%/%%PORTVERSION%%/test/coremore.fs
%%DATADIR%%/%%PORTVERSION%%/test/coretest.fs
%%DATADIR%%/%%PORTVERSION%%/test/dbltest.fs
+%%DATADIR%%/%%PORTVERSION%%/test/deferred.fs
%%DATADIR%%/%%PORTVERSION%%/test/float.fs
+%%DATADIR%%/%%PORTVERSION%%/test/gforth-nofast.fs
%%DATADIR%%/%%PORTVERSION%%/test/gforth.fs
+%%DATADIR%%/%%PORTVERSION%%/test/libcc.fs
%%DATADIR%%/%%PORTVERSION%%/test/other.fs
%%DATADIR%%/%%PORTVERSION%%/test/postpone.fs
+%%DATADIR%%/%%PORTVERSION%%/test/primtest.fs
+%%DATADIR%%/%%PORTVERSION%%/test/search.fs
%%DATADIR%%/%%PORTVERSION%%/test/signals.fs
%%DATADIR%%/%%PORTVERSION%%/test/string.fs
%%DATADIR%%/%%PORTVERSION%%/test/tester.fs
+%%DATADIR%%/%%PORTVERSION%%/test/ttester.fs
%%DATADIR%%/%%PORTVERSION%%/tt.fs
%%DATADIR%%/%%PORTVERSION%%/unbuffer.fs
%%DATADIR%%/%%PORTVERSION%%/unix/socket.fs
+%%DATADIR%%/%%PORTVERSION%%/utf-8.fs
%%DATADIR%%/%%PORTVERSION%%/vt100.fs
%%DATADIR%%/%%PORTVERSION%%/vt100key.fs
%%DATADIR%%/%%PORTVERSION%%/wordinfo.fs
%%DATADIR%%/%%PORTVERSION%%/wordsets.fs
+%%DATADIR%%/%%PORTVERSION%%/xwords.fs
@exec mkdir -p %D/%%DATADIR%%/site-forth
-@dirrmtry %%DATADIR%%/site-forth
-@dirrmtry %%DATADIR%%/%%PORTVERSION%%/unix
-@dirrmtry %%DATADIR%%/%%PORTVERSION%%/test
-@dirrmtry %%DATADIR%%/%%PORTVERSION%%/kernel
-@dirrmtry %%DATADIR%%/%%PORTVERSION%%/ec
-@dirrmtry %%DATADIR%%/%%PORTVERSION%%/doc
-@dirrmtry %%DATADIR%%/%%PORTVERSION%%/compat
-@dirrmtry %%DATADIR%%/%%PORTVERSION%%/asm
-@dirrmtry %%DATADIR%%/%%PORTVERSION%%/arch/mips
-@dirrmtry %%DATADIR%%/%%PORTVERSION%%/arch/alpha
-@dirrmtry %%DATADIR%%/%%PORTVERSION%%/arch/386
-@dirrmtry %%DATADIR%%/%%PORTVERSION%%/arch
-@dirrmtry %%DATADIR%%/%%PORTVERSION%%
-@dirrmtry %%DATADIR%%
-@dirrmtry lib/gforth/site-forth
-@dirrmtry lib/gforth/%%PORTVERSION%%
-@dirrmtry lib/gforth
+@dirrm %%DATADIR%%/site-forth
+@dirrm %%DATADIR%%/%%PORTVERSION%%/unix
+@dirrm %%DATADIR%%/%%PORTVERSION%%/test
+@dirrm %%DATADIR%%/%%PORTVERSION%%/kernel
+@dirrm %%DATADIR%%/%%PORTVERSION%%/ec
+@dirrm %%DATADIR%%/%%PORTVERSION%%/doc
+@dirrm %%DATADIR%%/%%PORTVERSION%%/compat
+@dirrm %%DATADIR%%/%%PORTVERSION%%/asm
+@dirrm %%DATADIR%%/%%PORTVERSION%%/arch/386
+@dirrm %%DATADIR%%/%%PORTVERSION%%/arch/alpha
+@dirrm %%DATADIR%%/%%PORTVERSION%%/arch/amd64
+@dirrm %%DATADIR%%/%%PORTVERSION%%/arch/mips
+@dirrm %%DATADIR%%/%%PORTVERSION%%/arch/power
+@dirrm %%DATADIR%%/%%PORTVERSION%%/arch
+@dirrm %%DATADIR%%/%%PORTVERSION%%
+@dirrm %%DATADIR%%
+@dirrm include/gforth/%%PORTVERSION%%
+@dirrm include/gforth
+@dirrm lib/gforth/site-forth
+@dirrm lib/gforth/%%PORTVERSION%%/libcc-named
+@dirrm lib/gforth/%%PORTVERSION%%
+@dirrm lib/gforth