aboutsummaryrefslogtreecommitdiff
path: root/lang/ghc
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2020-07-04 21:37:19 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2020-07-04 21:37:19 +0000
commit35cbe487f82dbde45f5f43040bf561fe2c70e80f (patch)
tree9bae226551a3395c99882c3c41164ee9127d9be2 /lang/ghc
parent9e47f56284a6422761554a07844e6e18978a7ef6 (diff)
downloadports-35cbe487f82dbde45f5f43040bf561fe2c70e80f.tar.gz
ports-35cbe487f82dbde45f5f43040bf561fe2c70e80f.zip
lang/ghc: Don't hardcode libffi shlib version
Don't hardcode the libffi shared library version in lang/ghc makefile. This fixes the build after devel/libffi was updated. This was missed in r541232 PR: 247028 (for tracking)
Notes
Notes: svn path=/head/; revision=541237
Diffstat (limited to 'lang/ghc')
-rw-r--r--lang/ghc/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 3dd8cbe057f2..6675b56ce18f 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ghc
PORTVERSION= ${GHC_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang haskell
MASTER_SITES= https://www.haskell.org/ghc/dist/${PORTVERSION}/:source \
LOCAL/arrowd/:boot \
@@ -56,7 +56,7 @@ DYNAMIC_CONFIGURE_WITH= system-libffi \
ffi-includes=${LOCALBASE}/include \
ffi-libraries=${LOCALBASE}/lib
# The version number is needed as lang/gcc installs a different version
-DYNAMIC_LIB_DEPENDS= libffi.so.6:devel/libffi
+DYNAMIC_LIB_DEPENDS= libffi.so:devel/libffi
DYNAMIC_SUB_LIST= WITH_DYNAMIC="YES"
DYNAMIC_SUB_LIST_OFF= WITH_DYNAMIC="NO"